Bug 1625187 - After doing the Emoji selection by mouse from the emoji category list, the same list does not invoke again.
Summary: After doing the Emoji selection by mouse from the emoji category list, the sa...
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: ibus   
(Show other bugs)
Version: 29
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: fujiwara
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 1625696 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-09-04 10:54 UTC by Bhushan Barve
Modified: 2018-09-23 18:29 UTC (History)
5 users (show)

Fixed In Version: ibus-1.5.19-4.fc29
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-09-23 18:29:41 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Bhushan Barve 2018-09-04 10:54:38 UTC
Description of problem: Tried to select an Emoji using mouse from the emoji category list window. After that, tried to invoke the same window again using ctrl + shift + e. However, was not able to invoke it. Had to reboot. This works fine with keyboard selection.


Version-Release number of selected component (if applicable):
F29 workstation
ibus-1.5.19-3.fc29.x86_64

How reproducible:
always

Steps to Reproduce:
1. Launch gedit
2. press ctrl-shift-e
3. press space
4. From the emoji category list, select any emoji by mouse
5. press space to commit the emoji symbol

Actual results:
When ctrl-shift-e is pressed again, the emoji category list window does not invoke.

Expected results:
The emoji category list window should invoke properly.

Additional info:

Comment 1 Mike FABIAN 2018-09-04 11:38:36 UTC
I see  the same problem, also when selecting the emoji using the keyboard only and not using the mouse. 

I did this:

- Type Ctrl-Shift-e Space to open the emoji category list
- Type Space again to go the "people" category
- Type Return to open  the "people" category
- Type Return again to select the first smiley in that category
  I don’t yet get that smiley inserted into  gedit, I still see the underlined "e"
  at this moment
- Type space again
    The smiley appears in the application (I am using gedit)

- Repeat the above steps.

  Usually after the second time I do this, Ctrl-Shift-e stops working
  and I cannot input emoji anymore.

Comment 2 fujiwara 2018-09-14 07:18:51 UTC
*** Bug 1625696 has been marked as a duplicate of this bug. ***

Comment 3 fujiwara 2018-09-14 07:30:46 UTC
(In reply to Bhushan Barve from comment #0)
> Description of problem: Tried to select an Emoji using mouse from the emoji
> category list window. After that, tried to invoke the same window again
> using ctrl + shift + e. However, was not able to invoke it. Had to reboot.
> This works fine with keyboard selection.

This is caused because gnome-shell does not send focus-in event to ibus-extension-gtk3 because ibus emojier expects focus-en event and terminates ctrl-shift-e feature.
But the ibus implementation causes this bug and now I changed it and ibus terminates ctrl-shift-e feature immediately when an emoji is chosen whether focus-in event comes or not.

https://github.com/ibus/ibus/commit/1c6565e205528a45e88a84ba2a328f9035875c8d


(In reply to Mike FABIAN from comment #1)
> I see  the same problem, also when selecting the emoji using the keyboard
> only and not using the mouse. 

This includes three issues actually.

> 
> I did this:
> 
> - Type Ctrl-Shift-e Space to open the emoji category list
> - Type Space again to go the "people" category
> - Type Return to open  the "people" category
> - Type Return again to select the first smiley in that category
>   I don’t yet get that smiley inserted into  gedit, I still see the
> underlined "e"

This is caused because gnome-shell does not send focus-in event and it's filed as https://gitlab.gnome.org/GNOME/gnome-shell/issues/573 .

If you cannot cancel "e" with Escape key, it's caused because gnome-shell does not implement HidePreedit feature and it's filed as https://gitlab.gnome.org/GNOME/gnome-shell/issues/431 .

>   at this moment
> - Type space again
>     The smiley appears in the application (I am using gedit)

After you type anything, focus-in event comes and the emoji is output but the wrong order causes SEGV.

Comment 4 Fedora Update System 2018-09-14 09:32:23 UTC
ibus-1.5.19-4.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2018-cc4521487d

Comment 5 Fedora Update System 2018-09-14 20:01:03 UTC
ibus-1.5.19-4.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-cc4521487d

Comment 6 Fedora Update System 2018-09-23 18:29:41 UTC
ibus-1.5.19-4.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.