Bug 1625252 - After inserting emoticon via gedit context menu, not able to input text other than en_US
Summary: After inserting emoticon via gedit context menu, not able to input text other...
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: ibus-m17n   
(Show other bugs)
Version: 29
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Mike FABIAN
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: i18n
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-09-04 13:27 UTC by Krishna Babu K
Modified: 2018-12-11 09:08 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-12-11 09:08:35 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
reference .gif to reproduce the issue (151.02 KB, image/gif)
2018-09-04 13:27 UTC, Krishna Babu K
no flags Details
Not able to reproduce reported issue. (345.76 KB, application/octet-stream)
2018-11-20 13:09 UTC, Krishna Babu K
no flags Details

Description Krishna Babu K 2018-09-04 13:27:24 UTC
Created attachment 1480778 [details]
reference .gif to reproduce the issue

Description of problem:
 After inserting emoticon via "gedit->rightclick->Insert Emoji", not able to input text other than en_US.

Version-Release number of selected component (if applicable):

ibus-1.5.19-2.fc29.x86_64
ibus-m17n-1.3.4-27.fc29.x86_64
gedit-3.29.90-1.fc29.x86_64

How reproducible:

Always

Steps to Reproduce:
1. Open gedit, Ctrl+Shift+e, type smile and select emoticon.
2. Try to input text using multiple input methods. (e.g. en_US, te_IN, hi_IN, input is working fine.
3. Now in the next line, select 'Right click -> Insert Emoji -> emoticon'.
4. Try to input text using multiple input methods, only able to input en_US.

Actual results:
 Not able to input using multiple input methods when used emoticon via "gedit->rightclick->Insert Emoji"

Expected results:
Input should work fine.

Additional info:
Not sure about the component and hence choose ibus-m17n

insert-emoji.gif attached.

Comment 1 Mike FABIAN 2018-10-19 16:21:52 UTC
I cannot reproduce this in Gnome Wayland using a Fedora-Workstation-netinst-x86_64-29-20181008.n.0.iso installation.

Comment 2 Jens Petersen 2018-11-17 05:30:50 UTC
Krishna, this only affects ibus-m17n?

Comment 3 Mike FABIAN 2018-11-20 06:15:29 UTC
I still cannot reproduce this, neither in Gnome Wayland  nor in Gnome Xorg.

Comment 4 Krishna Babu K 2018-11-20 13:09 UTC
Created attachment 1507412 [details]
Not able to reproduce reported issue.

Hi,
I am not able to reproduce this any more.
Thanks,
Krishna.


Note You need to log in before you can comment on or make changes to this bug.