Bug 1625253 - gnome-shell on wayland might crash when moving bookmark in nautilus
Summary: gnome-shell on wayland might crash when moving bookmark in nautilus
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: mutter
Version: 29
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Florian Müllner
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker
Depends On:
Blocks: F29FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2018-09-04 13:28 UTC by František Zatloukal
Modified: 2018-10-10 17:40 UTC (History)
9 users (show)

Fixed In Version: mutter-3.30.1-1.fc29
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-10-10 17:40:31 UTC
Type: Bug


Attachments (Terms of Use)
meta_wayland_surface_drag_dest_focus_out (7.79 KB, text/plain)
2018-09-04 13:31 UTC, František Zatloukal
no flags Details


Links
System ID Private Priority Status Summary Last Updated
GNOME Gitlab https://gitlab.gnome.org/GNOME/mutter/issues/336 0 None None None 2018-10-07 16:52:43 UTC

Description František Zatloukal 2018-09-04 13:28:24 UTC
Version-Release number of selected component (if applicable):
gnome-shell-3.29.91-1.fc29.x86_64
mutter-3.29.91-1.fc29.x86_64
nautilus-3.28.1-2.fc29.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Create few bookmarks in Nautilus
2. Drag one of them and hover with it over "Other Locations" section

Actual results:
As soon as you hover over "Other Locations", entire session crashes, bringing you to the login screen.

Expected results:
Gnome Shell shouldn't crash.

Additional info:
Crash happens only on Wayland, everything is fine on Xorg.

Process 2721 (gnome-shell) of user 1000 dumped core.

Stack trace of thread 2721:
#0  0x00007f50ee2de120 meta_wayland_surface_drag_dest_focus_out (libmut>
#1  0x00007f50ee2cf2b3 meta_wayland_drag_grab_set_focus (libmutter-3.so>
#2  0x00007f50ee2d32f4 n/a (libmutter-3.so.0)
#3  0x00007f50eb5c7856 n/a (libwayland-server.so.0)
#4  0x00007f50eb5c78c2 wl_resource_destroy (libwayland-server.so.0)
#5  0x00007f50ed5d0ace ffi_call_unix64 (libffi.so.6)
#6  0x00007f50ed5d048f ffi_call (libffi.so.6)
#7  0x00007f50eb5cb30d n/a (libwayland-server.so.0)
#8  0x00007f50eb5c7c69 n/a (libwayland-server.so.0)
#9  0x00007f50eb5c92e2 wl_event_loop_dispatch (libwayland-server.so.0)
#10 0x00007f50ee2c761b n/a (libmutter-3.so.0)
#11 0x00007f50eee5e2ad g_main_context_dispatch (libglib-2.0.so.0)
#12 0x00007f50eee5e678 n/a (libglib-2.0.so.0)
#13 0x00007f50eee5e9a2 g_main_loop_run (libglib-2.0.so.0)
#14 0x00007f50ee28df00 meta_run (libmutter-3.so.0)
#15 0x000055bee90adb96 n/a (gnome-shell)
#16 0x00007f50ee008413 __libc_start_main (libc.so.6)
#17 0x000055bee90adcee n/a (gnome-shell)

Stack trace of thread 2723:
#0  0x00007f50ee0d6301 __poll (libc.so.6)
#1  0x00007f50eee5e5e6 n/a (libglib-2.0.so.0)
#2  0x00007f50eee5e710 g_main_context_iteration (libglib-2.0.so.0)
#3  0x00007f50eee5e761 n/a (libglib-2.0.so.0)
#4  0x00007f50eee876ea n/a (libglib-2.0.so.0)
#5  0x00007f50ee1b258e start_thread (libpthread.so.0)
#6  0x00007f50ee0e1513 __clone (libc.so.6)

Stack trace of thread 2724:
#0  0x00007f50ee0d6301 __poll (libc.so.6)
#1  0x00007f50eee5e5e6 n/a (libglib-2.0.so.0)
#2  0x00007f50eee5e9a2 g_main_loop_run (libglib-2.0.so.0)
#3  0x00007f50ef05e90a n/a (libgio-2.0.so.0)
#4  0x00007f50eee876ea n/a (libglib-2.0.so.0)
#5  0x00007f50ee1b258e start_thread (libpthread.so.0)
#6  0x00007f50ee0e1513 __clone (libc.so.6)

Stack trace of thread 2760:
#0  0x00007f50ee1b867c pthread_cond_wait@@GLIBC_2.3.2 (libpthread.so.0)
#1  0x00007f50eba999c8 _ZN2js17ConditionVariable4waitERNS_9LockGuardINS>
#2  0x00007f50eba99c85 _ZN2js17ConditionVariable8wait_forERNS_9LockGuar>
#3  0x00007f50ebe850b0 _ZN2js12HelperThread10threadLoopEv (libmozjs-52.>
#4  0x00007f50ebea6046 _ZN2js6detail16ThreadTrampolineIRFvPvEJPNS_12Hel>
#5  0x00007f50ee1b258e start_thread (libpthread.so.0)
#6  0x00007f50ee0e1513 __clone (libc.so.6)

Stack trace of thread 2764:
#0  0x00007f50ee1b867c pthread_cond_wait@@GLIBC_2.3.2 (libpthread.so.0)
#1  0x00007f50eba999c8 _ZN2js17ConditionVariable4waitERNS_9LockGuardINS>
#2  0x00007f50eba99c85 _ZN2js17ConditionVariable8wait_forERNS_9LockGuar>
#3  0x00007f50ebe850b0 _ZN2js12HelperThread10threadLoopEv (libmozjs-52.>
#4  0x00007f50ebea6046 _ZN2js6detail16ThreadTrampolineIRFvPvEJPNS_12Hel>
#5  0x00007f50ee1b258e start_thread (libpthread.so.0)
#6  0x00007f50ee0e1513 __clone (libc.so.6)

Stack trace of thread 2767:
#0  0x00007f50ee1b867c pthread_cond_wait@@GLIBC_2.3.2 (libpthread.so.0)
#1  0x00007f50eba999c8 _ZN2js17ConditionVariable4waitERNS_9LockGuardINS>
#2  0x00007f50eba99c85 _ZN2js17ConditionVariable8wait_forERNS_9LockGuar>
#3  0x00007f50ebe850b0 _ZN2js12HelperThread10threadLoopEv (libmozjs-52.>
#4  0x00007f50ebea6046 _ZN2js6detail16ThreadTrampolineIRFvPvEJPNS_12Hel>
#5  0x00007f50ee1b258e start_thread (libpthread.so.0)
#6  0x00007f50ee0e1513 __clone (libc.so.6)

Stack trace of thread 2761:
#0  0x00007f50ee1b867c pthread_cond_wait@@GLIBC_2.3.2 (libpthread.so.0)
#1  0x00007f50eba999c8 _ZN2js17ConditionVariable4waitERNS_9LockGuardINS>
#2  0x00007f50eba99c85 _ZN2js17ConditionVariable8wait_forERNS_9LockGuar>
#3  0x00007f50ebe850b0 _ZN2js12HelperThread10threadLoopEv (libmozjs-52.>
#4  0x00007f50ebea6046 _ZN2js6detail16ThreadTrampolineIRFvPvEJPNS_12Hel>
#5  0x00007f50ee1b258e start_thread (libpthread.so.0)
#6  0x00007f50ee0e1513 __clone (libc.so.6)

Stack trace of thread 2766:
#0  0x00007f50ee1b867c pthread_cond_wait@@GLIBC_2.3.2 (libpthread.so.0)
#1  0x00007f50eba999c8 _ZN2js17ConditionVariable4waitERNS_9LockGuardINS>
#2  0x00007f50eba99c85 _ZN2js17ConditionVariable8wait_forERNS_9LockGuar>
#3  0x00007f50ebe850b0 _ZN2js12HelperThread10threadLoopEv (libmozjs-52.>
#4  0x00007f50ebea6046 _ZN2js6detail16ThreadTrampolineIRFvPvEJPNS_12Hel>
#5  0x00007f50ee1b258e start_thread (libpthread.so.0)
#6  0x00007f50ee0e1513 __clone (libc.so.6)

Stack trace of thread 2765:
#0  0x00007f50ee1b867c pthread_cond_wait@@GLIBC_2.3.2 (libpthread.so.0)
#1  0x00007f50eba999c8 _ZN2js17ConditionVariable4waitERNS_9LockGuardINS>
#2  0x00007f50eba99c85 _ZN2js17ConditionVariable8wait_forERNS_9LockGuar>
#3  0x00007f50ebe850b0 _ZN2js12HelperThread10threadLoopEv (libmozjs-52.>
#4  0x00007f50ebea6046 _ZN2js6detail16ThreadTrampolineIRFvPvEJPNS_12Hel>
#5  0x00007f50ee1b258e start_thread (libpthread.so.0)
#6  0x00007f50ee0e1513 __clone (libc.so.6)

Stack trace of thread 2763:
#0  0x00007f50ee1b867c pthread_cond_wait@@GLIBC_2.3.2 (libpthread.so.0)
#1  0x00007f50eba999c8 _ZN2js17ConditionVariable4waitERNS_9LockGuardINS>
#2  0x00007f50eba99c85 _ZN2js17ConditionVariable8wait_forERNS_9LockGuar>
#3  0x00007f50ebe850b0 _ZN2js12HelperThread10threadLoopEv (libmozjs-52.>
#4  0x00007f50ebea6046 _ZN2js6detail16ThreadTrampolineIRFvPvEJPNS_12Hel>
#5  0x00007f50ee1b258e start_thread (libpthread.so.0)
#6  0x00007f50ee0e1513 __clone (libc.so.6)

Stack trace of thread 2762:
#0  0x00007f50ee1b867c pthread_cond_wait@@GLIBC_2.3.2 (libpthread.so.0)
#1  0x00007f50eba999c8 _ZN2js17ConditionVariable4waitERNS_9LockGuardINS>
#2  0x00007f50eba99c85 _ZN2js17ConditionVariable8wait_forERNS_9LockGuar>
#3  0x00007f50ebe850b0 _ZN2js12HelperThread10threadLoopEv (libmozjs-52.>
#4  0x00007f50ebea6046 _ZN2js6detail16ThreadTrampolineIRFvPvEJPNS_12Hel>
#5  0x00007f50ee1b258e start_thread (libpthread.so.0)
#6  0x00007f50ee0e1513 __clone (libc.so.6)

Stack trace of thread 2759:
#0  0x00007f50ee0d6301 __poll (libc.so.6)
#1  0x00007f50e8290675 poll_func (libpulse.so.0)
#2  0x00007f50e8281c58 pa_mainloop_poll (libpulse.so.0)
#3  0x00007f50e82822a2 pa_mainloop_iterate (libpulse.so.0)
#4  0x00007f50e8282350 pa_mainloop_run (libpulse.so.0)
#5  0x00007f50e82905bd thread (libpulse.so.0)
#6  0x00007f50e822d06c internal_thread_func (libpulsecommon-12.2.so)
#7  0x00007f50ee1b258e start_thread (libpthread.so.0)
#8  0x00007f50ee0e1513 __clone (libc.so.6)

Stack trace of thread 2726:
#0  0x00007f50ee0d6301 __poll (libc.so.6)
#1  0x00007f50eee5e5e6 n/a (libglib-2.0.so.0)
#2  0x00007f50eee5e710 g_main_context_iteration (libglib-2.0.so.0)
#3  0x00007f50ef14a60d n/a (libdconfsettings.so)
#4  0x00007f50eee876ea n/a (libglib-2.0.so.0)
#5  0x00007f50ee1b258e start_thread (libpthread.so.0)
#6  0x00007f50ee0e1513 __clone (libc.so.6)

Comment 1 František Zatloukal 2018-09-04 13:31:50 UTC
Created attachment 1480779 [details]
meta_wayland_surface_drag_dest_focus_out

Comment 2 František Zatloukal 2018-09-04 13:32:21 UTC
I've added uncut log as an attachment, sorry for the noise.

Comment 3 Fedora Blocker Bugs Application 2018-09-04 14:03:57 UTC
Proposed as a Blocker for 29-beta by Fedora user frantisekz using the blocker tracking app because:

 Can't find the right criterion atm, but I think if there is something this easily reproducible on any HW causing entire session to crash... it should be a blocker :)

Comment 4 Geoffrey Marr 2018-09-04 20:09:39 UTC
Discussed during the 2018-09-04 blocker review meeting: [1]

The decision to classify this bug as an "AcceptedBlocker" (Final) and AcceptedFreezeException (Beta) was made as it violates the following criteria:

"All applications that can be launched using the standard graphical mechanism of a release-blocking desktop after a default installation of that desktop must start successfully and withstand a basic functionality test."

Also accepted as Beta FE as a major bug in GNOME that should be fixed in the live images.

[1] https://meetbot-raw.fedoraproject.org/fedora-blocker-review/2018-09-04/f29-blocker-review.2018-09-04-16.01.txt

Comment 6 Adam Williamson 2018-10-08 18:04:17 UTC
The MR is merged now, so the pending gnome-shell / mutter release and update should fix this.

Comment 7 Fedora Update System 2018-10-08 21:47:13 UTC
mutter-3.30.1-1.fc29 gnome-shell-extensions-3.30.1-1.fc29 gnome-shell-3.30.1-1.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2018-9e1f9f945d

Comment 8 Fedora Update System 2018-10-09 05:13:10 UTC
gnome-shell-3.30.1-1.fc29, gnome-shell-extensions-3.30.1-1.fc29, mutter-3.30.1-1.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-9e1f9f945d

Comment 9 Kamil Páral 2018-10-09 11:51:01 UTC
Frantisek, can you please test this? Thanks.

Comment 10 Fedora Update System 2018-10-10 17:40:31 UTC
gnome-shell-3.30.1-1.fc29, gnome-shell-extensions-3.30.1-1.fc29, mutter-3.30.1-1.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.