Bug 1625269 - The Region and Languages section displays in a very small window and therefore is difficult to use.
Summary: The Region and Languages section displays in a very small window and therefor...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-control-center
Version: 29
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Pete Walter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedFreezeException AcceptedBlocker
Depends On:
Blocks: F29BetaFreezeException F29FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2018-09-04 14:06 UTC by Lukas Ruzicka
Modified: 2018-10-09 11:53 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-10-09 11:53:23 UTC


Attachments (Terms of Use)
Journal logs (25.95 KB, text/plain)
2018-09-04 14:06 UTC, Lukas Ruzicka
no flags Details
Installed packages (52.00 KB, text/plain)
2018-09-04 14:07 UTC, Lukas Ruzicka
no flags Details
Situation when RandL are selected. (46.11 KB, image/png)
2018-09-04 14:08 UTC, Lukas Ruzicka
no flags Details
After clicking on dots. (47.02 KB, image/png)
2018-09-04 14:08 UTC, Lukas Ruzicka
no flags Details
After clicking on Other. (47.61 KB, image/png)
2018-09-04 14:10 UTC, Lukas Ruzicka
no flags Details
When resized. (60.81 KB, image/png)
2018-09-04 14:10 UTC, Lukas Ruzicka
no flags Details

Description Lukas Ruzicka 2018-09-04 14:06:53 UTC
Created attachment 1480790 [details]
Journal logs

Description of problem:

When running gnome-control-center, the Region and Languages settings are displayed in a very small window. Moreover, no options are available to choose from. The user only can click on the three dots. Clicking on them also does not provide a list of options, only an "Other" button is displayed. After clicking on Other, I am available to reach the list of available languages, however, I am not sure whether I can see all languages or just "Other" languages.
Also, I have to resize the window to get a usable list.

Version-Release number of selected component (if applicable):

gnome-shell-3.29.91-1.fc29.x86_64
gnome-control-center-3.29.90-1.fc29.x86_64
using Wayland

How reproducible:

Always

Steps to Reproduce:
1. Run gnome-control-center
2. Select Region and Languages
3. See for yourself.
4. Click on three dots
5. Click on others
6. Resize

Actual results:

The UI is very user unfriendly with this behaviour.

Expected results:

Bring back the behaviour of previous versions, where there was a list of languages available right away from the start.

Additional info:

See the attachments.

Comment 1 Lukas Ruzicka 2018-09-04 14:07:30 UTC
Created attachment 1480791 [details]
Installed packages

Comment 2 Lukas Ruzicka 2018-09-04 14:08:22 UTC
Created attachment 1480792 [details]
Situation when RandL are selected.

Comment 3 Lukas Ruzicka 2018-09-04 14:08:55 UTC
Created attachment 1480793 [details]
After clicking on dots.

Comment 4 Lukas Ruzicka 2018-09-04 14:10:19 UTC
Created attachment 1480794 [details]
After clicking on Other.

Comment 5 Lukas Ruzicka 2018-09-04 14:10:51 UTC
Created attachment 1480795 [details]
When resized.

Comment 6 Fedora Blocker Bugs Application 2018-09-04 14:14:13 UTC
Proposed as a Blocker and Freeze Exception for 29-beta by Fedora user lruzicka using the blocker tracking app because:

 I am not sure whether a Blocker or a FE, I want to leave to a discussion for BB meeting. 
In my opinion, this bug violates the basic functionality:

Basic functionality means that the app must at least be broadly capable of its most basic expected operations, and that it must not crash without user intervention or with only basic user intervention.

Comment 7 Geoffrey Marr 2018-09-04 20:05:03 UTC
Discussed during the 2018-09-04 blocker review meeting: [1]

The decision to classify this bug as an "AcceptedBlocker" (Final) and AcceptedFreezeException (Beta) was made as it violates the following criteria:

"All applications that can be launched using the standard graphical mechanism of a release-blocking desktop after a default installation of that desktop must start successfully and withstand a basic functionality test."

Also accepted as Beta FE as a major bug in GNOME that should be fixed in the live images.

[1] https://meetbot-raw.fedoraproject.org/fedora-blocker-review/2018-09-04/f29-blocker-review.2018-09-04-16.01.txt

Comment 8 Joachim Frieben 2018-09-08 09:09:04 UTC
(In reply to Lukas Ruzicka from comment #0)
After resizing the language list, it looks likely that all languages are actually  available; just scroll downward to verify that languages like "English (UK)", "English (US)", or "German" are well present.

Comment 9 Lukas Ruzicka 2018-09-11 09:26:15 UTC
(In reply to Joachim Frieben from comment #8)

Yes, the languages are there, but I still believe that this is erroneous behaviour.

Comment 10 Jens Petersen 2018-09-27 04:38:20 UTC
This has been fixed for a while now I think?

Comment 11 Adam Williamson 2018-10-08 17:57:05 UTC
lruzicka, can you please confirm or deny?

Comment 12 Kamil Páral 2018-10-09 11:53:23 UTC
This is now working as intended with gnome-control-center-3.30.0-1.fc29.x86_64


Note You need to log in before you can comment on or make changes to this bug.