Bug 162540 - [patch] Proposed changes to {find-and-,}aot-compile
[patch] Proposed changes to {find-and-,}aot-compile
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: java-1.4.2-gcj-compat (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Thomas Fitzsimmons
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-05 18:35 EDT by Robin Green
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-03 05:10:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch (3.80 KB, patch)
2005-07-05 18:35 EDT, Robin Green
no flags Details | Diff

  None (edit)
Description Robin Green 2005-07-05 18:35:40 EDT
This patch adds a bunch of (incompatible) changes to /usr/bin/aot-compile
(changes by Gary Benson) and to /usr/bin/find-and-aot-compile (changes by me).
It has been discussed previously on the fedora-java list and I've updated it
according to criticisms made.

Version-Release number of selected component (if applicable):
java-1.4.2-gcj-compat-1.4.2.0-40jpp_31rh

It makes the following changes:

aot-compile:
- Allow compiling multiple jars in a single call
- Swap order of options and jars, to be consistent with gcj and most other Linux
software
- Automatically generate destination .so names

find-and-aot-compile:
- Adds options --libdir and --skiptar (see usage in script)
- Moves generated .so file
- Registered generated .so files in a gcj-dbtool .db file (created by merging
individual .db files for each .jar/.so pair)

In summary, it makes AOT compilation simpler (because the gcj-dbtool stuff is
done automatically) and more efficient (because you can skip the .tar file
creation, which I don't really see the point of, to be honest).
Comment 1 Robin Green 2005-07-05 18:35:40 EDT
Created attachment 116389 [details]
patch
Comment 2 Thomas Fitzsimmons 2005-10-01 17:26:26 EDT
Gary, can you confirm that the current aot-compile-rpm incorporates all these
changes?  I'd like to close this one, if possible.
Comment 3 Gary Benson 2005-10-03 05:10:47 EDT
It either incorporates them or makes them unnecessary.

Note You need to log in before you can comment on or make changes to this bug.