Bug 1625520 - Undercloud - allow enabling routed_networks on undercloud upgrade
Summary: Undercloud - allow enabling routed_networks on undercloud upgrade
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 15.0 (Stein)
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: Upstream M1
: 15.0 (Stein)
Assignee: Harald Jensås
QA Contact: Alexander Chuzhoy
URL:
Whiteboard:
Depends On: 1626357
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-09-05 06:53 UTC by Harald Jensås
Modified: 2019-09-26 10:46 UTC (History)
5 users (show)

Fixed In Version: openstack-tripleo-heat-templates-10.5.1-0.20190506170359.f08bfef.el8ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-09-21 11:18:54 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
OpenStack gerrit 601369 0 'None' MERGED Allow enabling routed networks on undercloud update|upgrade 2020-10-08 11:00:48 UTC
Red Hat Product Errata RHEA-2019:2811 0 None None None 2019-09-21 11:19:12 UTC

Description Harald Jensås 2018-09-05 06:53:21 UTC
Description of problem:
-----------------------

When deploying the undercloud support for routed networks must be enabled using the enable_routed_networks option in undercloud.conf. If the option is set to False (the default) it is not possible to change it to True and re-run undercloud installer to enable support for routed networks.

Prior to Rocky it had to be like this because neutron did not support migrating a non-routed network to a routed network.

How reproducible:
-----------------

Easy

Steps to Reproduce:
-------------------

1. Deploy undercloud with `ènable_routed_networks = False`
2. Change to `enable_routed_networks = True" and re-run undercloud installer

Actual results:
---------------

Only the `local_subnet` is created.
Additional segments and subnets are not created.
The subnet does not have association with a segment.

Expected results:
-----------------

 * All subnets defined in undercloud.conf should be created.
 * All ctlplane segments defined in undercloud.conf should be created.
 * All ctlplane subnets defined in undercloud.conf should be created.
 * All ctlplane subnets should be associated to segments.

Additional info:
----------------

Once routed networks is enabled, it cannot be disable.

Comment 5 errata-xmlrpc 2019-09-21 11:18:54 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2019:2811


Note You need to log in before you can comment on or make changes to this bug.