Bug 1625551 - [Wayland] ibus-typing-booster broken
Summary: [Wayland] ibus-typing-booster broken
Keywords:
Status: CLOSED DUPLICATE of bug 1625142
Alias: None
Product: Fedora
Classification: Fedora
Component: ibus-typing-booster
Version: 29
Hardware: All
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Mike FABIAN
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-09-05 08:09 UTC by Bhushan Barve
Modified: 2018-09-11 11:09 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-09-11 11:09:42 UTC


Attachments (Terms of Use)

Description Bhushan Barve 2018-09-05 08:09:54 UTC
Description of problem: Installed f29 in fr_FR. Default session is gnome-wayland

[cedille@localhost ~]$ loginctl show-session 2
Id=2
User=1000
Name=cedille
Timestamp=Wed 2018-09-05 12:45:02 IST
TimestampMonotonic=90671074
VTNr=2
Seat=seat0
TTY=tty2
Remote=no
Service=gdm-password
Scope=session-2.scope
Leader=1324
Audit=2
Type=wayland
Class=user
Active=yes
State=active
IdleHint=no
IdleSinceHint=0
IdleSinceHintMonotonic=0
LockedHint=no

Tried to input using ibus-typing-booster in evolution mail compose window. However was not able to do it. When typed some input and hit enter to commit the same, it was not getting entered. Same case observed with CJK input too.

Following info was shown in gnome-terminal -

** (WebKitWebProcess:2199): CRITICAL **: 12:48:59.788: WebKitDOMNode* webkit_dom_node_get_next_sibling(WebKitDOMNode*): assertion 'WEBKIT_DOM_IS_NODE(self)' failed


The same thing works in gnome-classic session.


Version-Release number of selected component (if applicable):
F29
evolution-3.29.92-1.fc29.x86_64
ibus-1.5.19-3.fc29.x86_64


How reproducible:
always

Steps to Reproduce:
1. select input method as ibus-typing-booster or Japanese(kana kanji)
2. try to input in evolution
3.

Actual results:
Not able to commit text in evolution

Expected results:
Should be able to input properly.

Additional info:

Comment 1 Milan Crha 2018-09-05 09:42:22 UTC
Thanks for a bug report. The message body is edited in a WebKitGTK+ widget, which does all/most of the input processing. Could you try the same in Epiphany, eventually in:

   $ /usr/libexec/webkit2gtk-4.0/MiniBrowser --editor-mode

please? In case you do not have the MiniBrowser installed, then it is part of webkit2gtk3-devel package, thus:

   $ sudo dnf install webkit2gtk3-devel

The advantage of using the MiniBrowser is that it avoids any additional input processing, which can be done by other applications using WebKitGTK+.

Comment 2 Bhushan Barve 2018-09-05 10:26:09 UTC
Thanks Milan, yes I was able to input. Got following in the terminal -

[cedille@localhost ~]$ /usr/libexec/webkit2gtk-4.0/MiniBrowser --editor-mode
WaylandCompositor requires eglBindWaylandDisplayWL, eglUnbindWaylandDisplayWL and eglQueryWaylandBuffer.
Nested Wayland compositor could not initialize EGL

(MiniBrowser:20427): GLib-GObject-WARNING **: 15:51:47.305: invalid (NULL) pointer instance

(MiniBrowser:20427): GLib-GObject-CRITICAL **: 15:51:47.305: g_signal_emit_by_name: assertion 'G_TYPE_CHECK_INSTANCE (instance)' failed

Comment 3 Milan Crha 2018-09-05 10:29:28 UTC
(In reply to Bhushan Barve from comment #2)
> yes I was able to input

Okay. Could you give me some more detailed steps what to do, especially what to press and what to run and how, to reproduce this, please? I do not use ibus methods often, the less I know how to work with it and what magic sequences should produce what output. I'm sorry for being such ignorant.

Comment 4 Bhushan Barve 2018-09-05 11:45:40 UTC
(In reply to Milan Crha from comment #3)
> (In reply to Bhushan Barve from comment #2)
> > yes I was able to input
> 
> Okay. Could you give me some more detailed steps what to do, especially what
> to press and what to run and how, to reproduce this, please? I do not use
> ibus methods often, the less I know how to work with it and what magic
> sequences should produce what output. I'm sorry for being such ignorant.

Sure Milan, no issues. It's a simple reproducer with any random input, nothing specific. Please see following steps -

1. From settings -> Region and Languages, select input source as  other (typing booster). Or you can select Japanese (kana kanji) as well.

2. From the input method drop-down in the top right corner, choose typing-booster as your input method.

3. In Evolution, start typing any input in message body like for e.g. 'test'. A candidate window will appear with input suggestions. All you have to do is hit enter key to commit the input. Here the input is not getting committed. 

Please let me know, if you need any more info on this.

Comment 5 Milan Crha 2018-09-05 13:36:05 UTC
Thanks for the steps, I can reproduce it with them too. I tried to reproduce also in Fedora 28, but it works fine there. An interesting issue with the rawhide (I do not have any F29 machine yet) it that it misbehaves also in the Subject header, which is a native GtkEntry widget.

I see a runtime warning in both systems when playing with this:
> (evolution:2952): Gdk-WARNING **: 15:12:53.780: Event with type 8 not holding
> a GdkDevice. It is most likely synthesized outside Gdk/GTK+
which may or may not be related. It seems to be specific to Xorg only and I can reproduce it with the below steps as well.

Anyway, I found out that there are other things broken here. For me, with gtk3-3.23.2-1.fc29.x86_64 and ibus-typing-booster-2.1.0-2.fc30.noarch
I do:
a) run from a terminal: gtk3-demo
b) open: Entry->Entry Buffer
c) switch input method from English to Other (Typing Booster)
d) type: aaa<space>bbb<space>
   where <space> is for a space bar key

Right now the result in the entry demo is: "aaa bbb " (quoted for clarity only).

e) close this entry demo window, but *not* the gtk3-demo main window
f) open Entry->Entry Buffer again
g) repeat step d) (the step c) is not needed, the input method left selected)

And now, the result is: "  ", aka the "aaa" and "bbb" is replaced with the space, instead of the space being used as the word-end-indicator. I can reproduce this also in the MiniBrowser, but the issue as low as in the GtkEntry is more interesting.

I'd suppose from the above that there's something broken lower than in the widgets.

I also see the runtime warnings from comment #2 whenever I close the Entry Buffer window.

Comment 6 fujiwara 2018-09-11 10:18:47 UTC
I think this is duplicated of bug #1625142.

Comment 7 Mike FABIAN 2018-09-11 11:09:42 UTC

*** This bug has been marked as a duplicate of bug 1625142 ***


Note You need to log in before you can comment on or make changes to this bug.