Bug 1625557 - Blacklist multipath for local devices related to HCI Gluster only (allow all other shared storage protocols, like sas)
Summary: Blacklist multipath for local devices related to HCI Gluster only (allow all ...
Keywords:
Status: CLOSED CANTFIX
Alias: None
Product: vdsm
Classification: oVirt
Component: Core
Version: 4.20.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ovirt-4.3.1
: ---
Assignee: Vojtech Juranek
QA Contact: Elad
URL:
Whiteboard:
Depends On:
Blocks: 1627103
TreeView+ depends on / blocked
 
Reported: 2018-09-05 08:36 UTC by Ala Hino
Modified: 2019-02-28 14:48 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1627103 (view as bug list)
Environment:
Last Closed: 2019-02-28 14:48:35 UTC
oVirt Team: Storage
rule-engine: ovirt-4.2+
rule-engine: ovirt-4.3+


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1627095 0 high CLOSED Revert blacklist of multipath for local devices (based on transport protocol) 2021-02-22 00:41:40 UTC
oVirt gerrit 94168 0 master ABANDONED multipath: Blacklist "sas" local devices 2018-10-11 12:24:26 UTC

Internal Links: 1627095

Description Ala Hino 2018-09-05 08:36:38 UTC
Description of problem:
The fix for bug 1016535 added support to blacklist fcp and iscsi devices. The introduced a regression for sas devices.

Version-Release number of selected component (if applicable):
4.20.39

Comment 3 Sandro Bonazzola 2018-09-13 06:36:23 UTC
this is for 4.3.0, 4.2.z is tracked on bug#1627103

Comment 5 Sandro Bonazzola 2019-01-28 09:37:00 UTC
This bug has not been marked as blocker for oVirt 4.3.0.
Since we are releasing it tomorrow, January 29th, this bug has been re-targeted to 4.3.1.

Comment 6 Tal Nisan 2019-02-28 14:48:35 UTC
closing this bug as we could not come up with a blacklist filter that will be restrictive enough for the purpose of this bug and permissive enough not to cause problems in working setups, this should be fixed individually in each setup according to the specific needs


Note You need to log in before you can comment on or make changes to this bug.