Bug 162573 - Maya crashed with SIGSEGV in FC4 with I855GM Graphics
Maya crashed with SIGSEGV in FC4 with I855GM Graphics
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
4
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-06 09:47 EDT by Somsak Sriprayoonsakul
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-14 04:41:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Debugging message (from GDB) (7.16 KB, text/plain)
2005-07-06 09:48 EDT, Somsak Sriprayoonsakul
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 3076 None None None Never

  None (edit)
Description Somsak Sriprayoonsakul 2005-07-06 09:47:00 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
I tried to run Maya 6.0.1 on my system The installation goes fine, but when I run "maya" command. The program show Logo and licensing information, then crashed with SIGSEGV. I tried to run maya in debug mode (maya -d gdb) and there're two failure occured

1. SIGFPE sent when function _mesa_test_os_sse_exception_support was called, this also happened with glxgear demo comes with xorg-x11, somehow I could ignore it and continue the debugger

2. SIGSEGV occured in __driGarbageCollectDrawables (), called from driCreateNewContext(). 

As I googling through the web. There's a blog at http://translate.google.com/translate?hl=en&sl=it&u=http://www.adamantio.net/article359.html&prev=/search%3Fq%3Dmaya%2Bfedora%2Bcore%2B4%26hl%3Den%26lr%3D%26sa%3DG.
said that he can run Maya in FC4 (using NVIDIA?). So I supposed that this is the problem only on my system. Also I'm familiar with bug 161242 which effect Intel graphics chipset so I thought that this might be another variant of the bug.

Here's my system information
Notebook: Dell Latitude D500
Memory: 768MB
Graphics: I855GM Chipset
Xorg driver: i810
xdriinfo returned "Screen 0: i915"


Version-Release number of selected component (if applicable):
xorg-x11-6.8.2-37, Maya6_0-6.0.1-69

How reproducible:
Always

Steps to Reproduce:
1. Install maya 6.0.1
2. Run it (/usr/aw/maya/bin/maya), Alias Wavefront logo pop-up
3. Crashed
  

Actual Results:  Crashed

Expected Results:  At least GUI should pop-up. But only Logo pop-up and crashed

Additional info:
Comment 1 Somsak Sriprayoonsakul 2005-07-06 09:48:18 EDT
Created attachment 116409 [details]
Debugging message (from GDB)

This is debugging message from "maya -d gdb"
Comment 2 Mike A. Harris 2005-08-30 07:27:17 EDT
Please report this issue to X.Org developers by filing a bug report in
the X.Org bugzilla located at http://bugs.freedesktop.org in the "xorg"
component.

Once you've filed your bug report to X.Org, if you paste the new
bug URL here, Red Hat will continue to track the issue in the
centralized X.Org bug tracker, and will review any bug fixes that
become available for consideration in future updates.

Setting status to "NEEDINFO_REPORTER", awaiting X.Org bug URL for tracking.
Comment 3 Somsak Sriprayoonsakul 2005-08-30 07:44:34 EDT
I found that similar bug has been posted to 

https://bugs.freedesktop.org/show_bug.cgi?id=3076

This should be the same bug. Somehow I don't sure whether Intel has proprietary
DRI driver for I855GM? 
Comment 4 Mike A. Harris 2005-09-14 04:41:09 EDT
Thanks for the upstream bug URL.  Setting status to "UPSTREAM" for tracking
the bug in Xorg bugzilla.

Note You need to log in before you can comment on or make changes to this bug.