Bug 1626012 - SELinux is preventing dhclient from 'read' accesses on the chr_file random.
Summary: SELinux is preventing dhclient from 'read' accesses on the chr_file random.
Keywords:
Status: CLOSED DUPLICATE of bug 1624554
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 29
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Lukas Vrabec
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:f5d862d67315226e1bf649e0499...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-09-06 11:43 UTC by Christian Stadelmann
Modified: 2018-09-07 13:10 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-09-07 13:10:48 UTC
Type: ---


Attachments (Terms of Use)

Description Christian Stadelmann 2018-09-06 11:43:36 UTC
Description of problem:
SELinux is preventing dhclient from 'read' accesses on the chr_file random.

*****  Plugin catchall_boolean (89.3 confidence) suggests   ******************

Sie folgendes tun möchten: allow authlogin to nsswitch use ldap
Then sie müssen SELinux darüber benachrichtigen, indem Sie die 	boolesche Variable »authlogin_nsswitch_use_ldap« aktivieren.

Do
setsebool -P authlogin_nsswitch_use_ldap 1

*****  Plugin catchall (11.6 confidence) suggests   **************************

If you believe that dhclient should be allowed read access on the random chr_file by default.
Then sie sollten dies als Fehler melden.
Um diesen Zugriff zu erlauben, können Sie ein lokales Richtlinien-Modul erstellen.
Do
allow this access for now by executing:
# ausearch -c 'dhclient' --raw | audit2allow -M my-dhclient
# semodule -X 300 -i my-dhclient.pp

Additional Information:
Source Context                system_u:system_r:dhcpc_t:s0
Target Context                system_u:object_r:random_device_t:s0
Target Objects                random [ chr_file ]
Source                        dhclient
Source Path                   dhclient
Port                          <Unbekannt>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    <Unbekannt>
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 4.18.5-300.fc29.x86_64 #1 SMP Fri
                              Aug 24 17:16:35 UTC 2018 x86_64 x86_64
Alert Count                   3
First Seen                    2018-08-29 12:31:27 CEST
Last Seen                     2018-09-05 19:04:12 CEST
Local ID                      68352265-9bf2-4ac4-baca-09f36a77b4c1

Raw Audit Messages
type=AVC msg=audit(1536167052.446:241): avc:  denied  { read } for  pid=1575 comm="dhclient" name="random" dev="devtmpfs" ino=35 scontext=system_u:system_r:dhcpc_t:s0 tcontext=system_u:object_r:random_device_t:s0 tclass=chr_file permissive=0


Hash: dhclient,dhcpc_t,random_device_t,chr_file,read


Additional info:
component:      selinux-policy
reporter:       libreport-2.9.5
hashmarkername: setroubleshoot
kernel:         4.18.5-300.fc29.x86_64
type:           libreport

Potential duplicate: bug 1623170

Comment 1 Lukas Vrabec 2018-09-07 13:10:48 UTC

*** This bug has been marked as a duplicate of bug 1624554 ***


Note You need to log in before you can comment on or make changes to this bug.