Bug 1626061 - qemu blockjobs other than backup do not support job-finalize or job-dismiss
Summary: qemu blockjobs other than backup do not support job-finalize or job-dismiss
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm-rhev
Version: 7.6
Hardware: All
OS: All
high
high
Target Milestone: rc
: ---
Assignee: John Snow
QA Contact: Gu Nini
URL:
Whiteboard:
Depends On:
Blocks: 760547 1632939
TreeView+ depends on / blocked
 
Reported: 2018-09-06 13:37 UTC by John Snow
Modified: 2018-11-01 11:14 UTC (History)
8 users (show)

Fixed In Version: qemu-kvm-rhev-2.12.0-15.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1632939 (view as bug list)
Environment:
Last Closed: 2018-11-01 11:13:32 UTC
Target Upstream Version:


Attachments (Terms of Use)
Test_logs_for_the_block_jobs-withAutoFinalizeDismiss-NewCommands-09142018 (13.03 KB, text/plain)
2018-09-14 11:40 UTC, Gu Nini
no flags Details
Test_logs_for_the_block_jobs-withAutoFinalizeDismiss-OldCommands-09142018 (6.69 KB, text/plain)
2018-09-14 11:40 UTC, Gu Nini
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:3443 None None None 2018-11-01 11:14:44 UTC

Description John Snow 2018-09-06 13:37:09 UTC
Description of problem:

QEMU added job-finalize and job-dismiss for jobs to allow libvirt more explicit control over when and how graphs get manipulated. However, this functionality was only exposed for the backup job.

Libvirt needs this for ALL jobs.

Version-Release number of selected component (if applicable):

2.12.0, 7.6's version


How reproducible:

100%; the options are not present in QAPI

Steps to Reproduce:
1. Try to use auto-dismiss or auto-finalize parameters for the mirror, commit, or stream jobs
2. Weep

Actual results:

Wailing, gnashing of teeth

Expected results:

auto-finalize = false should allow jobs to sit in the PENDING state until the job-finalize command is sent to instruct them to perform their graph changes.

auto-dismiss = false should allow jobs to sit in the CONCLUDED state until they are dismissed with the job-dismiss command, which allows libvirt a chance to query their completion state in case libvirt missed the completion event.

Additional info:

-

Comment 4 Miroslav Rezanina 2018-09-12 13:12:27 UTC
Fix included in qemu-kvm-rhev-2.12.0-15.el7

Comment 6 Gu Nini 2018-09-14 11:40:09 UTC
Created attachment 1483321 [details]
Test_logs_for_the_block_jobs-withAutoFinalizeDismiss-NewCommands-09142018

Verify the bug with both old and new block job related commands.

Comment 7 Gu Nini 2018-09-14 11:40:59 UTC
Created attachment 1483322 [details]
Test_logs_for_the_block_jobs-withAutoFinalizeDismiss-OldCommands-09142018

Comment 8 Gu Nini 2018-09-14 11:42:04 UTC
The qemu version for the verification is qemu-kvm-rhev-2.12.0-15.el7.x86_64.

Comment 9 errata-xmlrpc 2018-11-01 11:13:32 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:3443


Note You need to log in before you can comment on or make changes to this bug.