Bug 1626453 - glusterd2-containers nightly job failing
Summary: glusterd2-containers nightly job failing
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: GlusterFS
Classification: Community
Component: project-infrastructure
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-09-07 11:27 UTC by Kaushal
Modified: 2018-10-01 06:27 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-10-01 02:36:29 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Kaushal 2018-09-07 11:27:55 UTC
The glusterd2-containers has failed every night since the first manually triggered build. [1]

The failure has been with the same error always. [2]

If possible, I'd like to get shell access to the builder to debug the failure.

[1]: https://build.gluster.org/job/glusterd2-containers/buildTimeTrend
[2]: https://build.gluster.org/job/glusterd2-containers/19/console

Comment 1 Nigel Babu 2018-10-01 02:36:29 UTC
Huh, okay, this is weird, so the build has been passing the last couple of days. I have no idea why. But this makes me suspect that a Fedora package was broken for a couple of weeks and it's now fixed.

Comment 2 Nigel Babu 2018-10-01 04:37:17 UTC
Packages updated on 23rd. None of these, as far as I can see should have made a difference for buildah.


cups-libs-2.2.6-23.fc28.x86_64                Sun 23 Sep 2018 02:30:56 PM UTC
kernel-headers-4.18.9-200.fc28.x86_64         Sun 23 Sep 2018 02:30:55 PM UTC
vim-minimal-8.1.408-1.fc28.x86_64             Sun 23 Sep 2018 02:30:54 PM UTC
libmodulemd-1.6.4-1.fc28.x86_64               Sun 23 Sep 2018 02:30:54 PM UTC
kernel-4.18.9-200.fc28.x86_64                 Sun 23 Sep 2018 02:30:54 PM UTC
openssl-devel-1.1.0i-1.fc28.x86_64            Sun 23 Sep 2018 02:30:53 PM UTC
vim-enhanced-8.1.408-1.fc28.x86_64            Sun 23 Sep 2018 02:30:52 PM UTC
NetworkManager-1.10.12-1.fc28.x86_64          Sun 23 Sep 2018 02:30:52 PM UTC
vim-common-8.1.408-1.fc28.x86_64              Sun 23 Sep 2018 02:30:51 PM UTC
NetworkManager-libnm-1.10.12-1.fc28.x86_64    Sun 23 Sep 2018 02:30:51 PM UTC
vim-filesystem-8.1.408-1.fc28.noarch          Sun 23 Sep 2018 02:30:48 PM UTC
openssl-pkcs11-0.4.8-2.fc28.x86_64            Sun 23 Sep 2018 02:30:48 PM UTC
openssl-libs-1.1.0i-1.fc28.x86_64             Sun 23 Sep 2018 02:30:48 PM UTC
openssl-1.1.0i-1.fc28.x86_64                  Sun 23 Sep 2018 02:30:48 PM UTC
kernel-modules-4.18.9-200.fc28.x86_64         Sun 23 Sep 2018 02:30:43 PM UTC
kernel-core-4.18.9-200.fc28.x86_64            Sun 23 Sep 2018 02:30:39 PM UTC

Comment 3 Nigel Babu 2018-10-01 04:58:14 UTC
The mystery of why this failed until today and what changed continues. The uptime is greater than any of these dates. So the kernel changes should not have had an impact.

Comment 4 Amar Tumballi 2018-10-01 05:10:43 UTC
Is it because of glusterfs' fix? https://review.gluster.org/21299

Comment 5 Nigel Babu 2018-10-01 06:27:52 UTC
Nope. The failures were permission errors from buildah. Way before it touched anything glusterfs.


Note You need to log in before you can comment on or make changes to this bug.