Bug 1626540 - Satellite 6.4 BETA repository sync logging is much more verbose [NEEDINFO]
Summary: Satellite 6.4 BETA repository sync logging is much more verbose
Keywords:
Status: CLOSED DUPLICATE of bug 1623937
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Repositories
Version: 6.4
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-09-07 15:12 UTC by Douglas Jones
Modified: 2018-10-17 17:15 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-10-17 17:15:49 UTC
Target Upstream Version:
bbuckingham: needinfo? (dojones)


Attachments (Terms of Use)

Description Douglas Jones 2018-09-07 15:12:44 UTC
Description of problem:
Logging during repository syncs is much more verbose.  Logging level still default of INFO level.  Normal production.log in lab is < 10MB uncompressed.  After 6.3.3 > 6.4.0 BETA update, production.log is ~1GB uncompressed.  Syncing 20 Red Hat repositories and EPEL6 and EPEL7.

Version-Release number of selected component (if applicable):
6.4.0 Public Beta

How reproducible:
Always

Steps to Reproduce:
1. Install Satellite 6.4.0 BETA
2. Configure multiple Red Hat repositories and/or custom products
3. (optional) Create Sync Plan and add all repositories
4. Perform sync

Actual results:
Syncing and /var/log/foreman/production.log verbosity is outputting much more detail even when utilizing INFO level of logging.

Expected results:
Syncing and /var/log/foreman/production.log verbosity to be same as on Satellite 6.3.x.  

Additional info:
Suggest moving some of the metadata and curl output to DEBUG level of logging.

Comment 1 Brad Buckingham 2018-09-10 18:38:40 UTC
This one may be a duplicate; however, can you attach the log output illustrating the verbosity?  Thanks!

Comment 2 Tanya Tereshchenko 2018-09-11 11:49:33 UTC
Changing component.
Pulp doesn't write logs into /var/log/foreman/production.log.

Comment 4 Brad Buckingham 2018-10-17 17:15:49 UTC
I believe this is the same as bug 1623937; therefore, closing as a duplicate.  If that is not the case, please re-open providing an example of the log output.  Thanks!

*** This bug has been marked as a duplicate of bug 1623937 ***


Note You need to log in before you can comment on or make changes to this bug.