Bug 1626610 - [USS]: Change gf_log to gf_msg
Summary: [USS]: Change gf_log to gf_msg
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: snapshot
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-09-07 17:39 UTC by Raghavendra Bhat
Modified: 2019-03-25 16:30 UTC (History)
2 users (show)

Fixed In Version: glusterfs-6.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-11-20 09:28:13 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Gluster.org Gerrit 21497 0 None Merged features/snapview-server: change gf_log instances to gf_msg 2018-11-05 07:05:58 UTC

Description Raghavendra Bhat 2018-09-07 17:39:00 UTC
Description of problem:

While the majority of the gluster code base has moved to gf_msg for logging, uss xlators snapview-client and snapview-server still use the gf_log APIs.

This bug is used to track the effort to move those 2 xlators to start using gf_msg.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Worker Ant 2018-09-19 21:04:52 UTC
REVIEW: https://review.gluster.org/21230 (features/snapview-client: replace gf_log with gf_msg) posted (#1) for review on master by Raghavendra Bhat

Comment 2 Worker Ant 2018-10-10 05:47:02 UTC
COMMIT: https://review.gluster.org/21230 committed in master by "Amar Tumballi" <amarts@redhat.com> with a commit message- features/snapview-client: replace gf_log with gf_msg

Change-Id: I87f01d86f50eb2fca21febb0ea3e77fbd152eb93
updates: bz#1626610
Signed-off-by: Raghavendra Bhat <raghavendra@redhat.com>

Comment 3 Worker Ant 2018-10-25 21:22:59 UTC
REVIEW: https://review.gluster.org/21497 ([WIP]features/snapview-server: change gf_log instances to gf_msg) posted (#1) for review on master by Raghavendra Bhat

Comment 4 Worker Ant 2018-11-05 07:05:57 UTC
REVIEW: https://review.gluster.org/21497 (features/snapview-server: change gf_log instances to gf_msg) posted (#6) for review on master by Amar Tumballi

Comment 5 Shyamsundar 2019-03-25 16:30:38 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-6.0, please open a new bug report.

glusterfs-6.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://lists.gluster.org/pipermail/announce/2019-March/000120.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.