Bug 1626968 - migrate yum to dnf: /etc/yum/protected.d/sudo.conf
Summary: migrate yum to dnf: /etc/yum/protected.d/sudo.conf
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: sudo
Version: 29
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Radovan Sroka
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 1626972
TreeView+ depends on / blocked
 
Reported: 2018-09-10 08:21 UTC by Daniel Mach
Modified: 2018-11-11 03:59 UTC (History)
6 users (show)

Fixed In Version: sudo-1.8.25-1.fc29
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1626972 (view as bug list)
Environment:
Last Closed: 2018-11-11 03:59:50 UTC
Type: Bug


Attachments (Terms of Use)

Description Daniel Mach 2018-09-10 08:21:02 UTC
sudo installs following file:
/etc/yum/protected.d/sudo.conf

Since yum is going away and has been replaced with dnf for years,
it would be good to place the file in the right location:
/etc/dnf/protected.d/sudo.conf

That would also allow dnf to install a compatibility symlink:
/etc/yum/protected.d -> /etc/dnf/protected.d
That is not currently possible, because RPM fails on directory x symlink conflict.

Comment 1 Fedora Update System 2018-09-10 12:46:51 UTC
sudo-1.8.25-1.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2018-7a207f18aa

Comment 2 Matthew Miller 2018-09-10 20:14:35 UTC
Wait, what? I thought the plan of record was to follow "Yum powered by DNF", keeping compatibility as much as possible. Why shuffle all of the yum files around?

Comment 3 Fedora Update System 2018-09-11 06:14:28 UTC
sudo-1.8.25-1.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-7a207f18aa

Comment 4 Radovan Sroka 2018-09-11 15:10:09 UTC
Can you explain why is that so to Matthew?

We are blocking sudo fedora update here.

https://bodhi.fedoraproject.org/updates/FEDORA-2018-7a207f18aa

Comment 5 Matthew Miller 2018-09-11 15:39:12 UTC
(In reply to Radovan Sroka from comment #4)
> Can you explain why is that so to Matthew?

As I understand the plan of record, the plan is for the user-facing tooling in EL to be "Yum 4 (powered by DNF)". This is reflected in https://blog.centos.org/2018/04/yum4-dnf-for-centos-7-updates/, but isn't news (see 
 https://pagure.io/fesco/issue/1312#comment-30997 from three years ago).

I don't see how a campaign to rename config files and paths is in line with that. If there's a document or proposal that's agreed to that outlines how it actually does fit, I'll retract my objection, but as it is, this seems to be coming out of nowhere and going in the wrong direction.

Comment 6 Daniel Mach 2018-10-01 14:52:29 UTC
Matthew,
there's no such campaign.

AFAIK there were only 2 issues (sudo and systemd) that were preventing us from switching /etc/yum directory to a symlink to /etc/dnf.
That is important for full YUM v3 compatibility layer in DNF.

The shuffling with files is required because we're not allowed to do that ourselves in a %pretrans script (it has to be in lua and that comes with several limitations). For the compatibility reasons, we need /etc/yum to become a symlink to /etc/dnf. That is definitely aligned with "keeping compatibility as much as possible" - users will be able to install files under the old locations. The problem is that if a package gets installed *before* DNF, it creates a directory. Then installing DNF fails on that directory, because it attempts to create a symlink in the same location. That's why we need to do some packaging changes. If we don't do them, we'll have to handle compatibility differently and (in my opinion) lower a bar on compatibility level.

If you want us to do something differently, could you propose what the next steps could be?

Comment 7 Matthew Miller 2018-10-01 15:01:39 UTC
Like I said, I'd like to see a document outlining the proposed changes and stakeholder agreement to it. I'm not opposed to change, but from my perspective it appears like uncoordinated requests towards an unclear goal. (I don't see why /etc/yum is to be the symlink rather than /etc/dnf, for example.)

From a Fedora perspective, I don't see anything under either of

* https://fedoraproject.org/wiki/Releases/29/ChangeSet
* https://fedoraproject.org/wiki/Releases/30/ChangeSet

which is definitely something I'd expect at this point.

Comment 9 Fedora Update System 2018-11-11 03:59:50 UTC
sudo-1.8.25-1.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.