Bug 162715 - gfs_fsck fails to complete, can't mount the device.
gfs_fsck fails to complete, can't mount the device.
Status: CLOSED DUPLICATE of bug 162709
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: gfs (Show other bugs)
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Ken Preslan
GFS Bugs
Depends On:
  Show dependency treegraph
Reported: 2005-07-07 19:06 EDT by Jon Scottorn
Modified: 2010-01-11 22:06 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-07-08 11:22:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Jon Scottorn 2005-07-07 19:06:15 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050517 Firefox/1.0.4 (Debian package 1.0.4-2)

Description of problem:
I have removed the storage server from the cluster and shutdown gnbd and
I have been running gfs_fsck for about 24 hours and it still hasn't
completed.  I have a 750GB raid 5 setup and I can't remount or
anything.  What do I need to do to fix this?

Here is what gfs_fsck reports:

Initializing fsck
Initializing lists...
Initializing special inodes...
Setting block ranges...
Creating a block list of size 183146926...
Clearing journals (this may take a while)
Clearing journal 0
Clearing journal 1
Clearing journal 2
Clearing journal 3
Cleared journals
Starting pass1
Checking metadata in Resource Group 0
Checking metadata in Resource Group 1
Checking metadata in Resource Group 2
...... Skipped to conserve space .............
Checking metadata in Resource Group 2791
Checking metadata in Resource Group 2792
Checking metadata in Resource Group 2793
Pass1 complete
Starting pass1b
Looking for duplicate blocks...
Found dup block at 61573000
Found dup block at 61573014
Found dup block at 61573015
Found dup block at 61573016
Found dup block at 61573017
Found dup block at 61573018
Found dup block at 61573019
Found dup block at 61573020
Found dup block at 61573021
Found dup block at 61573022
Found dup block at 61573024
Found dup block at 61573047
Found dup block at 61573048
Found dup block at 61573052
Found dup block at 61623032
Found dup block at 61623033
Found dup block at 61623034
Found dup block at 61623035
Scanning filesystem for inodes containing duplicate blocks...

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.run gfs_fsck and wait for it to stall

Actual Results:  Freezes

Expected Results:  Fix problems with the file system and repair the device.

Additional info:

I have patched gfs_fsck to see if it will give more information provided by AJ lewis
Comment 1 AJ Lewis 2005-07-08 11:22:20 EDT

*** This bug has been marked as a duplicate of 162709 ***

Note You need to log in before you can comment on or make changes to this bug.