Bug 162745 - odd behaviour with bugzilla icons
odd behaviour with bugzilla icons
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: eclipse-bugzilla (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kyu Lee
http://rheneas.eng.buffalo.edu/bugzilla/
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-08 03:57 EDT by Andrew Schultz
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-04 15:40:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
exception stacktrace (10.29 KB, text/plain)
2005-07-08 03:57 EDT, Andrew Schultz
no flags Details
screenshot of icons too small (12.44 KB, image/png)
2005-07-08 12:41 EDT, Andrew Schultz
no flags Details

  None (edit)
Description Andrew Schultz 2005-07-08 03:57:17 EDT
Description of problem:
If a bug system is created in eclipse, it fails if the bugzilla installation
does not have a favicon.  I'll attach the exception stack trace.

Version-Release number of selected component (if applicable):
eclipse-platform-3.1.0_fc-0.M6.22
eclipse-bugzilla-0.1.0_fc-16

A bugzilla installation without a favicon is here:
http://rheneas.eng.buffalo.edu/bugzilla/
Comment 1 Andrew Schultz 2005-07-08 03:57:17 EDT
Created attachment 116507 [details]
exception stacktrace
Comment 2 Jeff Pound 2005-07-08 11:37:18 EDT
When an icon is not specified the plug-in will default to the bugzilla icon
(http://www.bugzilla.org/img/bugzilla_icon.png). When i add your bugzilla
provider posted above, i get the mozilla icon (its commented out in the HTML,
but the plug-in screen scrapes for the icon since many HTML pages aren't a valid
DOM)

http://people.redhat.com/jpound/misc/Screenshot.png

As to the error your seeing, it seems like SWT is having issues with png (rather
odd, could be an SWT bug though). What arch are you running on? 
Comment 3 Andrew Schultz 2005-07-08 12:06:35 EDT
I'm running on an athlon XP.
I added the icon just to get eclipse-bugzilla working, but commented it out to
give a URL for this report (apparently that wasn't enough!).  I tried
referencing the bugzilla_icon.png directly, which also failed.  But the icon I
used before (mozilla-16.png) is also a PNG file.
Comment 4 Jeff Pound 2005-07-08 12:19:20 EDT
hmm, What happens you add https://bugs.eclipse.org/bugs ? (also does not have an
icon)
Comment 5 Andrew Schultz 2005-07-08 12:39:48 EDT
ok, I brought up eclipse again (with rheneas' bugzilla referencing
bugzilla_icon.png) and I didn't get an alert dialog.  Instead, the icon was a
small red square.  I added https://bugs.eclipse.org/bugs and that seemed to
work, but the icon is about 2x too small.  I'll attach a screenshot.
Comment 6 Andrew Schultz 2005-07-08 12:41:03 EDT
Created attachment 116522 [details]
screenshot of icons too small
Comment 7 Jeff Pound 2005-07-26 11:07:23 EDT
I was able to reproduce the "icons too small" bug for the first time today. It
happened when I switched workspaces. Restarting eclipse with the same workspace
resulted in normal sized icons... very odd.
Comment 8 Ben Konrath 2006-10-04 15:40:20 EDT
This bug is filed against FC4 which is no longer supported. Please re-test with
FC5 or FC6 and reopen the bug if the problem still exists. Thanks.

Note You need to log in before you can comment on or make changes to this bug.