Bug 162747 - After install of latest kernel 2.6.12-1.1390 then doing rpm -e kernel-2.6.11-1.1369_FC4 gives dependency errors
After install of latest kernel 2.6.12-1.1390 then doing rpm -e kernel-2.6.11-...
Status: CLOSED DUPLICATE of bug 158394
Product: Fedora
Classification: Fedora
Component: cman-kernel (Show other bugs)
4
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Feist
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-08 04:35 EDT by Mike Cohler
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-19 04:19:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike Cohler 2005-07-08 04:35:03 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
Trying to remove older kernel using rpm -e will not work for this kernel.

Terminal log as follows:

#First list the installed kernels
[root@home1 ~]# rpm -q kernel
kernel-2.6.11-1.1369_FC4
kernel-2.6.12-1.1387_FC4
kernel-2.6.12-1.1390_FC4
# Now remove the earlier kernel
[root@home1 ~]# rpm -e kernel-2.6.11-1.1369_FC4
error: Failed dependencies:
        kernel = 2.6.11-1.1369_FC4 is needed by (installed) cman-kernel-2.6.11.5-20050601.152643.FC4.2.i686
        kernel = 2.6.11-1.1369_FC4 is needed by (installed) dlm-kernel-2.6.11.5-20050601.152643.FC4.2.i686
        kernel = 2.6.11-1.1369_FC4 is needed by (installed) GFS-kernel-2.6.11.8-20050601.152643.FC4.2.i686
        kernel = 2.6.11-1.1369_FC4 is needed by (installed) gnbd-kernel-2.6.11.2-20050420.133124.FC4.35.i686
        /lib/modules/2.6.11-1.1369_FC4 is needed by (installed) cman-kernel-2.6.11.5-20050601.152643.FC4.2.i686
        /lib/modules/2.6.11-1.1369_FC4 is needed by (installed) dlm-kernel-2.6.11.5-20050601.152643.FC4.2.i686
        /lib/modules/2.6.11-1.1369_FC4 is needed by (installed) GFS-kernel-2.6.11.8-20050601.152643.FC4.2.i686
        /lib/modules/2.6.11-1.1369_FC4 is needed by (installed) gnbd-kernel-2.6.11.2-20050420.133124.FC4.35.i686
[root@home1 ~]#

Version-Release number of selected component (if applicable):
kernel-2.6.11-1.1369_FC4 rpm-4.4.1-21

How reproducible:
Always

Steps to Reproduce:
1. As root do "rpm -e kernel-2.6.11-1.1369_FC4"
2.
3.
  

Actual Results:  The same error as list above occurs, and the rpm data is not changed

Expected Results:  The previous kernel should have been removed.

Additional info:

This needs to be fixed soon since for anyone with a limited root partition the buildup of unnecessary files will eventually make the system unusable if there is eventually insufficient space left in the root partition - for example at some point large yum updates will fail due to a lack of available temporary space for working during the update process.
Comment 1 Mike Cohler 2005-07-08 06:20:08 EDT
The same occurs when running kernel-2.6.12-1.1387_FC4 if trying to remove
kernel-2.6.11-1.1369_FC4 using the analogous command.

Mike
Comment 2 Dave Jones 2005-07-08 19:01:41 EDT
The other modules need updates built for them.
Comment 3 Chris Feist 2005-07-11 13:51:07 EDT
The problem was caused because there were no updated kernel modules built for
the new kernels. I've rebuilt the gnbd,cman,dlm & GFS-kernel packages and the
packages should be available on the fedora updates site shortly.  You should be
able to update your machine which will update the cman, etc. kernel modules and
then you can remove the old kernel.
Comment 4 Mike Cohler 2005-07-11 15:55:47 EDT
(In reply to comment #3)

That's excellent - thank you for responding so quickly. Mike



Comment 5 Mike Cohler 2005-07-12 10:55:09 EDT
I am afraid that the latest change has not made this work!

The yum updates from the past day are listed in my machine as:
Jul 12 06:09:07 Updated: kdegraphics.i386 7:3.4.1-0.fc4.2
Jul 12 06:10:14 Updated: libwnck.i386 2.10.0-4.fc4
Jul 12 06:11:09 Updated: gaim.i386 1:1.4.0-4.fc4
Jul 12 06:11:44 Updated: procps.i386 3.2.5-6.3
Jul 12 06:11:53 Installed: cman-kernel.i686 2.6.11.5-20050601.152643.FC4.8
Jul 12 06:11:55 Updated: selinux-policy-targeted.noarch 1.25.1-7
Jul 12 06:12:43 Updated: metacity.i386 2.10.0-2.fc4
Jul 12 06:12:44 Updated: dlm-kernheaders.i686 2.6.11.5-20050601.152643.FC4.9
Jul 12 06:12:45 Updated: kdegraphics-devel.i386 7:3.4.1-0.fc4.2
Jul 12 06:13:07 Installed: gnbd-kernel.i686 2.6.11.2-20050420.133124.FC4.42
Jul 12 06:13:24 Updated: selinux-policy-targeted-sources.noarch 1.25.1-7
Jul 12 06:13:28 Installed: dlm-kernel.i686 2.6.11.5-20050601.152643.FC4.9
Jul 12 06:13:28 Updated: gnbd-kernheaders.i686 2.6.11.2-20050420.133124.FC4.42
Jul 12 06:13:28 Updated: cman-kernheaders.i686 2.6.11.5-20050601.152643.FC4.8
Jul 12 06:13:30 Updated: libwnck-devel.i386 2.10.0-4.fc4

Now running the rpm command still does not remove the kernel !

[root@home1 ~]# rpm -e kernel-2.6.11-1.1369_FC4
error: Failed dependencies:
        kernel = 2.6.11-1.1369_FC4 is needed by (installed)
cman-kernel-2.6.11.5-20050601.152643.FC4.2.i686
        kernel = 2.6.11-1.1369_FC4 is needed by (installed)
dlm-kernel-2.6.11.5-20050601.152643.FC4.2.i686
        kernel = 2.6.11-1.1369_FC4 is needed by (installed)
GFS-kernel-2.6.11.8-20050601.152643.FC4.2.i686
        kernel = 2.6.11-1.1369_FC4 is needed by (installed)
gnbd-kernel-2.6.11.2-20050420.133124.FC4.35.i686
        /lib/modules/2.6.11-1.1369_FC4 is needed by (installed)
cman-kernel-2.6.11.5-20050601.152643.FC4.2.i686
        /lib/modules/2.6.11-1.1369_FC4 is needed by (installed)
dlm-kernel-2.6.11.5-20050601.152643.FC4.2.i686
        /lib/modules/2.6.11-1.1369_FC4 is needed by (installed)
GFS-kernel-2.6.11.8-20050601.152643.FC4.2.i686
        /lib/modules/2.6.11-1.1369_FC4 is needed by (installed)
gnbd-kernel-2.6.11.2-20050420.133124.FC4.35.i686
[root@home1 ~]#

Mike
Comment 6 Mike Cohler 2005-07-12 10:56:52 EDT
Also GFS-kernel on my machine shows as 

[root@home1 ~]# rpm -q GFS-kernel
GFS-kernel-2.6.11.8-20050601.152643.FC4.2
[root@home1 ~]#
Comment 7 Chris Feist 2005-07-12 11:03:20 EDT
Because cman-kernel, gnbd-kernel, etc. are kernel modules when you install a new
version the old version isn't automatically removed.  If you want to remove the
old kernel, you must remove the old cman-kernel,gnbd-kernel, etc. packages.
Comment 8 Mike Cohler 2005-07-12 17:37:19 EDT
I just discovered that this issue has already been dealt with previously and the
solution is at
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=158394

The solution is to use "yum remove" rather than "rpm -e"

Apologies that I missed the previous bug report.

Mike 
Comment 9 Walter Justen 2005-08-19 04:19:31 EDT

*** This bug has been marked as a duplicate of 158394 ***

Note You need to log in before you can comment on or make changes to this bug.