Bug 162753 - ps/2 mouse works during install but not after booting
ps/2 mouse works during install but not after booting
Status: CLOSED DEFERRED
Product: Fedora
Classification: Fedora
Component: kudzu (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-08 08:34 EDT by Graham Freeman
Modified: 2014-03-16 22:54 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-02 12:06:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg.conf file (2.98 KB, text/plain)
2005-07-08 09:06 EDT, Graham Freeman
no flags Details
/var/log/messages from booting attempts (204.74 KB, text/plain)
2005-07-08 09:09 EDT, Graham Freeman
no flags Details
/var/log/Xorg.o.log file from most recent reboot (45.88 KB, text/plain)
2005-07-08 09:12 EDT, Graham Freeman
no flags Details

  None (edit)
Description Graham Freeman 2005-07-08 08:34:44 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

Description of problem:
I have just upgraded from an old RedHat version to Fedora 4.  The PS/2 mouse was previously identified in the XF86Config file as being /dev/mouse.
After installation, booting failed because the mouse could not be opened during the xorg start-up.  The /var/log/Xorg.0.log file indicated that it could not open device /dev/mouse, and I was able to confirm that indeed there was no device /dev/mouse.  There was a device /dev/mouse0, so I edited the /etc/X11/xorg.conf file to refer instead to this device.  
The machine now boots, with no error messages about the mouse in the log file.  However, the mouse does not work.  I tried running /usr/sbin/mouseconfig, but this made no difference.
I am not sure if this is an xorg problem or a device detection problem with the new device handling system in Fedora.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.If I boot the machine in MS Windows, the mouse works fine.
2.If I boot the machine from the Fedora installation disk, the mouse works fine during installation.
3.After installation, the mouse is dead under Linux.
  

Actual Results:  I am only able to use Linux in text mode.

Additional info:
Comment 1 Graham Freeman 2005-07-08 09:06:56 EDT
Created attachment 116512 [details]
xorg.conf file
Comment 2 Graham Freeman 2005-07-08 09:09:36 EDT
Created attachment 116513 [details]
/var/log/messages from booting attempts

This shows that the Logitech mouse is detected during booting, as least in the
most recent attempts.  Nevertheless, X Windows does not see it.
Comment 3 Graham Freeman 2005-07-08 09:12:18 EDT
Created attachment 116514 [details]
/var/log/Xorg.o.log file from most recent reboot

Xorg seems happy with the config file.
Comment 4 Mike A. Harris 2005-08-30 07:32:00 EDT
I'm not sure if our installer (anaconda) or whichever other config
tool is responsible, properly handles upgrading xorg.conf to use
/dev/input instead of /dev/psaux.

Anaconda-team:
Reassigning to anaconda for review/comment.  If anaconda isn't
responsible for this, please reassign to appropriate component.
Comment 5 Bill Nottingham 2005-08-30 15:36:45 EDT
You don't want /dev/mouse0, you want /dev/input/mice.

What exactly were you running beforehand?
Comment 6 Graham freeman 2005-09-02 08:43:04 EDT
I was running Red Hat 7.2.

/dev/input/mice works fine. 

I guess that coping with upgrading from all historical systems cleanly is a tall
order.  I suggest closing the bug report as not worth pursuing further.  Thanks.
Comment 7 Bill Nottingham 2005-09-02 12:06:18 EDT
There is a script that anaconda runs on upgrade (/usr/sbin/fix-mouse-psaux) -
but it's generally only been tested on upgrades from FC1.

Deferring for now, will reopen if we get a chance to do more testing/fixing of
this script.

Note You need to log in before you can comment on or make changes to this bug.