Bug 1627631 - Remote unauthenticated crash
Summary: Remote unauthenticated crash
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: cockpit
Version: 7.6
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: 7.6
Assignee: Martin Pitt
QA Contact: Jan Ščotka
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-09-11 06:14 UTC by Martin Pitt
Modified: 2018-10-30 10:35 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-10-30 10:34:55 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:3148 0 None None None 2018-10-30 10:35:46 UTC

Description Martin Pitt 2018-09-11 06:14:10 UTC
Description of problem:

Accessing these URLs

https://ip_or_dns:9090/cockpit/static/%
https://ip_or_dns:9090/cockpit/static/%00

causes Cockpit to crash:

Sep 6 02:28:51 ucockpit cockpit-ws[1418]: Error: signal Segmentation fault:
Sep 6 02:28:51 ucockpit cockpit-ws[1418]: /usr/lib/cockpit/cockpit-ws[0x41e0be]
Sep 6 02:28:51 ucockpit cockpit-ws[1418]: /lib/x86_64-linux-gnu/libc.so.6(+0x354b0)[0x7fb76da5f4b0]
Sep 6 02:28:51 ucockpit cockpit-ws[1418]: /lib/x86_64-linux-gnu/libc.so.6(+0x8e06e)[0x7fb76dab806e]
Sep 6 02:28:51 ucockpit cockpit-ws[1418]: /usr/lib/cockpit/cockpit-ws[0x422cfb]
Sep 6 02:28:51 ucockpit cockpit-ws[1418]: /usr/lib/cockpit/cockpit-ws[0x40ff3e]
Sep 6 02:28:51 ucockpit cockpit-ws[1418]: /usr/lib/cockpit/cockpit-ws[0x40c052]
Sep 6 02:28:51 ucockpit cockpit-ws[1418]: /usr/lib/x86_64-linux-gnu/libffi.so.6(ffi_call_unix64+0x4c)[0x7fb76cfcce40]
Sep 6 02:28:51 ucockpit cockpit-ws[1418]: /usr/lib/x86_64-linux-gnu/libffi.so.6(ffi_call+0x2eb)[0x7fb76cfcc8ab]
Sep 6 02:28:51 ucockpit cockpit-ws[1418]: /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0(g_cclosure_marshal_generic+0x1f9)[0x7fb76ec677c9]
Sep 6 02:28:51 ucockpit cockpit-ws[1418]: /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0(g_closure_invoke+0x145)[0x7fb76ec66fa5]
Sep 6 02:28:51 ucockpit cockpit-ws[1418]: /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0(+0x21fc1)[0x7fb76ec78fc1]
Sep 6 02:28:51 ucockpit cockpit-ws[1418]: /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0(g_signal_emit_valist+0xa59)[0x7fb76ec817f9]
Sep 6 02:28:51 ucockpit cockpit-ws[1418]: /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0(g_signal_emit+0x8f)[0x7fb76ec8208f]
Sep 6 02:28:51 ucockpit cockpit-ws[1418]: /usr/lib/cockpit/cockpit-ws[0x423c8d]
Sep 6 02:28:51 ucockpit cockpit-ws[1418]: /usr/lib/x86_64-linux-gnu/libffi.so.6(ffi_call_unix64+0x4c)[0x7fb76cfcce40]
Sep 6 02:28:51 ucockpit cockpit-ws[1418]: /usr/lib/x86_64-linux-gnu/libffi.so.6(ffi_call+0x2eb)[0x7fb76cfcc8ab]

How reproducible: Always

Comment 6 errata-xmlrpc 2018-10-30 10:34:55 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:3148


Note You need to log in before you can comment on or make changes to this bug.