Bug 1627689 - The elasticsearch-config should be logging-elasticsearch-ops in logging-es-ops pods
Summary: The elasticsearch-config should be logging-elasticsearch-ops in logging-es-op...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Logging
Version: 3.11.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 3.11.z
Assignee: Jeff Cantrill
QA Contact: Anping Li
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-09-11 09:07 UTC by Anping Li
Modified: 2018-11-20 03:11 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: The installer did not parameterize the configmap used by the ES pods Consequence: The ops ES pods used the configmap of the non-ops ES pods Fix: Parameterize the template used by the installer Result: The ES ops pods use the logging-es-ops configmap
Clone Of:
Environment:
Last Closed: 2018-11-20 03:10:43 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift openshift-ansible pull 10357 None None None 2018-10-08 21:02:26 UTC
Red Hat Product Errata RHBA-2018:3537 None None None 2018-11-20 03:11:19 UTC

Description Anping Li 2018-09-11 09:07:43 UTC
Description of problem:
The configmap are logging-elasticsearch in logging-es-ops deploymentconfig.  As a result, the ping.unicast.hosts is logging-es-cluster in elasticsearch.yml. That made the logging-es-ops pods couldn't be started.

#oc rsh logging-es-ops-data-master-k06vkabq-1-kn9mr head -6  /etc/elasticsearch/elasticsearch.yml
cluster:
  name: ${CLUSTER_NAME}
discovery.zen:
  minimum_master_nodes: ${NODE_QUORUM}
  ping.unicast.hosts: logging-es-cluster

Version-Release number of selected component (if applicable):
openshift-ansible:v3.11.0-0.32.0

How reproducible:
always

Steps to Reproduce:
1. deploy logging and enable logging-ops
openshift_logging_install_logging=true
openshift_logging_use_ops=true

2. Check the elasticsearch-config in logging-es-ops deploymengconfig
$ oc get dc logging-es-ops-data-master-o7f0q18m -o yaml |grep -A 3 configMap
      - configMap:
          defaultMode: 420
          name: logging-elasticsearch
        name: elasticsearch-config

3. check the elasticsearch.yml
 oc rsh logging-es-ops-data-master-k06vkabq-1-kn9mr head -6  /etc/elasticsearch/elasticsearch.yml
cluster:
  name: ${CLUSTER_NAME}
discovery.zen:
  minimum_master_nodes: ${NODE_QUORUM}
  ping.unicast.hosts: logging-es-cluster

Actual results:

The ping.unicast.hosts is logging-es-cluster. The logging-es-ops pods are using elasticsearch.yml from logging-elasticsearch configmap


Expected results:
The ping.unicast.hosts is logging-es-ops-cluster. The logging-es-ops pods should use elasticsearch.yml from logging-elasticsearch-ops configmap

Additional info:

Comment 1 Jeff Cantrill 2018-09-13 17:45:19 UTC
Moved this to a z-stream as the expectation is it affects a small number of customers if any at all.

Comment 5 Qiaoling Tang 2018-11-02 07:00:51 UTC
Verified with:
openshift-ansible-docs-3.11.36-1.git.0.2213c76.el7.noarch
ansible-2.6.5-1.el7ae.noarch
openshift-ansible-playbooks-3.11.36-1.git.0.2213c76.el7.noarch
openshift-ansible-3.11.36-1.git.0.2213c76.el7.noarch
openshift-ansible-roles-3.11.36-1.git.0.2213c76.el7.noarch


# oc exec -c elasticsearch logging-es-ops-data-master-eisqwbuv-1-v5g4r -- head -6  /etc/elasticsearch/elasticsearch.yml
cluster:
  name: ${CLUSTER_NAME}
discovery.zen:
  minimum_master_nodes: ${NODE_QUORUM}
  ping.unicast.hosts: logging-es-ops-cluster
gateway:

# oc get dc logging-es-ops-data-master-eisqwbuv -o yaml |grep -A 3 configMap
      - configMap:
          defaultMode: 420
          name: logging-elasticsearch-ops
        name: elasticsearch-config

Comment 7 errata-xmlrpc 2018-11-20 03:10:43 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:3537


Note You need to log in before you can comment on or make changes to this bug.