Bug 1627693 - /usr/libexec/qemu-kvm: relocation error: /lib64/libspice-server.so.1: symbol SSL_CONF_CTX_set_ssl_ctx, version libssl.so.10 not defined in file libssl.so.10 with link time referenceopenssl dependency:
Summary: /usr/libexec/qemu-kvm: relocation error: /lib64/libspice-server.so.1: symbol ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: spice
Version: 7.6
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: 7.8
Assignee: Radek Duda
QA Contact: SPICE QE bug list
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-09-11 09:25 UTC by Dr. David Alan Gilbert
Modified: 2019-08-06 12:48 UTC (History)
7 users (show)

Fixed In Version: spice-0.14.0-7.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-08-06 12:47:53 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:2106 None None None 2019-08-06 12:48:00 UTC

Description Dr. David Alan Gilbert 2018-09-11 09:25:18 UTC
Description of problem:
I hit the error:
  /usr/libexec/qemu-kvm: relocation error: /lib64/libspice-server.so.1: symbol SSL_CONF_CTX_set_ssl_ctx, version libssl.so.10 not defined in file libssl.so.10 with link time reference
after manually upgrading my dev box to:

spice-protocol-0.12.13-2.el7.noarch
spice-server-0.14.0-6.el7.x86_64
spice-server-devel-0.14.0-6.el7.x86_64

Version-Release number of selected component (if applicable):

it had:
5:openssl-1:1.0.1e-51.el7_2.4
on it.

Upgrading to openssl-1.0.2k-16.el7.x86_64.rpm openssl-libs-1.0.2k-16.el7.x86_64.rpm openssl-devel-1.0.2k-16.el7.x86_64.rpm

seems to have fixed it.

How reproducible:
??

Steps to Reproduce:
1. Take old RHEL install
2. Upgrade qemu and spice-server 
3.

Actual results:


Expected results:


Additional info:

Comment 3 Christophe Fergeau 2018-12-18 15:58:47 UTC
The Requires: openssl-libs >= 1.0.2k-16 has been added to the rhel-7.7 branch, so this should get fixed with the next build.

Comment 8 Frediano Ziglio 2019-06-28 08:12:30 UTC
Should this bug be closed?

Comment 11 errata-xmlrpc 2019-08-06 12:47:53 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2106


Note You need to log in before you can comment on or make changes to this bug.