Bug 1627696 - The nested guest hangs at" failed to start networkmanager wait online" all the time
Summary: The nested guest hangs at" failed to start networkmanager wait online" all th...
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: virt-manager   
(Show other bugs)
Version: 29
Hardware: Unspecified Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Cole Robinson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-09-11 09:30 UTC by lnie
Modified: 2018-09-12 13:33 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-09-12 13:33:36 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
journal (1.67 MB, text/plain)
2018-09-11 09:30 UTC, lnie
no flags Details
screencast (973.34 KB, application/octet-stream)
2018-09-11 09:31 UTC, lnie
no flags Details

Description lnie 2018-09-11 09:30:13 UTC
Created attachment 1482321 [details]
journal

Description of problem:
I try to create a nested guest using virt-install --name test-day-vm --ram 2048 --disk /home/lnie/fedora282.qcow2 --os-variant fedora28 --import
but got WARNING  KVM acceleration not available, using 'qemu',
and the VM hangs at "failed to start networkmanager wait online" all the time

Version-Release number of selected component (if applicable):
virt-manager-1.6.0-1.3.git3bc7ff24c.fc29.noarch

How reproducible:
always

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 lnie 2018-09-11 09:31 UTC
Created attachment 1482322 [details]
screencast

Comment 2 Cole Robinson 2018-09-11 16:14:41 UTC
The hang is probably due to that warning: it's not using 'kvm' acceleration, so the nested VM will be extremely slow

Is your host intel? You probably need to enable nesting on the host. Uncomment the kvm_intel line in /etc/modprobe.d/kvm.conf , reboot, and try again

Comment 3 lnie 2018-09-12 02:50:15 UTC
(In reply to Cole Robinson from comment #2)
> The hang is probably due to that warning: it's not using 'kvm' acceleration,
> so the nested VM will be extremely slow
> 
> Is your host intel? You probably need to enable nesting on the host.
> Uncomment the kvm_intel line in /etc/modprobe.d/kvm.conf , reboot, and try
> again


yeah,it's intel.Here is the steps how I enable the nested vm on the host:
1)modprobe -r kvm_intel
2)modprobe kvm_intel nested=1
3)uncomment options kvm_intel nested=1 and reboot the host.

[root@192 iscsi]# cat /sys/module/kvm_intel/parameters/nested
Y

Comment 4 Cole Robinson 2018-09-12 13:33:36 UTC
Okay that's expected then. So if you were following test day steps they probably need to be updated


Note You need to log in before you can comment on or make changes to this bug.