Bug 1627697 - 'Copy host cpu' should be using mode=host-model nowadays
Summary: 'Copy host cpu' should be using mode=host-model nowadays
Status: CLOSED UPSTREAM
Alias: None
Product: Virtualization Tools
Classification: Community
Component: virt-manager
Version: unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Cole Robinson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-09-11 09:31 UTC by lnie
Modified: 2018-10-04 18:45 UTC (History)
4 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2018-10-04 18:45:55 UTC


Attachments (Terms of Use)

Description lnie 2018-09-11 09:31:32 UTC
Description of problem:
I've clicked "copy host cpu configuration" for the guest hypervisor VM, which should use host-model,but there isn't,

Version-Release number of selected component (if applicable):
virt-manager-1.4.3-2.fc27.noarch(host)
virt-manager-1.6.0-1.3.git3bc7ff24c.fc29.noarch

How reproducible:
always

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Cole Robinson 2018-09-11 20:24:09 UTC
Thanks for the report. Indeed 'copy host CPU' uses our old manual host-model implementation, because it was safer in some old situations, but we should be using host-model nowadays, at least if libvirt is new enough

Comment 2 Cole Robinson 2018-10-04 18:45:55 UTC
Upstream now:

commit 9edca3486abd76e9a7c2c2fe3ad12ae32fc65733 (HEAD -> master, origin/master, origin/HEAD, cpu)
Author: Cole Robinson <crobinso@redhat.com>
Date:   Thu Oct 4 14:19:32 2018 -0400

    virt-manager: Wire up support for default mode=host-model


Note You need to log in before you can comment on or make changes to this bug.