Bug 162770 - kernel panics with 2.6.12-1.1370_FC3smp but is fine non-smp (mptscsih.ko)
kernel panics with 2.6.12-1.1370_FC3smp but is fine non-smp (mptscsih.ko)
Status: CLOSED DUPLICATE of bug 163437
Product: Fedora
Classification: Fedora
Component: mkinitrd (Show other bugs)
3
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-08 11:37 EDT by Michael Ditum
Modified: 2015-01-04 17:20 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-21 10:14:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Ditum 2005-07-08 11:37:27 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

Description of problem:
I installed the kernel-2.6.12-1.1370_FC3.i686.rpm and kernel-smp-2.6.12-1.1370_FC3.i686.rpm files (from http://people.redhat.com/davej/kernels/Fedora/FC3/RPMS.kernel/) to test the new kernel for my DVB-S Card.

Booting the non-smp one is fine (and my DVB card works great) however if I try to boot the smp kernel I get a kernel panic a little while after an insmod error about mptscsih.ko having an unknown symbol.

This is running on an HP ProLiant ML350 G4 Server (info at http://h10010.www1.hp.com/wwpc/uk/en/sm/WF06b/521-525-358265-358265-12083545-11302097-15164387.html)

Version-Release number of selected component (if applicable):
2.6.12-1.1370_FC3smp

How reproducible:
Always

Steps to Reproduce:
1. Get an HP ProLiant ML350 G4
2. Install kernel-smp-2.6.12-1.1370_FC3.i686.rpm
3. Boot smp kernel
  

Actual Results:  Booting 'Fedora Core (2.6.12-1.1370_FC3smp)'

root (hd0,0)
  Filesystem type is ext2fs, partition type 0x83
  kernel /vmlinuz-2.6.12-1.1370_FC3 ro root=/dev/VolGroup00/LogVol00 rhgb quiet
    [Linux-bzImage, setup=0x1e00, size=0x17e806]
  initrd /initrd-2.6.12-1.1370_FC3smp.img
    [Linux-initrd @ 0x1fed9000, 0x109cea bytes]

Uncompressing Linux... OK booting the kernel.
pnp: Unable to assign resources to device 00:08
Red Hat nash version 4.1.18 starting
insmod: error inserting '/lib/mptscsih.ko': -1 Unknown symbol in module
Error /bin/insmod exited abnormally!
insmod: error inserting '/lib/dm-mirror.ko': -1 Unknown symbol in module
Error /bin/insmod exited abnormally!
mount: error 6 mounting ext2
mount: error 2 mounting none
switchroot: mount failed: 22
umount /initrd/dev failed: 2
kernel panic - not synching: Attempting to kill init!

Expected Results:  Computer should load drivers correctly and then boot up

Additional info:

I got this same error message when I tried building 2.6.12.1 kernel from source using kernel.org version. Thought I would try your version to see if it had been fixed.
Comment 1 Dan Carpenter 2005-07-08 16:29:27 EDT
This could be the same thing as bug 160652

Can't hurt to try upgrading you mkinitrd package and retesting.

Comment 2 Michael Ditum 2005-07-11 05:16:57 EDT
Its booting now but I have another problem which is a side effect from this...
just to document...

I updated to mkinitrd from FC4 and that required that I updated to udev 057-3
though I could only find an rpm for udev 058-1 also for FC4 (both were
downloaded from
http://download.fedora.redhat.com/pub/fedora/linux/core/4/i386/os/Fedora/RPMS/).

I then removed the kernel rpm's using -e and then installed them again.

The system now boots fine and seemed to be working ok.

I assume when you release the new kernel you will create new packages of
mkinitrd and udev for FC3 as well to fix this 

issue.

However my dvb drivers no longer work. They aren't creating the device nodes
when I load the modules. I downgraded mkinitrd and udev back to their original
versions and it works fine now. I assume its a problem with the new version of
udev. The output to /var/log/messages looks exactly the same for both versions
so maybe its just a configuration issue. Only thing that looks slightly suspect
is the line...

Jul 11 09:52:22 bloodhound hal.hotplug[4629]: DEVPATH is not set

but that appears with both versions of udev...

Not sure if I should issue a new bug report or not as I installed an FC4 rpm on
FC3... not exactly something you support.

Thanks for all your help!
Comment 3 Dave Jones 2005-07-15 15:32:24 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.
Comment 4 Dave Jones 2005-07-15 19:22:07 EDT
note that mixing and matching bits from different releases can sometimes lead to
really obscure bugs, that are particularly awkward to diagnose.  It may be in
your best interest to reinstall with fc4 at some point.
Comment 5 Armijn Hemel 2005-07-16 04:59:52 EDT
I just installed the latest FC3 update (kernel-2.6.12-1.1372_FC3) and I'm seeing
similar errors:

mount: error 6 mounting ext3
mount: error 2 mounting none
switchroot: mount failed: 22
umount /initrd/dev failed: 2
kernel panic - not synching: Attempting to kill init!

This only happens when I boot the SMP kernel, the non-smp kernel works just fine.
The machine is a vanilla FC3.
Comment 6 Allen Kistler 2005-07-16 17:09:08 EDT
My experience is similar to Comment #5.  Here's a little more info.

Booting 2.6.11-1.35_FC3smp (which works fine), a slightly expanded console
output looks like this:

Loading scsi_mod.ko module
SCSI subsystem initialized
Loading sd_mod.ko module
Loading aic79xx.ko module
Creating root device
Mounting root filesystem
etc.

Booting 2.6.12-1.1372_FC3smp (broken) looks like this:

Loading scsi_mod.ko module
Loading sd_mod.ko module
SCSI subsystem initialized  [note the different order, significant?]
Loading aic79xx.ko module
Creating root device
mkrootdev: label / not found
Mounting root filesystem
mount: error 2 mounting ext2
mount: error 2 mounting none
etc.

I've torn the two respective initrds apart (zcat | cpio -idm).
The directories are identical.  The init files are identical.

According to sfdisk, my labels are just fine.
Comment 7 Dan Carpenter 2005-07-16 17:41:04 EDT
***************************
Disclaimer:  I don't work for RedHat
***************************

I hate to see you guys banging your heads against the wall.

http://www.adras.com/Race-condition-in-module-load-causing-undefined-symbols.t6648-141-3.html

> The issue is that David Howells posted a patch that changed the behaviour of
> kallsyms/insmod/rmmod sometime ago. The patch *is correct* in what it does,
> however, the patch requires that /sbin/sh [in the initrd] must be aware of 
> pid returns by wait().

So basically, you should just be able to unpack your initrd, insert an updated
/bin/sh and package it up again.  

Probably an easier thing is to just downgrade your kernel until a new mkinitrd
package for FC3 is released.
Comment 8 Allen Kistler 2005-07-20 20:41:31 EDT
Perhaps Mike D should change the component to mkinitrd, then, which will let
whoever covers mkinitrd know there's something to do for fc3 and get this bug
out of NEEDINFO status and moving forward.  Dan C's comment seems pretty
convincing.  Anyone disagree?
Comment 9 Michael Ditum 2005-07-21 03:39:35 EDT
I just checked the new 2.6.12-1.1372_FC3smp kernel and it didn't fix the problem
so I'm gonna do as Allen K says and change the component to mkinitrd. Feel free
to change it back if I shouldn't have...
Comment 10 Frank Ch. Eigler 2005-07-21 10:14:42 EDT

*** This bug has been marked as a duplicate of 163437 ***

Note You need to log in before you can comment on or make changes to this bug.