Bug 162790 - Totem displays a black screen when playing movies
Summary: Totem displays a black screen when playing movies
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: totem
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: John (J5) Palmieri
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-07-08 17:54 UTC by Aaron VanDevender
Modified: 2013-03-13 04:48 UTC (History)
2 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2006-04-15 14:30:24 UTC


Attachments (Terms of Use)

Description Aaron VanDevender 2005-07-08 17:54:02 UTC
Description of problem:
I play a movie with totem (such as an ogg/theora file like
http://www.redhat.com/v/magazine/ogg/inevitable.ogg) and the sound plays fine,
but instead of the video it displays only a black rectangle.

I can make video appear by changing the /system/gstreamer/0.8/default/videosink
gconf key from "xvimagesink" to "xvimagesink name=xvimagesink0"

even though xvimagesink0 should be the default. Perhaps this is related to Bug
151579

Version-Release number of selected component (if applicable):
totem-1.0.2-1
gstreamer-0.8.10-1
gstreamer-plugins-0.8.8-6

One shouldn't have to use gconf-editor to play movies with totem. It should work
out of the box.

Comment 1 John Thacker 2006-04-14 20:12:03 UTC
Can you reproduce this in FC5?  A bug with playing ogg/theora video was fixed in
totem-1.3.1.  This certainly WORKSFORME without any gconf changes.

Comment 2 Aaron VanDevender 2006-04-15 14:30:24 UTC
This is not only fixed, but not even really relevent anymore, since as of
gst-0.10.x, we have the autovideosink and so which sets up xvimagesink (or
whatever) correctly. I'm closing this bug.


Note You need to log in before you can comment on or make changes to this bug.