Bug 1627955 - clicking on a daemonset pod takes you to the daemonset list
Summary: clicking on a daemonset pod takes you to the daemonset list
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 3.10.0
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
: 4.1.0
Assignee: Samuel Padgett
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-09-12 00:36 UTC by raffaele spazzoli
Modified: 2019-06-04 10:40 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, clicking on the daemon set pod donut in the overview took you to the list of daemon sets. In 4.0, clicking on the daemon set replica count in the overview takes you directly to the list of daemon set pods.
Clone Of:
Environment:
Last Closed: 2019-06-04 10:40:34 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:40:43 UTC

Description raffaele spazzoli 2018-09-12 00:36:38 UTC
Description of problem:
clicking on a daemonset pod takes you to the daemonset list

Version-Release number of selected component (if applicable):
3.10

How reproducible:
100%

Steps to Reproduce:
1. deploy a daemonset
2. click on the daemonset pods (the big blue circle)
  

Actual results:
This takes you to the daemonset list

Expected results:
this should take you to the pod list of that dameonset or to the pod directly if there is only one pod.

Comment 1 Samuel Padgett 2018-09-12 12:14:51 UTC
This is intentional, although I understand why it's a little odd. Clicking on the donut for any resource with more than one pod takes you to the resource details. In the case of a daemon set, we don't have a dedicated page, so we go to the list.

I'm going to leave this open as a low severity defect. We will address in the 4.0 coverged console.

Comment 2 Samuel Padgett 2019-01-12 16:22:18 UTC
Clicking on the daemon set pod link in the 4.0 overview takes you directly to the daemon set pod list.

https://github.com/openshift/console/pull/559

Comment 4 Yadan Pei 2019-01-28 08:06:43 UTC
1. Create DaemonSet
2. Go to Home -> Status page
3. Clicking on N of N pods redirects to DaemonSet Pods list page

Verified on
$ oc get pods openshift-console-6d9974dd74-5hjqt -n openshift-console -o yaml | grep image
    image: quay.io/openshift-release-dev/ocp-v4.0-art-dev@sha256:a8f450c6f9047ab41cb624d5834e916e99c5d8ea43328211e40ec694363b8803
$ oc image info quay.io/openshift-release-dev/ocp-v4.0-art-dev@sha256:a8f450c6f9047ab41cb624d5834e916e99c5d8ea43328211e40ec694363b8803
             io.openshift.build.commit.id=5070df1f11d481f36152c0218f209a085eed9d64
             io.openshift.build.commit.url=https://github.com/openshift/console/commit/5070df1f11d481f36152c0218f209a085eed9d64

Comment 7 errata-xmlrpc 2019-06-04 10:40:34 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.