Bug 16280 - piranha-gui puts lvs.cf in the wrong place?
piranha-gui puts lvs.cf in the wrong place?
Status: CLOSED ERRATA
Product: Red Hat High Availability Server
Classification: Retired
Component: piranha (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Copeland
Wil Harris
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-08-15 14:35 EDT by lars
Modified: 2007-04-18 12:28 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-09-11 21:37:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Red Hat Bugzilla 2000-08-15 14:35:59 EDT
The piranha web GUI wants to put lvs.cf in /etc/sysconfig/ha.  Pulse, from
piranha-0.4.16-3, wants it to be in /etc/lvs.cf.  Neither rpm appears to
set up a symlink, and the GUI doesn't appear to have a "deploy" button for
putting the file in the correct spot.
Comment 1 Red Hat Bugzilla 2000-08-15 15:21:28 EDT
This sounds like Bryce included V2 logic in the V1.1 RPM release. It's also
possible that this logic is support to be there, but is accidentally being
trigger on the sparc platform install.

Forwarding to Bryce for review.

Comment 2 Red Hat Bugzilla 2000-08-15 15:24:32 EDT
[a more understandable version of the previous paragraph]

This sounds like Bryce included V2 logic in the V1.1 RPM release. It's also     
possible that this logic is suppose to be there, but is accidentally being     
triggered by the sparc platform install.

Forwarding to Bryce for review.

Comment 3 Red Hat Bugzilla 2000-08-16 16:27:12 EDT
I am running the latest version (0.4.16-3) in i386 and the Config is properly
handled in /etc/lvs.cf.  This is most likely a SPARC only issue.
Comment 4 Red Hat Bugzilla 2000-08-16 19:38:44 EDT
With all due respect, I don't believe this is an architecture related problem:

  $ rpm -i piranha-0.4.16-3.src.rpm
  $ cd /usr/src
  $ rpm -bp SPECS/piranha.spec
  $ cd BUILD/piranha/web
  $ find . -type f -print | xargs grep -li '/etc/lvs\.cf'
  <NO OUTPUT>
  $ find . -type f -print | xargs grep -li '/etc/sysconfig/ha/lvs\.cf'
  ./html/secure/lvserror.php3
  ./html/secure/parse.php3

Not a single file in the web gui references /etc/lvs.cf.  Furthermore, there is
nothing in the spec file that modifies any of the php files to point to a new
location.  If you're using RPMS built from the same source packages as I'm
using, I'd appreciate it if you would point me at the part of the build process
that is fixing what appears to be an error, because the other alternative is
that I'm simply going insane.

I have even built the piranha-gui package on my i386 system, used rpm2cpio to
extract *ALL THE FILES*, and then run a recursive grep on them for /etc/lvs.cf. 
IT'S JUST NOT THERE!
Comment 5 Red Hat Bugzilla 2000-08-17 08:39:15 EDT
Sorry, with all due respect, I'm an idiot.  Yes, I'm running -3 of piranha, but
only -2 of the piranha-gui.

-- Keith
Comment 6 Red Hat Bugzilla 2000-08-17 08:46:49 EDT
As payment for looking stupid, I'll be glad to fix the issue, the question is
where does RedHat want the config?  Want a fix to support the old location, or
fix the install to migrate to the new location?

-- Keith Moore
Disclaimer: I do not work for RedHat
Comment 7 Red Hat Bugzilla 2000-08-18 22:17:20 EDT
Actually, after looking through the Redhat HA FAQ, I found this:

  Why doesn't the GUI automatically copy the changed configuration file?

  This is planned for a future release. It simply did not make it into this 
  release in time because the changes require extensive security review. 

Apparently, the piranha folks are already aware of this.  I'd feel sheepish, but
no-one else reading thus bug noticed either.
Comment 8 Red Hat Bugzilla 2000-09-11 21:36:58 EDT
Care to comment Phil?
Comment 9 Red Hat Bugzilla 2000-09-13 20:49:00 EDT
The config problem has been fixed and updated RPMs have been posted to
ftp://people.redhat.com/kbarrett/HA/

Note You need to log in before you can comment on or make changes to this bug.