Bug 1628103 - Kernel updates are reporting strange errors
Summary: Kernel updates are reporting strange errors
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jaroslav Rohel
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 1635694
TreeView+ depends on / blocked
 
Reported: 2018-09-12 08:37 UTC by Vít Ondruch
Modified: 2018-10-19 16:07 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1635694 (view as bug list)
Environment:
Last Closed: 2018-10-05 16:05:47 UTC
Type: Bug


Attachments (Terms of Use)

Description Vít Ondruch 2018-09-12 08:37:51 UTC
Description of problem:
My intention is to update everything except kernel, so DNF should not compalin about kernel at all:

~~~
$ sudo dnf update -x kernel\* 
Last metadata expiration check: 0:17:13 ago on Wed Sep 12 10:17:18 2018.
Dependencies resolved.

 Problem 1: cannot install the best update candidate for package kernel-4.17.6-200.fc28.x86_64
  - package kernel-4.19.0-0.rc3.git0.1.fc30.x86_64 is disabled
 Problem 2: cannot install the best update candidate for package kernel-4.17.14-200.fc28.x86_64
  - package kernel-4.19.0-0.rc3.git0.1.fc30.x86_64 is disabled
 Problem 3: cannot install the best update candidate for package kernel-4.18.5-300.fc29.x86_64
  - package kernel-4.19.0-0.rc3.git0.1.fc30.x86_64 is disabled
 Problem 4: cannot install the best update candidate for package kernel-core-4.17.6-200.fc28.x86_64
  - package kernel-core-4.19.0-0.rc3.git0.1.fc30.x86_64 is disabled
 Problem 5: cannot install the best update candidate for package kernel-core-4.17.14-200.fc28.x86_64
  - package kernel-core-4.19.0-0.rc3.git0.1.fc30.x86_64 is disabled
 Problem 6: cannot install the best update candidate for package kernel-core-4.18.5-300.fc29.x86_64
  - package kernel-core-4.19.0-0.rc3.git0.1.fc30.x86_64 is disabled
 Problem 7: cannot install the best update candidate for package kernel-modules-4.17.6-200.fc28.x86_64
  - package kernel-modules-4.19.0-0.rc3.git0.1.fc30.x86_64 is disabled
 Problem 8: cannot install the best update candidate for package kernel-modules-4.17.14-200.fc28.x86_64
  - package kernel-modules-4.19.0-0.rc3.git0.1.fc30.x86_64 is disabled
 Problem 9: cannot install the best update candidate for package kernel-modules-4.18.5-300.fc29.x86_64
  - package kernel-modules-4.19.0-0.rc3.git0.1.fc30.x86_64 is disabled
 Problem 10: package libreoffice-calc-1:6.1.0.3-1.fc30.x86_64 requires liborcus-0.13.so.0()(64bit), but none of the providers can be installed
  - package libreoffice-calc-1:6.1.0.3-1.fc30.x86_64 requires liborcus-parser-0.13.so.0()(64bit), but none of the providers can be installed
  - cannot install both liborcus-0.14.0-1.fc30.x86_64 and liborcus-0.13.4-3.fc29.x86_64
  - cannot install the best update candidate for package libreoffice-calc-1:6.1.0.3-1.fc30.x86_64
  - cannot install the best update candidate for package liborcus-0.13.4-3.fc29.x86_64
===============================================================================
 Package          Arch           Version                 Repository       Size
===============================================================================
Skipping packages with conflicts:
(add '--best --allowerasing' to command line to force their upgrade):
 liborcus         x86_64         0.14.0-1.fc30           rawhide         430 k

Transaction Summary
===============================================================================
Skip  1 Package

Nothing to do.
Complete!
~~~

Similarly, I want to update just kernel but DNF again shows some complaints:

~~~
$ sudo dnf update --disablerepo=* --enablerepo=fedora --release 29 kernel\*
Last metadata expiration check: 0:05:26 ago on Wed Sep 12 10:30:27 2018.
Dependencies resolved.

 Problem 1: cannot install both kernel-4.18.5-300.fc29.x86_64 and kernel-4.18.5-300.fc29.x86_64
  - cannot install the best update candidate for package kernel-4.18.5-300.fc29.x86_64
  - cannot install the best update candidate for package kernel-4.17.6-200.fc28.x86_64
 Problem 2: cannot install both kernel-core-4.18.5-300.fc29.x86_64 and kernel-core-4.18.5-300.fc29.x86_64
  - cannot install the best update candidate for package kernel-core-4.18.5-300.fc29.x86_64
  - cannot install the best update candidate for package kernel-core-4.17.6-200.fc28.x86_64
 Problem 3: cannot install both kernel-modules-4.18.5-300.fc29.x86_64 and kernel-modules-4.18.5-300.fc29.x86_64
  - cannot install the best update candidate for package kernel-modules-4.18.5-300.fc29.x86_64
  - cannot install the best update candidate for package kernel-modules-4.17.6-200.fc28.x86_64
===============================================================================
 Package              Arch         Version                  Repository    Size
===============================================================================
Reinstalling:
 kernel               x86_64       4.18.5-300.fc29          fedora        22 k
 kernel-core          x86_64       4.18.5-300.fc29          fedora        24 M
 kernel-modules       x86_64       4.18.5-300.fc29          fedora        28 M

Transaction Summary
===============================================================================

Total size: 52 M
Installed size: 87 M
Is this ok [y/N]: 
~~~




Version-Release number of selected component (if applicable):
$ rpm -q dnf
dnf-3.2.0-2.fc29.noarch


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:
DNF complains about some broken dependencies.


Expected results:
DNF does not complain.


Additional info:

Comment 1 Vít Ondruch 2018-09-12 08:41:26 UTC
Actually now I noticed that for the second case, DNF is going to *reinstall* the already installed kernel. That doesn't make sense at all.

Comment 2 chemek 2018-09-19 23:32:57 UTC
I had fix this when upgraded fedora from 29 to 30.

To avoid the version conflict of liborcus, just downgrade it by removing the package (sudo dnf remove liborcus) and downloading and installing liborcus-0.13.4-1.fc28.x86_64.rpm. 

Now you have the 4.19 linux kernel and you can use libreoffice.

Comment 3 Vít Ondruch 2018-09-20 05:03:43 UTC
(In reply to chemek from comment #2)
I am not complaining about liborcus but about kernel.

Comment 4 chemek 2018-09-22 08:52:33 UTC
updating of everything except the kernel is working fine for me, but I had the same display indicates some problems. I think it's just a warning.





[-------@fedoraPC ~]$ sudo dnf update -x kernel\*
[sudo] Mot de passe de ------ : 
Fedora - Modular Rawhide - Developmental packag  15 kB/s |  29 kB     00:01    
Fedora - Modular Rawhide - Developmental packag  72 kB/s | 1.4 MB     00:19    
Fedora - Rawhide - Developmental packages for t  16 kB/s |  30 kB     00:01    
Fedora - Rawhide - Developmental packages for t 402 kB/s |  62 MB     02:38    
RPM Fusion for Fedora Rawhide - Free            4.2 kB/s |  17 kB     00:04    
Dernière vérification de l’expiration des métadonnées effectuée il y a 0:00:02 le ven. 21 sept. 2018 22:51:14 CET.
Dépendances résolues.

 Problème 1: cannot install the best update candidate for package apache-commons-logging-1.2-13.module_1885+a6f9b3e6.noarch
  - package apache-commons-logging-1.2-14.fc29.noarch is disabled
 Problème 2: cannot install the best update candidate for package kernel-4.19.0-0.rc3.git1.1.fc30.x86_64
  - package kernel-4.19.0-0.rc4.git1.1.fc30.x86_64 is disabled
 Problème 3: cannot install the best update candidate for package kernel-4.19.0-0.rc3.git2.1.fc30.x86_64
  - package kernel-4.19.0-0.rc4.git1.1.fc30.x86_64 is disabled
 Problème 4: cannot install the best update candidate for package kernel-4.19.0-0.rc3.git3.1.fc30.x86_64
  - package kernel-4.19.0-0.rc4.git1.1.fc30.x86_64 is disabled
 Problème 5: cannot install the best update candidate for package kernel-core-4.19.0-0.rc3.git1.1.fc30.x86_64
  - package kernel-core-4.19.0-0.rc4.git1.1.fc30.x86_64 is disabled
 Problème 6: cannot install the best update candidate for package kernel-core-4.19.0-0.rc3.git2.1.fc30.x86_64
  - package kernel-core-4.19.0-0.rc4.git1.1.fc30.x86_64 is disabled
 Problème 7: cannot install the best update candidate for package kernel-core-4.19.0-0.rc3.git3.1.fc30.x86_64
  - package kernel-core-4.19.0-0.rc4.git1.1.fc30.x86_64 is disabled
 Problème 8: cannot install the best update candidate for package kernel-devel-4.19.0-0.rc3.git1.1.fc30.x86_64
  - package kernel-devel-4.19.0-0.rc4.git1.1.fc30.x86_64 is disabled
 Problème 9: cannot install the best update candidate for package kernel-devel-4.19.0-0.rc3.git2.1.fc30.x86_64
  - package kernel-devel-4.19.0-0.rc4.git1.1.fc30.x86_64 is disabled
 Problème 10: cannot install the best update candidate for package kernel-devel-4.19.0-0.rc3.git3.1.fc30.x86_64
  - package kernel-devel-4.19.0-0.rc4.git1.1.fc30.x86_64 is disabled
 Problème 11: cannot install the best update candidate for package kernel-modules-4.19.0-0.rc3.git1.1.fc30.x86_64
  - package kernel-modules-4.19.0-0.rc4.git1.1.fc30.x86_64 is disabled
 Problème 12: cannot install the best update candidate for package kernel-modules-4.19.0-0.rc3.git2.1.fc30.x86_64
  - package kernel-modules-4.19.0-0.rc4.git1.1.fc30.x86_64 is disabled
 Problème 13: cannot install the best update candidate for package kernel-modules-4.19.0-0.rc3.git3.1.fc30.x86_64
  - package kernel-modules-4.19.0-0.rc4.git1.1.fc30.x86_64 is disabled
 Problème 14: cannot install the best update candidate for package kernel-modules-extra-4.19.0-0.rc3.git1.1.fc30.x86_64
  - package kernel-modules-extra-4.19.0-0.rc4.git1.1.fc30.x86_64 is disabled
 Problème 15: cannot install the best update candidate for package kernel-modules-extra-4.19.0-0.rc3.git2.1.fc30.x86_64
  - package kernel-modules-extra-4.19.0-0.rc4.git1.1.fc30.x86_64 is disabled
 Problème 16: cannot install the best update candidate for package kernel-modules-extra-4.19.0-0.rc3.git3.1.fc30.x86_64
  - package kernel-modules-extra-4.19.0-0.rc4.git1.1.fc30.x86_64 is disabled
 Problème 17: cannot install the best update candidate for package libnghttp2-1.33.0-1.fc30.x86_64
  - package libnghttp2-1.33.0-1.module_2177+076c917f.x86_64 is disabled
 Problème 18: cannot install the best update candidate for package ruby-2.5.1-100.fc30.x86_64
  - package ruby-2.5.1-100.module_2189+93ac0776.x86_64 is disabled
 Problème 19: cannot install the best update candidate for package ruby-irb-2.5.1-100.fc30.noarch
  - package ruby-irb-2.5.1-100.module_2189+93ac0776.noarch is disabled
 Problème 20: cannot install the best update candidate for package ruby-libs-2.5.1-100.fc30.x86_64
  - package ruby-libs-2.5.1-100.module_2189+93ac0776.x86_64 is disabled
 Problème 21: cannot install the best update candidate for package rubygem-bigdecimal-1.3.4-100.fc30.x86_64
  - package rubygem-bigdecimal-1.3.4-100.module_2189+93ac0776.x86_64 is disabled
 Problème 22: cannot install the best update candidate for package rubygem-did_you_mean-1.2.0-100.fc30.noarch
  - package rubygem-did_you_mean-1.2.0-100.module_2189+93ac0776.noarch is disabled
 Problème 23: cannot install the best update candidate for package rubygem-io-console-0.4.6-100.fc30.x86_64
  - package rubygem-io-console-0.4.6-100.module_2189+93ac0776.x86_64 is disabled
 Problème 24: cannot install the best update candidate for package rubygem-openssl-2.1.0-100.fc30.x86_64
  - package rubygem-openssl-2.1.0-100.module_2189+93ac0776.x86_64 is disabled
 Problème 25: cannot install the best update candidate for package rubygem-psych-3.0.2-100.fc30.x86_64
  - package rubygem-psych-3.0.2-100.module_2189+93ac0776.x86_64 is disabled
 Problème 26: cannot install the best update candidate for package rubygems-2.7.6-100.fc30.noarch
  - package rubygems-2.7.6-100.module_2189+93ac0776.noarch is disabled
======================================================================================================================================
 Paquet                                   Architecture       Version                                        Dépôt               Taille
======================================================================================================================================
Mise à jour de:
 NetworkManager                           x86_64             1:1.14.0-1.fc30                                rawhide             1.6 M
 NetworkManager-adsl                      x86_64             1:1.14.0-1.fc30                                rawhide              26 k
 NetworkManager-bluetooth                 x86_64             1:1.14.0-1.fc30                                rawhide              47 k
 NetworkManager-libnm                     x86_64             1:1.14.0-1.fc30                                rawhide             1.3 M
 NetworkManager-ppp                       x86_64             1:1.14.0-1.fc30                                rawhide              34 k
 NetworkManager-team                      x86_64             1:1.14.0-1.fc30                                rawhide              28 k
 NetworkManager-wifi                      x86_64             1:1.14.0-1.fc30                                rawhide              57 k
 NetworkManager-wwan                      x86_64             1:1.14.0-1.fc30                                rawhide              51 k
 annobin                                  x86_64             8.36-1.fc30                                    rawhide             171 k
 autocorr-en                              noarch             1:6.1.1.2-1.fc30                               rawhide             151 k
 dmidecode                                x86_64             1:3.2-1.fc30                                   rawhide              78 k
 dnfdaemon                                noarch             0.3.19-4.fc30                                  rawhide              63 k
 dnfdaemon-selinux                        noarch             0.3.19-4.fc30                                  rawhide             9.6 k
 fedora-obsolete-packages                 noarch             30-8                                           rawhide              19 k
 fping                                    x86_64             4.1-1.fc30                                     rawhide              36 k
 gdb                                      x86_64             8.2.50.20180917-1.fc30                         rawhide             131 k
 gdb-headless                             x86_64             8.2.50.20180917-1.fc30                         rawhide             3.4 M
 glusterfs                                x86_64             5.0-0.1.rc0.fc30                               rawhide             637 k
 glusterfs-api                            x86_64             5.0-0.1.rc0.fc30                               rawhide              82 k
 glusterfs-cli                            x86_64             5.0-0.1.rc0.fc30                               rawhide             189 k
 glusterfs-client-xlators                 x86_64             5.0-0.1.rc0.fc30                               rawhide             956 k
 glusterfs-fuse                           x86_64             5.0-0.1.rc0.fc30                               rawhide             128 k
 glusterfs-libs                           x86_64             5.0-0.1.rc0.fc30                               rawhide             381 k
 gstreamer1                               x86_64             1.14.3-1.fc30                                  rawhide             1.2 M
 gstreamer1-plugins-bad-free              x86_64             1.14.3-1.fc30                                  rawhide             1.7 M
 gstreamer1-plugins-base                  x86_64             1.14.3-1.fc30                                  rawhide             1.7 M
 gstreamer1-plugins-good                  x86_64             1.14.3-1.fc30                                  rawhide             2.1 M
 gstreamer1-plugins-good-gtk              x86_64             1.14.3-1.fc30                                  rawhide              28 k
 gstreamer1-plugins-ugly-free             x86_64             1.14.3-1.fc30                                  rawhide              83 k
 json-glib                                x86_64             1.4.4-1.fc30                                   rawhide             137 k
 lcms2                                    x86_64             2.9-4.fc30                                     rawhide             150 k
 libdnf                                   x86_64             0.19.1-3.fc30                                  rawhide             501 k
 libdrm                                   x86_64             2.4.94-1.fc30                                  rawhide             145 k
 libdrm-devel                             x86_64             2.4.94-1.fc30                                  rawhide             138 k
 libmodulemd                              x86_64             1.6.4-1.fc30                                   rawhide             153 k
 liborcus                                 x86_64             0.14.0-1.fc30                                  rawhide             430 k
 libreoffice                              x86_64             1:6.1.1.2-1.fc30                               rawhide              17 k
 libreoffice-base                         x86_64             1:6.1.1.2-1.fc30                               rawhide             2.1 M
 libreoffice-calc                         x86_64             1:6.1.1.2-1.fc30                               rawhide             8.1 M
 libreoffice-core                         x86_64             1:6.1.1.2-1.fc30                               rawhide              87 M
 libreoffice-data                         noarch             1:6.1.1.2-1.fc30                               rawhide             2.2 M
 libreoffice-draw                         x86_64             1:6.1.1.2-1.fc30                               rawhide              30 k
 libreoffice-emailmerge                   x86_64             1:6.1.1.2-1.fc30                               rawhide              30 k
 libreoffice-graphicfilter                x86_64             1:6.1.1.2-1.fc30                               rawhide             313 k
 libreoffice-gtk2                         x86_64             1:6.1.1.2-1.fc30                               rawhide             235 k
 libreoffice-gtk3                         x86_64             1:6.1.1.2-1.fc30                               rawhide             323 k
 libreoffice-help-en                      x86_64             1:6.1.1.2-1.fc30                               rawhide             5.1 M
 libreoffice-impress                      x86_64             1:6.1.1.2-1.fc30                               rawhide             543 k
 libreoffice-langpack-en                  x86_64             1:6.1.1.2-1.fc30                               rawhide             107 k
 libreoffice-math                         x86_64             1:6.1.1.2-1.fc30                               rawhide             427 k
 libreoffice-opensymbol-fonts             noarch             1:6.1.1.2-1.fc30                               rawhide             191 k
 libreoffice-pdfimport                    x86_64             1:6.1.1.2-1.fc30                               rawhide             228 k
 libreoffice-pyuno                        x86_64             1:6.1.1.2-1.fc30                               rawhide             353 k
 libreoffice-ure                          x86_64             1:6.1.1.2-1.fc30                               rawhide             2.1 M
 libreoffice-ure-common                   noarch             1:6.1.1.2-1.fc30                               rawhide             452 k
 libreoffice-writer                       x86_64             1:6.1.1.2-1.fc30                               rawhide             3.6 M
 libreoffice-x11                          x86_64             1:6.1.1.2-1.fc30                               rawhide             241 k
 libteam                                  x86_64             1.27-11.fc30                                   rawhide              45 k
 minizip-compat                           x86_64             1.2.11-13.fc30                                 rawhide              29 k
 network-scripts-teamd                    x86_64             1.27-11.fc30                                   rawhide              11 k
 openssl-pkcs11                           x86_64             0.4.8-2.fc30                                   rawhide              58 k
 orca                                     noarch             3.30.0-1.fc30                                  rawhide             2.6 M
 pcre2                                    x86_64             10.32-2.fc30                                   rawhide             236 k
 pcre2-utf16                              x86_64             10.32-2.fc30                                   rawhide             221 k
 python3-dnfdaemon                        noarch             0.3.19-4.fc30                                  rawhide              21 k
 python3-hawkey                           x86_64             0.19.1-3.fc30                                  rawhide              71 k
 python3-libdnf                           x86_64             0.19.1-3.fc30                                  rawhide             619 k
 redhat-rpm-config                        noarch             120-1.fc30                                     rawhide              58 k
 teamd                                    x86_64             1.27-11.fc30                                   rawhide              95 k
 virglrenderer                            x86_64             0.7.0-1.20180919git402c22886.fc30              rawhide             765 k
 wingpanel-applications-menu              x86_64             2.4.0-1.fc30                                   rawhide             287 k
 xen-libs                                 x86_64             4.11.0-7.fc30                                  rawhide             541 k
 xen-licenses                             x86_64             4.11.0-7.fc30                                  rawhide              57 k
 xorg-x11-server-utils                    x86_64             7.7-27.fc30                                    rawhide             176 k
 zlib                                     i686               1.2.11-13.fc30                                 rawhide              91 k
 zlib                                     x86_64             1.2.11-13.fc30                                 rawhide              89 k
 zlib-devel                               i686               1.2.11-13.fc30                                 rawhide              46 k
 zlib-devel                               x86_64             1.2.11-13.fc30                                 rawhide              46 k

Résumé de la transaction
======================================================================================================================================
Mettre à jour  78 Paquets

Taille totale des téléchargements : 137 M
Voulez-vous continuer ? [o/N] : o
Téléchargement des paquets :

Comment 5 Vít Ondruch 2018-09-24 08:11:33 UTC
It is not "just warning". See the second case where DNF is trying to reinstall packages which are already installed, that is definitely wrong.

Comment 6 Luigi Cantoni 2018-09-28 07:42:54 UTC
Problem: cannot install both kernel-modules-extra

I have been getting this problem since updating (via dnf) to Fedora 28.
(Sorry not the development versions as listed here.)

The error has been moving with the kernels as they get loaded.
It is always the current version.
There are no F27 kernels left.
I hoped the problem would go away when that was the case or otherwise get fixed.
This has not happened.
It is on all my systems (4 different ones) but appears to cause no problems.

Sorry its not the original problem listed above but it was noted that my problem was also observed so I am hoping it might be a combined fix.

Comment 8 Fedora Update System 2018-10-03 10:36:41 UTC
libsolv-0.6.35-3.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2018-c12fd2bd59

Comment 9 Vít Ondruch 2018-10-03 12:46:47 UTC
Testing with recent libsolv:

~~~
$ rpm -q libsolv
libsolv-0.6.35-3.fc30.x86_64
~~~

It seems the second case is resolved:

~~~
$ sudo dnf update --disablerepo=* --enablerepo=fedora --release 29 kernel\*
Last metadata expiration check: 0:01:47 ago on Wed Oct  3 14:40:13 2018.
Dependencies resolved.
Nothing to do.
Complete!
~~~

While the first is just a bit better:

~~~
$ LANG=C.UTF-8 sudo dnf update -x kernel\*
RCM Tools for Fedora 30 (RPMs)                                                                                                                                                     231  B/s | 286  B     00:01    
Failed to synchronize cache for repo 'rcm-tools-fedora-rpms', ignoring this repo.
Last metadata expiration check: 0:11:18 ago on Wed Oct  3 14:31:39 2018.
Dependencies resolved.

 Problem 1: cannot install the best update candidate for package kernel-core-4.17.14-200.fc28.x86_64
  - package kernel-core-4.19.0-0.rc5.git3.1.fc30.x86_64 is disabled
 Problem 2: cannot install the best update candidate for package kernel-core-4.18.5-300.fc29.x86_64
  - package kernel-core-4.19.0-0.rc5.git3.1.fc30.x86_64 is disabled
 Problem 3: cannot install the best update candidate for package kernel-core-4.18.10-300.fc29.x86_64
  - package kernel-core-4.19.0-0.rc5.git3.1.fc30.x86_64 is disabled
 Problem 4: cannot install the best update candidate for package kernel-modules-4.17.14-200.fc28.x86_64
  - package kernel-modules-4.19.0-0.rc5.git3.1.fc30.x86_64 is disabled
 Problem 5: cannot install the best update candidate for package kernel-modules-4.18.5-300.fc29.x86_64
  - package kernel-modules-4.19.0-0.rc5.git3.1.fc30.x86_64 is disabled
 Problem 6: cannot install the best update candidate for package kernel-modules-4.18.10-300.fc29.x86_64
  - package kernel-modules-4.19.0-0.rc5.git3.1.fc30.x86_64 is disabled

... snip ...
~~~

So there is not mentioned "kernel" package anymore in comparison with the original report, but there still are "kernel-core" and "kernel-modules" reported. Isn't it somehow related to bug 1615377, where the excludes does not work as expected? Maybe the wildcard is not exploded somewhere ...

Comment 10 Vít Ondruch 2018-10-03 13:32:17 UTC
(In reply to Vít Ondruch from comment #9)
> Isn't it somehow related to bug 1615377, where the excludes does
> not work as expected?

libdnf-0.20.0-2.fc30.x86_64 solves the bug 1615377, so it must be something else ...

Comment 11 Fedora Update System 2018-10-03 16:31:07 UTC
libsolv-0.6.35-3.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-c12fd2bd59

Comment 12 Fedora Update System 2018-10-05 16:05:47 UTC
libsolv-0.6.35-3.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.

Comment 13 Luigi Cantoni 2018-10-06 00:46:12 UTC
As my problem is with F28 I do not expect a fix at the moment.
F29 official release is:
2018-10-30 	Fedora 29 Final Release (GA) (Target #1)
I will wait until the start of Nov and upgrade to F29.
If fixed/not fixed I will report then (or open new bug if this is closed).
I expect it should be fixed based on what I have read above (and in other bug reports).

Comment 14 Fedora Update System 2018-10-15 07:37:26 UTC
libsolv-0.6.35-3.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-77e628e053

Comment 15 Fedora Update System 2018-10-15 11:13:18 UTC
libsolv-0.6.35-3.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-77e628e053

Comment 16 Fedora Update System 2018-10-19 16:07:33 UTC
libsolv-0.6.35-3.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.