Bug 1628125 - FlightGear needs rebuild for new qt5
Summary: FlightGear needs rebuild for new qt5
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: FlightGear
Version: 28
Hardware: Unspecified
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Fabrice Bellet
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-09-12 09:58 UTC by J. Randall Owens
Modified: 2018-10-05 17:08 UTC (History)
3 users (show)

Fixed In Version: FlightGear-2018.1.1-2.fc28
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-10-05 17:08:04 UTC
Type: Bug


Attachments (Terms of Use)

Description J. Randall Owens 2018-09-12 09:58:33 UTC
Description of problem:
FlightGear requires libQt5Quick.so.5(Qt_5.10.1_PRIVATE_API)(64bit), but the new qt5-qtdeclarative-5.11.1-3.fc28.x86_64 provides libQt5Quick.so.5(Qt_5.11.1_PRIVATE_API)(64bit), and can't be upgraded until FlightGear is rebuilt for it, I suppose.

Version-Release number of selected component (if applicable):
FlightGear-2018.1.1-1.fc28.x86_64

How reproducible:
easily

Steps to Reproduce:
1. have a system that hasn't been upgraded to qt5-*-5.11.1 yet
2. dnf install FlightGear
3. dnf upgrade
alternatively this should do it:
1. have a system without FlightGear but does have the qt5-*-5.11.1 update
2. dnf install FlightGear

Actual results:
 Problem: problem with installed package FlightGear-2018.1.1-1.fc28.x86_64
  - package FlightGear-2018.1.1-1.fc28.x86_64 requires libQt5Quick.so.5(Qt_5.10.1_PRIVATE_API)(64bit), but none of the providers can be installed
etc.

Expected results:
upgrade or install of FlightGear & qt5-*

Additional info:
SimGear has the same version number as FlightGear, but I don't know if it has to strictly correspond between the two (FG requires libSimGearCore.so.2018.1.1()(64bit) etc., so probably not). I'll leave it up to you whether it also needs a rebuild.

Comment 1 Fedora Update System 2018-09-13 11:59:09 UTC
FlightGear-2018.1.1-2.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-51dd913513

Comment 2 Fedora Update System 2018-09-13 17:52:11 UTC
FlightGear-2018.1.1-2.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-51dd913513

Comment 3 Alexandre Ducastaing 2018-09-14 16:01:06 UTC
FlightGear.x86_64   2018.1.1-2.fc28   @updates-testing works for me. Thanks.
I can upgrade the system...

Comment 4 René van Paassen 2018-09-18 07:45:53 UTC
Confirmed. I hit the same issue, and the @updates-testing rpm's work.

Comment 5 Fedora Update System 2018-10-05 17:08:04 UTC
FlightGear-2018.1.1-2.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.