Bug 1628131 - arm-none-eabi-newlib is missing newlib.h for nano specs
Summary: arm-none-eabi-newlib is missing newlib.h for nano specs
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: arm-none-eabi-newlib
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Michal Hlavinka
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-09-12 10:12 UTC by Joakim Nohlgård
Modified: 2019-04-06 20:18 UTC (History)
2 users (show)

Fixed In Version: arm-none-eabi-newlib-3.1.0-2.fc28 arm-none-eabi-newlib-3.1.0-2.fc29 arm-none-eabi-newlib-3.1.0-2.fc30
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-04-06 19:21:33 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Gentoo 532390 None None None 2018-09-12 10:12:57 UTC

Description Joakim Nohlgård 2018-09-12 10:12:57 UTC
Description of problem:

The arm-none-eabi-newlib package provides two instances of the library, one full functionality version and one size reduced version for constrained applications, with a smaller ROM and RAM footprint. However, the configuration declarations header file newlib.h is installed only for the full functionality version of the library. The nano build newlib.h is discarded.

Version-Release number of selected component (if applicable):


How reproducible:

Always

Steps to Reproduce:
1. check for the declaration of _NANO_FORMATTED_IO in newlib.h
2.
3.

Actual results:

Only one newlib.h, with the configuration for the full non-nano newlib, located in /usr/arm-none-eabi/include

Expected results:

A separate newlib.h for the nano configured build, placed in /usr/arm-none-eabi/include/newlib-nano
This would match the installation behaviour of the Debian and Gentoo packages as well as the ARM supported toolchain at https://developer.arm.com/open-source/gnu-toolchain/gnu-rm/downloads 


Additional info:

Comment 1 Szymon Janc 2019-03-08 10:23:57 UTC
Hi, any update on this bug?

It is also affecting Fedora 29. And since nano.specs is distributed build system may use nano version but fails due to missing header..

Comment 2 Michal Hlavinka 2019-03-11 12:49:33 UTC
Could you please provide some steps to test this? I mean some real small usecase that it works as it should, not just string grep of an include file.

Also, I've prepared a test build (not available from repository yet), if anyone wants to test it:
https://koji.fedoraproject.org/koji/taskinfo?taskID=33396634

Comment 3 Fedora Update System 2019-03-25 21:07:12 UTC
arm-none-eabi-gcc-cs-7.4.0-1.fc28 arm-none-eabi-newlib-3.1.0-2.fc28 arm-none-eabi-binutils-cs-2.32-1.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2019-3328f43d89

Comment 4 Fedora Update System 2019-03-25 21:07:31 UTC
arm-none-eabi-newlib-3.1.0-2.fc30 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-d1af067fbe

Comment 5 Fedora Update System 2019-03-25 21:07:41 UTC
arm-none-eabi-gcc-cs-7.4.0-1.fc29 arm-none-eabi-newlib-3.1.0-2.fc29 arm-none-eabi-binutils-cs-2.32-1.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-280f25c3e4

Comment 6 Szymon Janc 2019-03-26 10:11:14 UTC
Hi,

simple and real life usecase is to download https://github.com/RIOT-OS/RIOT

and execute:
make BOARD=nrf52dk -C examples/nimble_gatt


Also I can confirm than rpm from https://koji.fedoraproject.org/koji/taskinfo?taskID=33396634 fix the issue for me!
Many thanks.

Comment 7 Fedora Update System 2019-03-27 00:45:04 UTC
arm-none-eabi-newlib-3.1.0-2.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-d1af067fbe

Comment 8 Fedora Update System 2019-03-27 04:11:40 UTC
arm-none-eabi-binutils-cs-2.32-1.fc28, arm-none-eabi-gcc-cs-7.4.0-1.fc28, arm-none-eabi-newlib-3.1.0-2.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-3328f43d89

Comment 9 Fedora Update System 2019-03-27 04:34:22 UTC
arm-none-eabi-binutils-cs-2.32-1.fc29, arm-none-eabi-gcc-cs-7.4.0-1.fc29, arm-none-eabi-newlib-3.1.0-2.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-280f25c3e4

Comment 10 Fedora Update System 2019-04-06 19:21:33 UTC
arm-none-eabi-binutils-cs-2.32-1.fc28, arm-none-eabi-gcc-cs-7.4.0-1.fc28, arm-none-eabi-newlib-3.1.0-2.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2019-04-06 19:43:03 UTC
arm-none-eabi-binutils-cs-2.32-1.fc29, arm-none-eabi-gcc-cs-7.4.0-1.fc29, arm-none-eabi-newlib-3.1.0-2.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2019-04-06 20:18:43 UTC
arm-none-eabi-newlib-3.1.0-2.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.