Bug 1628202 - RTL8169 NIC not working with kernel 4.18.5
Summary: RTL8169 NIC not working with kernel 4.18.5
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 28
Hardware: x86_64
OS: Unspecified
unspecified
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-09-12 12:55 UTC by Norbert Jurkeit
Modified: 2018-09-21 08:58 UTC (History)
16 users (show)

Fixed In Version: kernel-4.18.8-200.fc28.x86_64
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-09-21 08:58:39 UTC
Type: Bug


Attachments (Terms of Use)

Description Norbert Jurkeit 2018-09-12 12:55:48 UTC
My desktop PC has 2 Ethernet interfaces, the first one located on the motherboard and listed by lshw as "RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller" and the second located on a PCI card listed as "RTL8169 PCI Gigabit Ethernet Controller". Both interfaces use driver r8169.

After upgrade to kernel 4.18.5 the second interface no longer works properly. According to ifconfig the interface is up and running and configured correctly with IPv4 and IPv6 addresses and also the LED on the NIC blinks while a local or remote ping command is running, but data transfer fails: ping to another host hangs almost forever and ping to this host from another host yields "Destination Host Unreachable".

Sometimes the hanging local ping command states after several minutes:

wrong data byte #22 should be 0x16 but was 0x26
#16	10 11 12 13 14 15 26 27 28 29 2a 2b 2c 2d 1e 1f 20 21 22 23 24 25 26 27 28 29 2a 2b 2c 2d 2e 2f 
#48	30 31 32 33 34 35 0 11

Probably received or transmitted packets are not processed correctly by the driver.

When I choose previous kernel 4.17.19 from Grub menu everything works fine again, so a hardware damage is unlikely. The issue has not occurred before on this hardware in 9 years with Fedora or other Linux distros.

Comment 1 Norbert Jurkeit 2018-09-21 08:58:39 UTC
After upgrade to kernel-4.18.8-200.fc28.x86_64 the issue is fixed, most likely thanks to commit "r8169: set RxConfig after tx/rx is enabled for RTL8169sb/8110sb devices".


Note You need to log in before you can comment on or make changes to this bug.