Bug 1628244 - gnome-documents will not start
Summary: gnome-documents will not start
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-documents
Version: 29
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Elad Alfassa
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedFreezeException AcceptedBlocker
Depends On:
Blocks: F29BetaFreezeException F29FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2018-09-12 14:26 UTC by Lukas Ruzicka
Modified: 2018-09-20 22:35 UTC (History)
12 users (show)

Fixed In Version: gnome-documents-3.30.0-1.fc29
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-09-20 22:35:50 UTC


Attachments (Terms of Use)

Description Lukas Ruzicka 2018-09-12 14:26:12 UTC
Description of problem:

Gnome Documents will not start on Fedora 29 Beta RC 1.1

Version-Release number of selected component (if applicable):

gnome-documents-3.29.91-1
gnome-shell-3.30.0-1

How reproducible:

Always

Steps to Reproduce:
1. Click on gnome-documents icon
2. Run the gnome-documents command from Terminal

Actual results:

Application does not start with:
(org.gnome.Documents:477): Gjs-CRITICAL **: 16:20:32.902: JS ERROR: SyntaxError: missing ) after catch @ resource:///org/gnome/Documents/js/evinceview.js:318
Script /usr/bin/gnome-documents threw an exception

Expected results:

App should start without problems.

Comment 1 Fedora Blocker Bugs Application 2018-09-12 14:29:14 UTC
Proposed as a Blocker for 29-final by Fedora user lruzicka using the blocker tracking app because:

 The bug violates the following criteria for Final Release: All applications that can be launched using the standard graphical mechanism of a release-blocking desktop after a default installation of that desktop must start successfully and withstand a basic functionality test.

Comment 2 Kalev Lember 2018-09-12 15:16:49 UTC
Thanks, should be fixed in gnome-documents-3.30.0-1.fc29

Comment 3 Fedora Update System 2018-09-12 15:17:04 UTC
gnome-documents-3.30.0-1.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2018-1b8f554867

Comment 4 Kalev Lember 2018-09-12 18:17:58 UTC
Proposing as a FE for Beta to get working gnome-documents on the install media.

Comment 5 Adam Williamson 2018-09-12 20:46:03 UTC
+1 FE.

Comment 6 Adam Williamson 2018-09-12 20:46:17 UTC
and +1 Final blocker.

Comment 7 Chris Murphy 2018-09-12 20:48:19 UTC
+1 beta freeze exception
+1 final blocker

Comment 8 Mohan Boddu 2018-09-12 21:28:01 UTC
+1 FE for F29 Beta

Comment 9 Fedora Update System 2018-09-13 05:36:32 UTC
gnome-documents-3.30.0-1.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-1b8f554867

Comment 10 Adam Williamson 2018-09-16 01:02:37 UTC
+3, setting accepted.

Comment 11 Geoffrey Marr 2018-09-17 20:17:02 UTC
Discussed during the 2018-09-17 blocker review meeting: [1]

The decision to classify this bug as an "AcceptedBlocker" was made as it violates the following criteria:

"All applications that can be launched using the standard graphical mechanism of a release-blocking desktop after a default installation of that desktop must start successfully and withstand a basic functionality test"

[1] https://meetbot.fedoraproject.org/fedora-blocker-review/2018-09-17/f29-blocker-review.2018-09-17-16.02.txt

Comment 12 Lukas Ruzicka 2018-09-19 08:03:17 UTC
I can verify, that the update solves the problem and now Documents start without problems.

Comment 13 Fedora Update System 2018-09-20 22:35:50 UTC
gnome-documents-3.30.0-1.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.