Bug 1628355 - F29 Beta RC1 does not boot on Raspberry Pi
Summary: F29 Beta RC1 does not boot on Raspberry Pi
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: spin-kickstarts
Version: 29
Hardware: armhfp
OS: All
unspecified
urgent
Target Milestone: ---
Assignee: Václav Pavlín
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker
Depends On:
Blocks: F29BetaBlocker
TreeView+ depends on / blocked
 
Reported: 2018-09-12 19:52 UTC by Adam Williamson
Modified: 2018-09-17 17:18 UTC (History)
15 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-09-17 17:18:55 UTC


Attachments (Terms of Use)

Description Adam Williamson 2018-09-12 19:52:21 UTC
Per pbrobinson, we have a problem caused by incomplete landing of this FE in F29 Beta RC1:

https://bugzilla.redhat.com/show_bug.cgi?id=1626076

it seems that for RC1, the update was included, but the associated change to fedora-kickstarts was not. According to Peter, a consequence of this is that the ARM images will not boot at all on Raspberry Pi systems.

As the Pi is a supported platform per https://fedoraproject.org/wiki/Architectures/ARM/Supported_Platforms , that makes this a clear blocker under criterion "All release-blocking images must boot in their supported configurations" - https://fedoraproject.org/wiki/Basic_Release_Criteria#Release-blocking_images_must_boot . Note footnote "Supported ARM platforms are those listed by the ARM team at Architectures/ARM/Supported_Platforms."

The PR has since been merged, so all we need to do if this is accepted as a blocker is run an RC2 compose (with any other blocker/FE fixes required).

Comment 1 Peter Robinson 2018-09-12 19:55:05 UTC
The above is correct. +1 to blocker

Comment 2 Stephen Gallagher 2018-09-12 20:00:54 UTC
+1 blocker

Comment 3 Mohan Boddu 2018-09-12 20:02:46 UTC
I guess its only arm 32 images on RPi, which is still a blocker.

+1 Blocker

Comment 4 Matthew Miller 2018-09-12 20:06:53 UTC
Noooooooooooooooo.

I mean, +1 to blocker. This is important.

Comment 5 Kevin Fenzi 2018-09-12 20:22:30 UTC
+1 blocker

Comment 6 Paul Whalen 2018-09-12 20:55:40 UTC
+1 to blocker

Comment 7 Adam Williamson 2018-09-12 22:10:35 UTC
That's + several, setting accepted.

Comment 8 Adam Williamson 2018-09-14 20:51:35 UTC
Setting MODIFIED to indicate the PR has been merged and the next successful compose should be fixed.

Comment 9 Alessio 2018-09-16 14:16:16 UTC
(In reply to Adam Williamson from comment #8)
> Setting MODIFIED to indicate the PR has been merged and the next successful
> compose should be fixed.

For the records, beta RC2 works.

Comment 10 Adam Williamson 2018-09-16 15:20:30 UTC
RC2 compose ultimately failed - can you confirm with RC3?

https://fedoraproject.org/wiki/Test_Results:Fedora_29_Beta_1.3_Installation

then we can close this. Thanks!

Comment 11 František Zatloukal 2018-09-17 11:23:24 UTC
RC3 boots just fine on RPI2.

Comment 12 Alessio 2018-09-17 12:30:22 UTC
(In reply to František Zatloukal from comment #11)
> RC3 boots just fine on RPI2.

It boots fine also on RPi3 as well.

Comment 13 Adam Williamson 2018-09-17 17:18:55 UTC
Thanks, closing.


Note You need to log in before you can comment on or make changes to this bug.