Bug 1628462 - input method cannot commit any strings in gnome-terminal with multiple Tabs
Summary: input method cannot commit any strings in gnome-terminal with multiple Tabs
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gtk3
Version: 29
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Matthias Clasen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedFreezeException
: 1628447 (view as bug list)
Depends On:
Blocks: F29BetaFreezeException
TreeView+ depends on / blocked
 
Reported: 2018-09-13 06:53 UTC by fujiwara
Modified: 2018-09-20 22:36 UTC (History)
4 users (show)

Fixed In Version: gtk3-3.24.1-1.fc29
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-09-20 22:36:12 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
GNOME Gitlab GNOME/mutter/issues/302 None None None 2018-09-13 06:57:21 UTC

Description fujiwara 2018-09-13 06:53:49 UTC
Description of problem:
GNOME Wayland changed the protocol version between gtk and mutter in Fedora 29 and any input methods cannot commit any strings in gnome-terminal when the multiple Tabs are open.

I also observed the same problem in gedit and soffice.

This problem does not happen in Fedora 28. 

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Open gnome-terminal
2. Type Ctrl-Shift-t and open a new tab
3. Enable ibus-libpinyin
4. Type 'a' and Space


Actual results:
Any string is not committed.

Expected results:
A Chinese character is committed with Space key

Additional info:

meta_wayland_text_input_focus_commit_text() sends the committing string but GTK does not receive the string.

Comment 1 fujiwara 2018-09-13 06:55:54 UTC
*** Bug 1628447 has been marked as a duplicate of this bug. ***

Comment 2 fujiwara 2018-09-13 06:57:22 UTC
I'd like to suggest the protocol version in f29 is reverted to one in f28 between gtk/modules/input/imwayland.c and mutter/src/wayland/meta-wayland-text-input.c

Comment 3 Matthias Clasen 2018-09-14 19:44:08 UTC
Looking at this now

Comment 4 Geoffrey Marr 2018-09-17 20:05:15 UTC
Discussed during the 2018-08-20 blocker review meeting: [1]

The decision to classify this bug as an "AcceptedFreezeException" was made as this is inconvenient for users of different input methods in the Workstation live and would benefit from a fix in the compose.

[1] https://meetbot.fedoraproject.org/fedora-blocker-review/2018-09-17/f29-blocker-review.2018-09-17-16.02.txt

Comment 5 Geoffrey Marr 2018-09-17 20:06:32 UTC
Correction to comment 4:

Discussed during the 2018-09-17 blocker review meeting:

Comment 6 Fedora Update System 2018-09-19 18:25:35 UTC
gtk3-3.24.1-1.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2018-2e24c97cb1

Comment 7 Fedora Update System 2018-09-20 16:18:32 UTC
gtk3-3.24.1-1.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-2e24c97cb1

Comment 8 Fedora Update System 2018-09-20 22:36:12 UTC
gtk3-3.24.1-1.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.