Bug 162850 - pci allocation error at bootup seems to be affecting my video card
pci allocation error at bootup seems to be affecting my video card
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-10 08:43 EDT by Jef Spaleta
Modified: 2015-01-04 17:20 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-17 11:22:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lspci output for HP nw8240 (17.94 KB, text/plain)
2005-11-21 07:40 EST, Maurice Pijpers
no flags Details

  None (edit)
Description Jef Spaleta 2005-07-10 08:43:44 EDT
Description of problem:
when using either the i686 
kernel-smp-2.6.12-1.1422_FC5 
or
kernel-smp-2.6.12-1.1425_FC5

I am getting this error at boot up:
kernel: PCI: Failed to allocate mem resource #6:20000@f8000000 for 0000:01:05.0
kernel: PCI: Bridge: 0000:00:01.0
kernel:   IO window: disabled.
kernel:   MEM window: e9000000-e9ffffff
kernel:   PREFETCH window: f0000000-f7ffffff


It seems to be affecting my video card using the nv driver. Initial text console
seems to work, but when rhgb or X tries to start the system becomes unresponsive.

Moving back to the kernel-smp-2.6.12-1.1421_FC5 and I no longer see the error
message at boot and everything starts up as expected.

Please let me know if you need additional information or testing.
Comment 1 Jef Spaleta 2005-07-13 22:54:06 EDT
still getting the PCI allocate memory error with the 
kernel-smp-2.6.12-1.1426_FC5
kernel-smp-2.6.12-1.1432_FC5

I'm also experiencing hard system lockups with any of the smp kernels that
produce the  PCI allocate error on boot (builds 1422-432), but on reboot I'm not
seeing any messages in /var/log/messages that would indicate what has gone
wrong.  The nightly cronjobs seem to be setting off the hard lock condition but
I havent been able to narrow it down to a smoking gun process.  

I have no idea if the lock-ups are related to the boottime message about the PCI
allocation error but it is suspicious.  Considering the error message as
compared to my lspci output it definitely looks like a boot time problem
associated with the video card.  And no... im not using the nvidia driver, I'm
using the nv driver.

For the record here is my lspci output:

00:00.0 Host bridge: Advanced Micro Devices [AMD] AMD-760 MP [IGD4-2P] System
Controller (rev 11)
00:01.0 PCI bridge: Advanced Micro Devices [AMD] AMD-760 MP [IGD4-2P] AGP
Bridge00:07.0 ISA bridge: Advanced Micro Devices [AMD] AMD-766 [ViperPlus] ISA
(rev 02)
00:07.1 IDE interface: Advanced Micro Devices [AMD] AMD-766 [ViperPlus] IDE (rev 01)
00:07.3 Bridge: Advanced Micro Devices [AMD] AMD-766 [ViperPlus] ACPI (rev 01)
00:07.4 USB Controller: Advanced Micro Devices [AMD] AMD-766 [ViperPlus] USB
(rev 07)
00:0b.0 Multimedia audio controller: Creative Labs SB Live! EMU10k1 (rev 07)
00:0b.1 Input device controller: Creative Labs SB Live! MIDI/Game Port (rev 07)
00:0c.0 USB Controller: NEC Corporation USB (rev 43)
00:0c.1 USB Controller: NEC Corporation USB (rev 43)
00:0c.2 USB Controller: NEC Corporation USB 2.0 (rev 04)
00:0d.0 Ethernet controller: Lite-On Communications Inc LNE100TX (rev 20)
01:05.0 VGA compatible controller: nVidia Corporation NV34 [GeForce FX 5200]
(rev a1)

Again if there is any other information that you need, please let me know. 
Comment 2 Jef Spaleta 2005-08-26 08:03:11 EDT
Just fyi, I've been tracking pretty much every daily rawhide update and the PCI
error continues to happen with each subsequent rawhide kernel. Running
2.6.12-1.1505_FC5smp currently getting read to boot into 1509.  

-jef
Comment 3 Stefan Hoelldampf 2005-09-24 16:28:19 EDT
I'm getting a similar message on FC4 with kernel-2.6.13-1.1524_FC4 from
updates-testing on my Toshiba Satellite 3000-100:

PCI: Failed to allocate mem resource #6:10000@f8000000 for 0000:01:00.0

Neverthelesss, the system works fine up to now, both "nv" and the binary
"nvidia" driver are working.

Output of "lspci":
00:00.0 Host bridge: Intel Corporation 82815 815 Chipset Host Bridge and Memory
Controller Hub (rev 11)
00:01.0 PCI bridge: Intel Corporation 82815 815 Chipset AGP Bridge (rev 11)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev 03)
00:1f.0 ISA bridge: Intel Corporation 82801BAM ISA Bridge (LPC) (rev 03)
00:1f.1 IDE interface: Intel Corporation 82801BAM IDE U100 (rev 03)
00:1f.2 USB Controller: Intel Corporation 82801BA/BAM USB (Hub #1) (rev 03)
00:1f.3 SMBus: Intel Corporation 82801BA/BAM SMBus (rev 03)
00:1f.4 USB Controller: Intel Corporation 82801BA/BAM USB (Hub #2) (rev 03)
00:1f.5 Multimedia audio controller: Intel Corporation 82801BA/BAM AC'97 Audio
(rev 03)
00:1f.6 Modem: Intel Corporation 82801BA/BAM AC'97 Modem (rev 03)
01:00.0 VGA compatible controller: nVidia Corporation NV11 [GeForce2 Go] (rev b2)
02:00.0 CardBus bridge: Texas Instruments PCI1420
02:00.1 CardBus bridge: Texas Instruments PCI1420
02:07.0 Ethernet controller: Realtek Semiconductor Co., Ltd.
RTL-8139/8139C/8139C+ (rev 10)
02:0a.0 FireWire (IEEE 1394): Texas Instruments TSB43AB22/A IEEE-1394a-2000
Controller (PHY/Link)


Comment 4 Maurice Pijpers 2005-11-21 07:38:19 EST
I get a similar message on FC4 (2.6.14-1.1637) on a HP nw8240:

PCI: Cannot allocate resource region 7 of bridge 0000:00:1c.1
PCI: Cannot allocate resource region 8 of bridge 0000:00:1c.1
PCI: Cannot allocate resource region 9 of bridge 0000:00:1c.1

Systems hangs immediately when booting the kernel.
It works correctly on 2.6.11-1.1369, but all kernels after this (including
development kernels) are not working.
Comment 5 Maurice Pijpers 2005-11-21 07:40:50 EST
Created attachment 121296 [details]
lspci output for HP nw8240
Comment 6 Jef Spaleta 2006-03-17 11:22:05 EST
While I still don't understand the message text concerncing the PCI mem
allocation at bootup... my issues with my system hanging has been resolved.

I'm closing this out as the original reporter.  Anyone else experiencing system
lockups with fc5's kernel should refile. I don't think the PCI allocation
messages at bootup are related.

-jef

Note You need to log in before you can comment on or make changes to this bug.