Bug 162851 - Installer crashed after I took the core dump
Installer crashed after I took the core dump
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
Depends On:
  Show dependency treegraph
Reported: 2005-07-10 08:56 EDT by Oded
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-07-25 23:58:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Oded 2005-07-10 08:56:16 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET CLR 1.1.4322)

Description of problem:
Traceback (most recent call last):
  File "/usr/lib/anaconda/gui.py", line 873, in nextClicked
  File "/usr/lib/anaconda/dispatch.py", line 174, in gotoNext
  File "/usr/lib/anaconda/dispatch.py", line 242, in moveStep
    rc = apply(func, self.bindArgs(args))
  File "/usr/lib/anaconda/packages.py", line 158, in readPackages
    hdrlist = method.readHeaders()
  File "/usr/lib/anaconda/urlinstall.py", line 189, in readHeaders
    hdrString = raw[8:] + url.read(totalSize)
  File "/usr/lib/python2.4/site-packages/urlgrabber/keepalive.py", line 393, in read
    s = self._rbuf + self._raw_read(amt)
  File "/usr/lib/python2.4/httplib.py", line 456, in read
    return self._read_chunked(amt)
  File "/usr/lib/python2.4/httplib.py", line 495, in _read_chunked
    chunk_left = int(line, 16)
ValueError: invalid literal for int(): 

Local variables in innermost frame:
i: -1
self: <urlgrabber.keepalive.HTTPResponse instance at 0xb7a7004c>
chunk_left: None

Version-Release number of selected component (if applicable):

How reproducible:
Couldn't Reproduce

Steps to Reproduce:
I tried to install again but it worked in the second time

Additional info:
Comment 1 Oded 2005-07-10 08:58:26 EDT
It happend when I installed from the site 
After the step I entered root password twice.
Comment 2 Jeremy Katz 2005-07-12 11:14:03 EDT
So this wasn't reproducible?  This looks like an odd little network blip
confusing python.
Comment 3 Oded 2005-07-19 09:07:06 EDT
Could be. I had during the packages installation a network error and when I  
installed the packages again, it was OK.

Note You need to log in before you can comment on or make changes to this bug.