Bug 1628620 (glusterfs-5.0) - GlusterFS 5.0 tracker
Summary: GlusterFS 5.0 tracker
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: glusterfs-5.0
Product: GlusterFS
Classification: Community
Component: core
Version: 5
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
Depends On: 1628668 1630804 1636504 1639688
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-09-13 14:59 UTC by Shyamsundar
Modified: 2019-03-27 13:38 UTC (History)
3 users (show)

Fixed In Version: glusterfs-5.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-03-27 13:38:18 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Shyamsundar 2018-09-13 14:59:35 UTC
Tracker for the release 5.0

Comment 1 Worker Ant 2018-09-13 17:15:52 UTC
REVIEW: https://review.gluster.org/21173 (core: move logs which are only developer relevant to DEBUG level) posted (#1) for review on release-5 by Shyamsundar Ranganathan

Comment 2 Worker Ant 2018-09-13 18:07:08 UTC
REVIEW: https://review.gluster.org/21174 (core: remove experimental xlators and associated tests) posted (#1) for review on release-5 by Shyamsundar Ranganathan

Comment 3 Worker Ant 2018-09-13 21:23:41 UTC
REVIEW: https://review.gluster.org/21175 (gfapi: revert \"gfapi: return pre/post attributes at callback for glfs api\") posted (#1) for review on release-5 by Shyamsundar Ranganathan

Comment 4 Worker Ant 2018-09-14 02:18:27 UTC
REVIEW: https://review.gluster.org/21176 (gfapi: revert several patchs that introduced pre/post attrs) posted (#1) for review on release-5 by Shyamsundar Ranganathan

Comment 5 Worker Ant 2018-09-14 14:23:54 UTC
COMMIT: https://review.gluster.org/21173 committed in release-5 by "Shyamsundar Ranganathan" <srangana@redhat.com> with a commit message- core: move logs which are only developer relevant to DEBUG level

For each release, we move certain logs on master that are meant
as an indicator to contributors to correct or adapt to core
infrastructure changes in libglusterfs and other places.

This commit achieves the above.

Change-Id: I4157a7ec7d5ec9c2948b2bbc1e4cb8317f28d6b8
Updates: bz#1628620
Signed-off-by: ShyamsundarR <srangana@redhat.com>

Comment 6 Worker Ant 2018-09-17 14:26:34 UTC
COMMIT: https://review.gluster.org/21175 committed in release-5 by "Shyamsundar Ranganathan" <srangana@redhat.com> with a commit message- gfapi: revert "gfapi: return pre/post attributes at callback for glfs api"

This reverts commit 384562b294e9a7847403961e878a4daa0fff33eb.

The revert is done manually owing to the clang format changes,
and the 4.1 patch that reverts this fix is used as the source
for the revert.

The 4.1 patch has the commit ID: 98376e0c0a

Change-Id: Ib2cbce9940f6a2a2755eb47bf332832147835e4d
Updates: bz#1628620
Signed-off-by: ShyamsundarR <srangana@redhat.com>

Comment 7 Worker Ant 2018-09-17 14:26:56 UTC
COMMIT: https://review.gluster.org/21176 committed in release-5 by "Shyamsundar Ranganathan" <srangana@redhat.com> with a commit message- gfapi: revert several patchs that introduced pre/post attrs

Reverted the following:
  - 248152767b0599986bbb6bb35fc27197f6be6964
  - 09943beb499617212f2985ca8ea9ecd1ed1b470e
  - d01f7244e9d9f7e3ef84e0ba7b48ef1b1b09d809

The reverts are redone by hand, due to clang format changes
that made using git to revert the changes more tedious.

Change-Id: I96489638a2b641fb2206a110298543225783f7be
Updates: bz#1628620
Signed-off-by: ShyamsundarR <srangana@redhat.com>

Comment 8 Worker Ant 2018-09-17 19:29:58 UTC
COMMIT: https://review.gluster.org/21174 committed in release-5 by "Shyamsundar Ranganathan" <srangana@redhat.com> with a commit message- core: remove experimental xlators and associated tests

experimental xlators removed from 5.0

Change-Id: I47219d8b95efc3d5875ec9224d1e79f8371e9f76
Updates: bz#1628620
Signed-off-by: ShyamsundarR <srangana@redhat.com>

Comment 9 Worker Ant 2018-09-28 18:57:08 UTC
REVIEW: https://review.gluster.org/21303 (doc: Initial release notes for 5.0) posted (#1) for review on release-5 by Shyamsundar Ranganathan

Comment 10 Worker Ant 2018-10-05 16:38:38 UTC
COMMIT: https://review.gluster.org/21303 committed in release-5 by "Shyamsundar Ranganathan" <srangana@redhat.com> with a commit message- doc: Initial release notes for 5.0

Change-Id: Id2ed7e04fc7fe708a144ac09c69b837956aedb94
Updates: bz#1628620
Signed-off-by: ShyamsundarR <srangana@redhat.com>

Comment 11 Worker Ant 2018-10-15 18:01:36 UTC
REVIEW: https://review.gluster.org/21421 (doc: Update release 5.0 release notes) posted (#1) for review on release-5 by Shyamsundar Ranganathan

Comment 12 Kaleb KEITHLEY 2018-10-16 12:00:38 UTC
1639688 is not urgent, cant wait for 5.1

Comment 13 Kaleb KEITHLEY 2018-10-16 12:04:43 UTC
(In reply to Kaleb KEITHLEY from comment #12)
> 1639688 is not urgent, cant wait for 5.1

 _can_ wait for 5.1

Comment 14 Worker Ant 2018-10-18 14:10:43 UTC
COMMIT: https://review.gluster.org/21421 committed in release-5 by "Shyamsundar Ranganathan" <srangana@redhat.com> with a commit message- doc: Update release 5.0 release notes

- Added missing options
- Added bugs fixed

Change-Id: I3b788a093bc00fb977f792ce535ed50cc0cd9c9e
Updates: bz#1628620
Signed-off-by: ShyamsundarR <srangana@redhat.com>

Comment 15 Shyamsundar 2018-10-23 15:19:00 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-5.0, please open a new bug report.

glusterfs-5.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://lists.gluster.org/pipermail/announce/2018-October/000115.html
[2] https://www.gluster.org/pipermail/gluster-users/

Comment 16 Worker Ant 2019-01-16 15:00:02 UTC
REVIEW: https://review.gluster.org/22053 (core: move logs which are only developer relevant to DEBUG level) posted (#1) for review on master by Amar Tumballi

Comment 17 Worker Ant 2019-01-16 17:09:06 UTC
REVISION POSTED: https://review.gluster.org/22053 (core: move logs which are only developer relevant to DEBUG level) posted (#2) for review on master by Amar Tumballi


Note You need to log in before you can comment on or make changes to this bug.