Bug 162865 - unpredictable freezes in FC4 x86_64
unpredictable freezes in FC4 x86_64
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2005-07-10 15:55 EDT by Adam Goodman
Modified: 2015-01-04 17:20 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-08-26 04:52:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Adam Goodman 2005-07-10 15:55:00 EDT
Description of problem:

After installing the x86_64 version of FC4 (and FC3, for that matter) on my
computer, the system freezes unpredictably, though in most cases, it does not
take more than an hour for such a freeze to occur after the system is booted.
I've only had this occur when using X (but I don't generally spend much time in
the console); it does not, however, matter which video driver I use - this has
happened with the default 'radeon', ATI's proprietary drivers, and even the vesa
driver. When the system freezes, it freezes completely - I cannot switch to a
console, kill the X server, etc.

I tried to look in the logs in /var/log near the time of the freezes, but found
nothing, however, I might not know where to look.

Except when I tried to use ATI's drivers (fglrx), I was not using anything other
than what is included in FC4. 

This does not happen if I use the i686 version of either distribution.

My System:
Motherboard: Chaintech VNF3-250
CPU: Socket 754 Athlon 64 3200+
Video Card: Sapphire ATI Radeon 9600 XT
Audio: NForce3 onboard audio using snd-intel8x0 driver
Other Hardware: Leadtek Winfast 2000XP deluxe tv tuner card (uses bttv)

How reproducible:
I cannot reproduce this problem predictably, except that I've never run my
system for more than a few hours without this happening.

Additional info:
My symptoms seem to be identical to those reported in bug 161328, but they are
not caused by a proprietary video driver.
Comment 1 Dave Jones 2005-07-15 17:03:19 EDT
[This comment has been added as a mass update for all FC4 kernel bugs.
 If you have migrated this bug from an FC3 bug today, ignore this comment.]

Please retest your problem with todays 2.6.12-1.1398_FC4 update.

If your problem involved being unable to boot, or some hardware not being
detected correctly, please make sure your /etc/modprobe.conf is correct *BEFORE*
installing any kernel updates.
If in doubt, you can recreate this file using..

mv /etc/sysconfig/hwconf /etc/sysconfig/hwconf.bak
mv /etc/modprobe.conf /etc/modprobe.conf.bak

Thank you.
Comment 2 Dave Jones 2005-08-26 04:52:55 EDT
There's not a great deal of info to go on here unfortunatly, though given you've
tried various different drivers, it smells like a hardware problem.

I recommend reading http://www.livejournal.com/users/kernelslacker/16552.html

unless you manage to capture a kernel panic with a serial console, there's not a
lot I can do about this bug.

Note You need to log in before you can comment on or make changes to this bug.