Bug 1629431 - oc cluster up does not work on Fedora 29 - "timed out waiting for the condition"
Summary: oc cluster up does not work on Fedora 29 - "timed out waiting for the condition"
Status: CLOSED DUPLICATE of bug 1608505
Alias: None
Product: Fedora
Classification: Fedora
Component: systemd
Version: 29
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: systemd-maint
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-09-16 08:22 UTC by Elad Alfassa
Modified: 2018-09-17 06:20 UTC (History)
9 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2018-09-17 06:20:11 UTC


Attachments (Terms of Use)

Description Elad Alfassa 2018-09-16 08:22:43 UTC
Description of problem:
I'm getting an error when trying to use "oc cluster up" on Fedora 29

Version-Release number of selected component (if applicable):
origin-clients-3.10.0-2.fc29.x86_64

How reproducible:
100%

Steps to Reproduce:
1. run oc cluster up

Actual results:
Getting a Docker client ...
Checking if image openshift/origin-control-plane:v3.10 is available ...
Checking type of volume mount ...
Determining server IP ...
Checking if OpenShift is already running ...
Checking for supported Docker version (=>1.22) ...
Checking if insecured registry is configured properly in Docker ...
Checking if required ports are available ...
Checking if OpenShift client is configured properly ...
Checking if image openshift/origin-control-plane:v3.10 is available ...
Starting OpenShift using openshift/origin-control-plane:v3.10 ...
I0916 11:01:27.522511   27322 config.go:42] Running "create-master-config"
I0916 11:01:30.225067   27322 config.go:46] Running "create-node-config"
I0916 11:01:31.726962   27322 flags.go:30] Running "create-kubelet-flags"
I0916 11:01:32.286633   27322 run_kubelet.go:48] Running "start-kubelet"
I0916 11:01:32.480319   27322 run_self_hosted.go:172] Waiting for the kube-apiserver to be ready ...
E0916 11:06:32.482776   27322 run_self_hosted.go:542] API server error: Get https://127.0.0.1:8443/healthz?timeout=32s: dial tcp 127.0.0.1:8443: connect: connection refused ()
Error: timed out waiting for the condition


Expected results:
A working "oc cluster up" cluster.

Additional info:

Comment 1 Jakub Čajka 2018-09-17 06:20:11 UTC

*** This bug has been marked as a duplicate of bug 1608505 ***


Note You need to log in before you can comment on or make changes to this bug.