Bug 1629438 - The 2.0.40-2 release of munin packages on Aug 25th 2018 is broken.
Summary: The 2.0.40-2 release of munin packages on Aug 25th 2018 is broken.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: munin
Version: epel7
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Kim B. Heino
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-09-16 09:10 UTC by Jerome Steunenberg
Modified: 2018-10-16 15:27 UTC (History)
5 users (show)

Fixed In Version: munin-2.0.40-4.fc28 munin-2.0.40-4.fc29 munin-2.0.40-4.el6 munin-2.0.40-4.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-09-27 17:28:33 UTC


Attachments (Terms of Use)

Description Jerome Steunenberg 2018-09-16 09:10:32 UTC
Description of problem:
The 2.0.40-2 release of munin packages on Aug 25th 2018 seems to be broken.

* First problem: the update is a major update since it changes completely the list of packages (addition of munin-apache and munin-nginx, the config file is not anymore copied into /etc/httpd/conf.d, etc.) This is very problematic since all production servers that have Munin installed get this major change.

* Second problem: When installing on a vanilla EL7 with Apache, Munin does not start anymore and the error "Can't use an undefined value as an ARRAY reference at /usr/share/perl5/vendor_perl/Munin/Master/HTMLOld.pm line 695" appears. On a vanilla EL7 with nginx, it doesn't seem to work out of the box either.
EL6 seems to have the same update on the same date but we haven't tested whether it works.

Version-Release number of selected component (if applicable):
munin-node-2.0.40-2.el7.noarch
munin-common-2.0.40-2.el7.noarch
munin-apache-2.0.40-2.el7.noarch
munin-cgi-2.0.40-2.el7.noarch
munin-2.0.40-2.el7.noarch


How reproducible:
Fresh install on minimal EL7 with httpd

Steps to Reproduce:
1. Install minimal EL7
2. yum install httpd
3. yum install munin munin-node munin-apache munin-common
4. cp /usr/share/doc/munin-common-2.0.40/httpd_munin.conf /etc/httpd/conf.d/
5. create /etc/munin/conf.d/local.conf as described in httpd_munin.conf
5. systemctl restart httpd

Actual results:
* No config file in /etc/httpd/conf.d by default after install munin
* Web browser: Can't use an undefined value as an ARRAY reference at /usr/share/perl5/vendor_perl/Munin/Master/HTMLOld.pm line 695

Expected results:
Working Munin out of the box like it used to...

Additional info:
When upgrading munin, it seems that the config file is removed (very problematic for installations that have custom config in there)

Temporary solution:
# yum install yum-plugin-versionlock
# yum versionlock munin munin-node munin-common
But on fresh installs, EPEL does not have the 2.0.33 release anymore so there is no way to make it work.

Comment 1 Kim B. Heino 2018-09-17 10:44:16 UTC
1st:

Yes, this is major upgrade. Split to nginx and apache subpackages was needed to have better nginx support without requiring apache/httpd.

New munin-2.0.40-4 build will keep existing /etc/httpd/conf.d/munin.conf files as ghosts, so they are not removed on update. Upgrade path from 2.0.33 with apache should be simple "yum update" now.

2nd:

The error message is because there are no nodes configured and no history data available on vanilla EL7 after simple "yum install".

New 2.0.40-4 will again add [localhost] node to config, as did 2.0.33. But you must also start munin-node service and wait 5-10 minutes for data, as in 2.0.33 (do this after step 5).

Also, %doc example config files have improved comments and new httpd_cron_graphs.conf example is added. It's simpler to use than httpd_cgi_graphs.conf setup. (More discussion: https://github.com/munin-monitoring/munin/issues/1071)

Comment 2 Fedora Update System 2018-09-17 10:55:11 UTC
munin-2.0.40-4.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2018-673f52b139

Comment 3 Fedora Update System 2018-09-17 10:55:25 UTC
munin-2.0.40-4.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-6455129fce

Comment 4 Fedora Update System 2018-09-17 10:55:42 UTC
munin-2.0.40-4.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2018-39b27a8592

Comment 5 Fedora Update System 2018-09-17 10:55:55 UTC
munin-2.0.40-4.el6 has been submitted as an update to Fedora EPEL 6. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2018-bf0c049faf

Comment 6 marianne@tuxette.fr 2018-09-17 12:21:32 UTC
Hi, 
EPEL 6 is broken too. My munin server, who is installed since a long time has the web interface broken since last update to 2.0.40. 
I haven't been able to find a workaround yet.

Comment 7 Kim B. Heino 2018-09-17 13:24:34 UTC
See https://koji.fedoraproject.org/koji/buildinfo?buildID=1145189 and it's /usr/share/doc/munin-common-2.0.40/httpd_cron_graphs.conf or httpd_cgi_graphs.conf file.

Comment 8 Fedora Update System 2018-09-17 18:50:59 UTC
munin-2.0.40-4.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2018-673f52b139

Comment 9 Fedora Update System 2018-09-17 19:11:41 UTC
munin-2.0.40-4.el6 has been pushed to the Fedora EPEL 6 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2018-bf0c049faf

Comment 10 Fedora Update System 2018-09-17 19:24:34 UTC
munin-2.0.40-4.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-6455129fce

Comment 11 Fedora Update System 2018-09-18 06:16:48 UTC
munin-2.0.40-4.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-39b27a8592

Comment 12 Jerome Steunenberg 2018-09-26 08:49:41 UTC
Thank you Kim for the update. I've tested on a vanilla rhel7. It seems to be working out of the box again now with epel-testing.

But, there is no munin.conf file and you're putting the generated munin html files in /var/www/html/munin. This is how it used to work a long time ago. Since then we switched to an alias configuration in the web server which is imho a much cleaner solution, don't you think ? Why the change ? And why the need to split out the software into munin-apache if you're not maintaining an apache config file anyway ?

Thanks

Comment 13 Kim B. Heino 2018-09-26 14:09:00 UTC
Thanks for testing this.

As far as I see, previous Munin 2.0.33-1.el7 also did the same:

1) copy /etc/munin/static to /var/www/html/munin/static as part of munin-cron run, if they are missing (2.0.33 packaged them)
2) if in cron graph mode (default), generate html + png to /var/www/html/munin

Static files can be served from /etc (with alias) or from /var/www (without alias). Both files are identical. I prefer /etc too and actually nginx-example is using that. Munin would still copy those files internally, even if they are unused by web server. Removing copy is a change that upstream should do.

Munin 3.0 will change all that with new munin-httpd. It doesn't copy and graphs are always generated dynamically.

Splitting munin.rpm to munin-apache and munin-nginx was needed because those subpackages have conflicting files with different permissions.

Comment 14 Fedora Update System 2018-09-27 17:28:33 UTC
munin-2.0.40-4.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.

Comment 15 Fedora Update System 2018-09-27 18:00:58 UTC
munin-2.0.40-4.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.

Comment 16 Fedora Update System 2018-10-03 13:47:19 UTC
munin-2.0.40-4.el6 has been pushed to the Fedora EPEL 6 stable repository. If problems still persist, please make note of it in this bug report.

Comment 17 Fedora Update System 2018-10-03 14:27:17 UTC
munin-2.0.40-4.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.

Comment 18 Jerome Steunenberg 2018-10-16 09:58:53 UTC
Hello Kim,

There seems to be a problem with SELinux. I had to add the following policy to get the zoom working, whether in cron or cgi strategy:

module mymunin 1.0;

require {
        type munin_var_lib_t;
        type munin_script_t;
        class dir { add_name create remove_name write };
        class file { create setattr unlink write };
}

#============= munin_script_t ==============
allow munin_script_t munin_var_lib_t:dir { add_name create remove_name write };
allow munin_script_t munin_var_lib_t:file { create setattr unlink write };

Thanks

Comment 19 Kim B. Heino 2018-10-16 15:27:51 UTC
There are many SELinux problems in current RHEL Munin policy. See bug #1164245 for large patch.

Your policy seems to be already included to that patch. But thanks for it, it will help others to fix zoom until #1164245 is fixed.


Note You need to log in before you can comment on or make changes to this bug.