Bug 1629462 - CLI - [RHSA-2018:2384 bug] hammer content-view incremental update caused dependency problem on clients
Summary: CLI - [RHSA-2018:2384 bug] hammer content-view incremental update caused depe...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Content Views
Version: 6.3.2
Hardware: x86_64
OS: Linux
high
high vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Lai
URL:
Whiteboard:
: 1631906 (view as bug list)
Depends On: 1152515
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-09-16 15:05 UTC by Timur Daianov
Modified: 2020-05-01 14:14 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
satellite 6.3
Last Closed: 2020-05-01 14:14:49 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Timur Daianov 2018-09-16 15:05:00 UTC
Description of problem:
create sub version of CV with errata ... causing dependency issue
# hammer content-view version incremental-update --content-view-version-id 37 --errata-ids RHSA-2018:2384
Added Content:
  Errata:
        RHSA-2018:2384
  Packages:
        audit-libs-2.8.1-3.el7_5.1.i686
        audit-libs-2.8.1-3.el7_5.1.x86_64
        dracut-033-535.el7_5.1.x86_64
        initscripts-9.49.41-1.el7_5.1.x86_64
        kernel-3.10.0-862.11.6.el7.x86_64
        kernel-abi-whitelists-3.10.0-862.11.6.el7.noarch
        kernel-debug-3.10.0-862.11.6.el7.x86_64
        kernel-debug-devel-3.10.0-862.11.6.el7.x86_64
        kernel-devel-3.10.0-862.11.6.el7.x86_64
        kernel-doc-3.10.0-862.11.6.el7.noarch
        kernel-headers-3.10.0-862.11.6.el7.x86_64
        kernel-tools-3.10.0-862.11.6.el7.x86_64
        kernel-tools-libs-3.10.0-862.11.6.el7.x86_64
        kpartx-0.4.9-119.el7_5.1.x86_64
        libblkid-2.23.2-52.el7_5.1.x86_64
        libmount-2.23.2-52.el7_5.1.x86_64
        libuuid-2.23.2-52.el7_5.1.i686
        libuuid-2.23.2-52.el7_5.1.x86_64
        perf-3.10.0-862.11.6.el7.x86_64
        python-perf-3.10.0-862.11.6.el7.x86_64
        systemd-219-57.el7_5.1.x86_64
        systemd-libs-219-57.el7_5.1.i686
        systemd-libs-219-57.el7_5.1.x86_64
        util-linux-2.23.2-52.el7_5.1.x86_64
Version-Release number of selected component (if applicable):
see above

How reproducible:
- get satellite 6.3.x with content view updated BEFORE august 2018
- execute hammer to publish new sub version with errata
# hammer content-view version incremental-update --content-view-version-id 37 --errata-ids RHSA-2018:2384
- try to update systemd on any client from this CV

Actual results:
# yum update systemd
Loaded plugins: enabled_repos_upload, package_upload, product-id, search-disabled-
              : repos, subscription-manager
rhel-7-server-rpms                                            | 2.0 kB  00:00:00     
rhel-7-server-satellite-tools-6.3-puppet4-rpms                | 2.1 kB  00:00:00     
rhel-7-server-satellite-tools-6.3-rpms                        | 2.1 kB  00:00:00     
rhel-server-rhscl-7-rpms                                      | 2.0 kB  00:00:00     
(1/12): rhel-7-server-rpms/7Server/x86_64/group               | 553 kB  00:00:00     
(2/12): rhel-7-server-rpms/7Server/x86_64/updateinfo          | 2.8 MB  00:00:00     
(3/12): rhel-7-server-satellite-tools-6.3-puppet4-rpms/x86_64 | 2.0 kB  00:00:00     
(4/12): rhel-7-server-satellite-tools-6.3-puppet4-rpms/x86_64 |  515 B  00:00:00     
(5/12): rhel-7-server-satellite-tools-6.3-puppet4-rpms/x86_64 | 2.0 kB  00:00:00     
(6/12): rhel-7-server-satellite-tools-6.3-rpms/x86_64/group   | 1.1 kB  00:00:00     
(7/12): rhel-7-server-satellite-tools-6.3-rpms/x86_64/updatei | 8.1 kB  00:00:00     
(8/12): rhel-7-server-satellite-tools-6.3-rpms/x86_64/primary |  22 kB  00:00:00     
(9/12): rhel-server-rhscl-7-rpms/7Server/x86_64/group         |  147 B  00:00:00     
(10/12): rhel-server-rhscl-7-rpms/7Server/x86_64/updateinfo   | 899 kB  00:00:00     
(11/12): rhel-7-server-rpms/7Server/x86_64/primary            |  30 MB  00:00:02     
(12/12): rhel-server-rhscl-7-rpms/7Server/x86_64/primary      | 3.2 MB  00:00:00     
rhel-7-server-rpms                                                       20729/20729
rhel-7-server-satellite-tools-6.3-puppet4-rpms                                   1/1
rhel-7-server-satellite-tools-6.3-rpms                                         80/80
rhel-server-rhscl-7-rpms                                                 10401/10401
Resolving Dependencies
--> Running transaction check
---> Package systemd.x86_64 0:219-57.el7 will be updated
--> Processing Dependency: systemd = 219-57.el7 for package: systemd-sysv-219-57.el7.x86_64
---> Package systemd.x86_64 0:219-57.el7_5.1 will be an update
--> Processing Dependency: systemd-libs = 219-57.el7_5.1 for package: systemd-219-57.el7_5.1.x86_64
--> Running transaction check
---> Package systemd.x86_64 0:219-57.el7 will be updated
--> Processing Dependency: systemd = 219-57.el7 for package: systemd-sysv-219-57.el7.x86_64
---> Package systemd-libs.x86_64 0:219-57.el7 will be updated
--> Processing Dependency: systemd-libs = 219-57.el7 for package: libgudev1-219-57.el7.x86_64
---> Package systemd-libs.x86_64 0:219-57.el7_5.1 will be an update
--> Running transaction check
---> Package systemd.x86_64 0:219-57.el7 will be updated
--> Processing Dependency: systemd = 219-57.el7 for package: systemd-sysv-219-57.el7.x86_64
---> Package systemd-libs.i686 0:219-57.el7 will be installed
--> Processing Dependency: libselinux.so.1 for package: systemd-libs-219-57.el7.i686
--> Processing Dependency: librt.so.1(GLIBC_2.3.4) for package: systemd-libs-219-57.el7.i686
--> Processing Dependency: librt.so.1(GLIBC_2.2) for package: systemd-libs-219-57.el7.i686
--> Processing Dependency: librt.so.1 for package: systemd-libs-219-57.el7.i686
--> Processing Dependency: libresolv.so.2 for package: systemd-libs-219-57.el7.i686
--> Processing Dependency: libpthread.so.0(GLIBC_2.2) for package: systemd-libs-219-57.el7.i686
--> Processing Dependency: libpthread.so.0(GLIBC_2.0) for package: systemd-libs-219-57.el7.i686
--> Processing Dependency: libpthread.so.0 for package: systemd-libs-219-57.el7.i686
--> Processing Dependency: libpam_misc.so.0(LIBPAM_MISC_1.0) for package: systemd-libs-219-57.el7.i686
--> Processing Dependency: libpam_misc.so.0 for package: systemd-libs-219-57.el7.i686
--> Processing Dependency: libpam.so.0(LIBPAM_MODUTIL_1.0) for package: systemd-libs-219-57.el7.i686
--> Processing Dependency: libpam.so.0(LIBPAM_EXTENSION_1.0) for package: systemd-libs-219-57.el7.i686
--> Processing Dependency: libpam.so.0(LIBPAM_1.0) for package: systemd-libs-219-57.el7.i686
--> Processing Dependency: libpam.so.0 for package: systemd-libs-219-57.el7.i686
--> Processing Dependency: libm.so.6 for package: systemd-libs-219-57.el7.i686
--> Processing Dependency: liblzma.so.5(XZ_5.0) for package: systemd-libs-219-57.el7.i686
--> Processing Dependency: liblzma.so.5 for package: systemd-libs-219-57.el7.i686
--> Processing Dependency: liblz4.so.1 for package: systemd-libs-219-57.el7.i686
--> Processing Dependency: libgpg-error.so.0 for package: systemd-libs-219-57.el7.i686
--> Processing Dependency: libgcrypt.so.11(GCRYPT_1.2) for package: systemd-libs-219-57.el7.i686
--> Processing Dependency: libgcrypt.so.11 for package: systemd-libs-219-57.el7.i686
--> Processing Dependency: libgcc_s.so.1(GCC_3.3.1) for package: systemd-libs-219-57.el7.i686
--> Processing Dependency: libgcc_s.so.1(GCC_3.0) for package: systemd-libs-219-57.el7.i686
--> Processing Dependency: libgcc_s.so.1 for package: systemd-libs-219-57.el7.i686
--> Processing Dependency: libdw.so.1 for package: systemd-libs-219-57.el7.i686
--> Processing Dependency: libdl.so.2 for package: systemd-libs-219-57.el7.i686
--> Processing Dependency: libcap.so.2 for package: systemd-libs-219-57.el7.i686
--> Processing Dependency: libc.so.6(GLIBC_2.9) for package: systemd-libs-219-57.el7.i686
--> Processing Dependency: libc.so.6(GLIBC_2.8) for package: systemd-libs-219-57.el7.i686
--> Processing Dependency: libc.so.6(GLIBC_2.7) for package: systemd-libs-219-57.el7.i686
--> Processing Dependency: libc.so.6(GLIBC_2.4) for package: systemd-libs-219-57.el7.i686
--> Processing Dependency: libc.so.6(GLIBC_2.3.4) for package: systemd-libs-219-57.el7.i686
--> Processing Dependency: libc.so.6(GLIBC_2.3.3) for package: systemd-libs-219-57.el7.i686
--> Processing Dependency: libc.so.6(GLIBC_2.3.2) for package: systemd-libs-219-57.el7.i686
--> Processing Dependency: libc.so.6(GLIBC_2.3) for package: systemd-libs-219-57.el7.i686
--> Processing Dependency: libc.so.6(GLIBC_2.2.3) for package: systemd-libs-219-57.el7.i686
--> Processing Dependency: libc.so.6(GLIBC_2.2) for package: systemd-libs-219-57.el7.i686
--> Processing Dependency: libc.so.6(GLIBC_2.17) for package: systemd-libs-219-57.el7.i686
--> Processing Dependency: libc.so.6(GLIBC_2.16) for package: systemd-libs-219-57.el7.i686
--> Processing Dependency: libc.so.6(GLIBC_2.14) for package: systemd-libs-219-57.el7.i686
--> Processing Dependency: libc.so.6(GLIBC_2.1.3) for package: systemd-libs-219-57.el7.i686
--> Processing Dependency: libc.so.6(GLIBC_2.1.1) for package: systemd-libs-219-57.el7.i686
--> Processing Dependency: libc.so.6(GLIBC_2.1) for package: systemd-libs-219-57.el7.i686
--> Processing Dependency: libc.so.6(GLIBC_2.0) for package: systemd-libs-219-57.el7.i686
--> Processing Dependency: libc.so.6 for package: systemd-libs-219-57.el7.i686
--> Processing Dependency: ld-linux.so.2(GLIBC_2.3) for package: systemd-libs-219-57.el7.i686
--> Processing Dependency: ld-linux.so.2 for package: systemd-libs-219-57.el7.i686
---> Package systemd-libs.x86_64 0:219-57.el7 will be updated
--> Running transaction check
---> Package elfutils-libs.i686 0:0.170-4.el7 will be installed
--> Processing Dependency: elfutils-libelf(x86-32) = 0.170-4.el7 for package: elfutils-libs-0.170-4.el7.i686
--> Processing Dependency: libz.so.1(ZLIB_1.2.2.3) for package: elfutils-libs-0.170-4.el7.i686
--> Processing Dependency: libz.so.1 for package: elfutils-libs-0.170-4.el7.i686
--> Processing Dependency: libelf.so.1(ELFUTILS_1.7) for package: elfutils-libs-0.170-4.el7.i686
--> Processing Dependency: libelf.so.1(ELFUTILS_1.6) for package: elfutils-libs-0.170-4.el7.i686
--> Processing Dependency: libelf.so.1(ELFUTILS_1.5) for package: elfutils-libs-0.170-4.el7.i686
--> Processing Dependency: libelf.so.1(ELFUTILS_1.4) for package: elfutils-libs-0.170-4.el7.i686
--> Processing Dependency: libelf.so.1(ELFUTILS_1.3) for package: elfutils-libs-0.170-4.el7.i686
--> Processing Dependency: libelf.so.1(ELFUTILS_1.1.1) for package: elfutils-libs-0.170-4.el7.i686
--> Processing Dependency: libelf.so.1(ELFUTILS_1.0) for package: elfutils-libs-0.170-4.el7.i686
--> Processing Dependency: libelf.so.1 for package: elfutils-libs-0.170-4.el7.i686
--> Processing Dependency: libbz2.so.1 for package: elfutils-libs-0.170-4.el7.i686
---> Package glibc.i686 0:2.17-222.el7 will be installed
--> Processing Dependency: libfreebl3.so(NSSRAWHASH_3.12.3) for package: glibc-2.17-222.el7.i686
--> Processing Dependency: libfreebl3.so for package: glibc-2.17-222.el7.i686
---> Package libcap.i686 0:2.22-9.el7 will be installed
--> Processing Dependency: libattr.so.1(ATTR_1.0) for package: libcap-2.22-9.el7.i686
--> Processing Dependency: libattr.so.1 for package: libcap-2.22-9.el7.i686
---> Package libgcc.i686 0:4.8.5-28.el7_5.1 will be installed
---> Package libgcrypt.i686 0:1.5.3-14.el7 will be installed
---> Package libgpg-error.i686 0:1.12-3.el7 will be installed
---> Package libselinux.i686 0:2.5-12.el7 will be installed
--> Processing Dependency: libsepol(x86-32) >= 2.5-6 for package: libselinux-2.5-12.el7.i686
--> Processing Dependency: libsepol.so.1(LIBSEPOL_1.0) for package: libselinux-2.5-12.el7.i686
--> Processing Dependency: libsepol.so.1 for package: libselinux-2.5-12.el7.i686
--> Processing Dependency: libpcre.so.1 for package: libselinux-2.5-12.el7.i686
---> Package lz4.i686 0:1.7.5-2.el7 will be installed
---> Package pam.i686 0:1.1.8-22.el7 will be installed
--> Processing Dependency: libdb-5.3.so for package: pam-1.1.8-22.el7.i686
--> Processing Dependency: libcrack.so.2 for package: pam-1.1.8-22.el7.i686
--> Processing Dependency: libaudit.so.1 for package: pam-1.1.8-22.el7.i686
---> Package systemd.x86_64 0:219-57.el7 will be updated
--> Processing Dependency: systemd = 219-57.el7 for package: systemd-sysv-219-57.el7.x86_64
---> Package xz-libs.i686 0:5.2.2-1.el7 will be installed
--> Running transaction check
---> Package audit-libs.x86_64 0:2.8.1-3.el7 will be updated
--> Processing Dependency: audit-libs(x86-64) = 2.8.1-3.el7 for package: audit-2.8.1-3.el7.x86_64
---> Package audit-libs.i686 0:2.8.1-3.el7_5.1 will be installed
--> Processing Dependency: libcap-ng.so.0 for package: audit-libs-2.8.1-3.el7_5.1.i686
---> Package audit-libs.x86_64 0:2.8.1-3.el7_5.1 will be an update
---> Package bzip2-libs.i686 0:1.0.6-13.el7 will be installed
---> Package cracklib.i686 0:2.9.0-11.el7 will be installed
---> Package elfutils-libelf.i686 0:0.170-4.el7 will be installed
---> Package libattr.i686 0:2.4.46-13.el7 will be installed
---> Package libdb.i686 0:5.3.21-24.el7 will be installed
---> Package libsepol.i686 0:2.5-8.1.el7 will be installed
---> Package nss-softokn-freebl.i686 0:3.36.0-5.el7_5 will be installed
---> Package pcre.i686 0:8.32-17.el7 will be installed
--> Processing Dependency: libstdc++.so.6(GLIBCXX_3.4.9) for package: pcre-8.32-17.el7.i686
--> Processing Dependency: libstdc++.so.6(GLIBCXX_3.4) for package: pcre-8.32-17.el7.i686
--> Processing Dependency: libstdc++.so.6(CXXABI_1.3) for package: pcre-8.32-17.el7.i686
--> Processing Dependency: libstdc++.so.6 for package: pcre-8.32-17.el7.i686
---> Package systemd.x86_64 0:219-57.el7 will be updated
--> Processing Dependency: systemd = 219-57.el7 for package: systemd-sysv-219-57.el7.x86_64
---> Package zlib.i686 0:1.2.7-17.el7 will be installed
--> Running transaction check
---> Package audit-libs.x86_64 0:2.8.1-3.el7 will be updated
--> Processing Dependency: audit-libs(x86-64) = 2.8.1-3.el7 for package: audit-2.8.1-3.el7.x86_64
---> Package libcap-ng.i686 0:0.7.5-4.el7 will be installed
---> Package libstdc++.i686 0:4.8.5-28.el7_5.1 will be installed
---> Package systemd.x86_64 0:219-57.el7 will be updated
--> Processing Dependency: systemd = 219-57.el7 for package: systemd-sysv-219-57.el7.x86_64
--> Finished Dependency Resolution
Error: Package: audit-2.8.1-3.el7.x86_64 (@anaconda/7.5)
           Requires: audit-libs(x86-64) = 2.8.1-3.el7
           Removing: audit-libs-2.8.1-3.el7.x86_64 (@anaconda/7.5)
               audit-libs(x86-64) = 2.8.1-3.el7
           Updated By: audit-libs-2.8.1-3.el7_5.1.x86_64 (rhel-7-server-rpms)
               audit-libs(x86-64) = 2.8.1-3.el7_5.1
           Available: audit-libs-2.3.3-4.el7.x86_64 (rhel-7-server-rpms)
               audit-libs(x86-64) = 2.3.3-4.el7
           Available: audit-libs-2.4.1-5.el7.x86_64 (rhel-7-server-rpms)
               audit-libs(x86-64) = 2.4.1-5.el7
           Available: audit-libs-2.6.5-3.el7.x86_64 (rhel-7-server-rpms)
               audit-libs(x86-64) = 2.6.5-3.el7
           Available: audit-libs-2.6.5-3.el7_3.1.x86_64 (rhel-7-server-rpms)
               audit-libs(x86-64) = 2.6.5-3.el7_3.1
           Available: audit-libs-2.7.6-3.el7.x86_64 (rhel-7-server-rpms)
               audit-libs(x86-64) = 2.7.6-3.el7
Error: Package: systemd-sysv-219-57.el7.x86_64 (@anaconda/7.5)
           Requires: systemd = 219-57.el7
           Removing: systemd-219-57.el7.x86_64 (@anaconda/7.5)
               systemd = 219-57.el7
           Updated By: systemd-219-57.el7_5.1.x86_64 (rhel-7-server-rpms)
               systemd = 219-57.el7_5.1
           Available: systemd-208-11.el7.x86_64 (rhel-7-server-rpms)
               systemd = 208-11.el7
           Available: systemd-208-11.el7_0.2.x86_64 (rhel-7-server-rpms)
               systemd = 208-11.el7_0.2
           Available: systemd-208-11.el7_0.4.x86_64 (rhel-7-server-rpms)
               systemd = 208-11.el7_0.4
           Available: systemd-208-11.el7_0.5.x86_64 (rhel-7-server-rpms)
               systemd = 208-11.el7_0.5
           Available: systemd-208-11.el7_0.6.x86_64 (rhel-7-server-rpms)
               systemd = 208-11.el7_0.6
           Available: systemd-208-20.el7.x86_64 (rhel-7-server-rpms)
               systemd = 208-20.el7
           Available: systemd-208-20.el7_1.2.x86_64 (rhel-7-server-rpms)
               systemd = 208-20.el7_1.2
           Available: systemd-208-20.el7_1.3.x86_64 (rhel-7-server-rpms)
               systemd = 208-20.el7_1.3
           Available: systemd-208-20.el7_1.5.x86_64 (rhel-7-server-rpms)
               systemd = 208-20.el7_1.5
           Available: systemd-208-20.el7_1.6.x86_64 (rhel-7-server-rpms)
               systemd = 208-20.el7_1.6
           Available: systemd-219-19.el7.x86_64 (rhel-7-server-rpms)
               systemd = 219-19.el7
           Available: systemd-219-19.el7_2.4.x86_64 (rhel-7-server-rpms)
               systemd = 219-19.el7_2.4
           Available: systemd-219-19.el7_2.7.x86_64 (rhel-7-server-rpms)
               systemd = 219-19.el7_2.7
           Available: systemd-219-19.el7_2.9.x86_64 (rhel-7-server-rpms)
               systemd = 219-19.el7_2.9
           Available: systemd-219-19.el7_2.11.x86_64 (rhel-7-server-rpms)
               systemd = 219-19.el7_2.11
           Available: systemd-219-19.el7_2.12.x86_64 (rhel-7-server-rpms)
               systemd = 219-19.el7_2.12
           Available: systemd-219-19.el7_2.13.x86_64 (rhel-7-server-rpms)
               systemd = 219-19.el7_2.13
           Available: systemd-219-30.el7.x86_64 (rhel-7-server-rpms)
               systemd = 219-30.el7
           Available: systemd-219-30.el7_3.3.x86_64 (rhel-7-server-rpms)
               systemd = 219-30.el7_3.3
           Available: systemd-219-30.el7_3.6.x86_64 (rhel-7-server-rpms)
               systemd = 219-30.el7_3.6
           Available: systemd-219-30.el7_3.7.x86_64 (rhel-7-server-rpms)
               systemd = 219-30.el7_3.7
           Available: systemd-219-30.el7_3.8.x86_64 (rhel-7-server-rpms)
               systemd = 219-30.el7_3.8
           Available: systemd-219-30.el7_3.9.x86_64 (rhel-7-server-rpms)
               systemd = 219-30.el7_3.9
           Available: systemd-219-42.el7.x86_64 (rhel-7-server-rpms)
               systemd = 219-42.el7
           Available: systemd-219-42.el7_4.1.x86_64 (rhel-7-server-rpms)
               systemd = 219-42.el7_4.1
           Available: systemd-219-42.el7_4.4.x86_64 (rhel-7-server-rpms)
               systemd = 219-42.el7_4.4
           Available: systemd-219-42.el7_4.6.x86_64 (rhel-7-server-rpms)
               systemd = 219-42.el7_4.6
           Available: systemd-219-42.el7_4.7.x86_64 (rhel-7-server-rpms)
               systemd = 219-42.el7_4.7
           Available: systemd-219-42.el7_4.10.x86_64 (rhel-7-server-rpms)
               systemd = 219-42.el7_4.10
**********************************************************************
yum can be configured to try to resolve such errors by temporarily enabling
disabled repos and searching for missing dependencies.
To enable this functionality please set 'notify_only=0' in /etc/yum/pluginconf.d/search-disabled-repos.conf
**********************************************************************

Error: Package: audit-2.8.1-3.el7.x86_64 (@anaconda/7.5)
           Requires: audit-libs(x86-64) = 2.8.1-3.el7
           Removing: audit-libs-2.8.1-3.el7.x86_64 (@anaconda/7.5)
               audit-libs(x86-64) = 2.8.1-3.el7
           Updated By: audit-libs-2.8.1-3.el7_5.1.x86_64 (rhel-7-server-rpms)
               audit-libs(x86-64) = 2.8.1-3.el7_5.1
           Available: audit-libs-2.3.3-4.el7.x86_64 (rhel-7-server-rpms)
               audit-libs(x86-64) = 2.3.3-4.el7
           Available: audit-libs-2.4.1-5.el7.x86_64 (rhel-7-server-rpms)
               audit-libs(x86-64) = 2.4.1-5.el7
           Available: audit-libs-2.6.5-3.el7.x86_64 (rhel-7-server-rpms)
               audit-libs(x86-64) = 2.6.5-3.el7
           Available: audit-libs-2.6.5-3.el7_3.1.x86_64 (rhel-7-server-rpms)
               audit-libs(x86-64) = 2.6.5-3.el7_3.1
           Available: audit-libs-2.7.6-3.el7.x86_64 (rhel-7-server-rpms)
               audit-libs(x86-64) = 2.7.6-3.el7
Error: Package: systemd-sysv-219-57.el7.x86_64 (@anaconda/7.5)
           Requires: systemd = 219-57.el7
           Removing: systemd-219-57.el7.x86_64 (@anaconda/7.5)
               systemd = 219-57.el7
           Updated By: systemd-219-57.el7_5.1.x86_64 (rhel-7-server-rpms)
               systemd = 219-57.el7_5.1
           Available: systemd-208-11.el7.x86_64 (rhel-7-server-rpms)
               systemd = 208-11.el7
           Available: systemd-208-11.el7_0.2.x86_64 (rhel-7-server-rpms)
               systemd = 208-11.el7_0.2
           Available: systemd-208-11.el7_0.4.x86_64 (rhel-7-server-rpms)
               systemd = 208-11.el7_0.4
           Available: systemd-208-11.el7_0.5.x86_64 (rhel-7-server-rpms)
               systemd = 208-11.el7_0.5
           Available: systemd-208-11.el7_0.6.x86_64 (rhel-7-server-rpms)
               systemd = 208-11.el7_0.6
           Available: systemd-208-20.el7.x86_64 (rhel-7-server-rpms)
               systemd = 208-20.el7
           Available: systemd-208-20.el7_1.2.x86_64 (rhel-7-server-rpms)
               systemd = 208-20.el7_1.2
           Available: systemd-208-20.el7_1.3.x86_64 (rhel-7-server-rpms)
               systemd = 208-20.el7_1.3
           Available: systemd-208-20.el7_1.5.x86_64 (rhel-7-server-rpms)
               systemd = 208-20.el7_1.5
           Available: systemd-208-20.el7_1.6.x86_64 (rhel-7-server-rpms)
               systemd = 208-20.el7_1.6
           Available: systemd-219-19.el7.x86_64 (rhel-7-server-rpms)
               systemd = 219-19.el7
           Available: systemd-219-19.el7_2.4.x86_64 (rhel-7-server-rpms)
               systemd = 219-19.el7_2.4
           Available: systemd-219-19.el7_2.7.x86_64 (rhel-7-server-rpms)
               systemd = 219-19.el7_2.7
           Available: systemd-219-19.el7_2.9.x86_64 (rhel-7-server-rpms)
               systemd = 219-19.el7_2.9
           Available: systemd-219-19.el7_2.11.x86_64 (rhel-7-server-rpms)
               systemd = 219-19.el7_2.11
           Available: systemd-219-19.el7_2.12.x86_64 (rhel-7-server-rpms)
               systemd = 219-19.el7_2.12
           Available: systemd-219-19.el7_2.13.x86_64 (rhel-7-server-rpms)
               systemd = 219-19.el7_2.13
           Available: systemd-219-30.el7.x86_64 (rhel-7-server-rpms)
               systemd = 219-30.el7
           Available: systemd-219-30.el7_3.3.x86_64 (rhel-7-server-rpms)
               systemd = 219-30.el7_3.3
           Available: systemd-219-30.el7_3.6.x86_64 (rhel-7-server-rpms)
               systemd = 219-30.el7_3.6
           Available: systemd-219-30.el7_3.7.x86_64 (rhel-7-server-rpms)
               systemd = 219-30.el7_3.7
           Available: systemd-219-30.el7_3.8.x86_64 (rhel-7-server-rpms)
               systemd = 219-30.el7_3.8
           Available: systemd-219-30.el7_3.9.x86_64 (rhel-7-server-rpms)
               systemd = 219-30.el7_3.9
           Available: systemd-219-42.el7.x86_64 (rhel-7-server-rpms)
               systemd = 219-42.el7
           Available: systemd-219-42.el7_4.1.x86_64 (rhel-7-server-rpms)
               systemd = 219-42.el7_4.1
           Available: systemd-219-42.el7_4.4.x86_64 (rhel-7-server-rpms)
               systemd = 219-42.el7_4.4
           Available: systemd-219-42.el7_4.6.x86_64 (rhel-7-server-rpms)
               systemd = 219-42.el7_4.6
           Available: systemd-219-42.el7_4.7.x86_64 (rhel-7-server-rpms)
               systemd = 219-42.el7_4.7
           Available: systemd-219-42.el7_4.10.x86_64 (rhel-7-server-rpms)
               systemd = 219-42.el7_4.10
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
Uploading Enabled Repositories Report
Loaded plugins: product-id, subscription-manager


Expected results:
yum update should be completed without problems

Additional info:

incremental update do not honour systemd dependencies that results into a major problem.

Comment 1 Timur Daianov 2018-09-16 15:06:15 UTC
workaround would be to add some extra errata into list

hammer content-view version incremental-update --content-view-version-id 37 --errata-ids "RHSA-2018:2384","RHBA-2018:2447","RHBA-2018:2463","RHBA-2018:2442"

Comment 3 sthirugn@redhat.com 2019-03-20 16:21:55 UTC
*** Bug 1631906 has been marked as a duplicate of this bug. ***

Comment 4 Bryan Kearney 2020-05-01 14:14:49 UTC
Thank you for your interest in Satellite 6. We have evaluated this request, and while we recognize that it is a valid request, we do not expect this to be implemented in the product in the foreseeable future. This is due to other priorities for the product, and not a reflection on the request itself. We are therefore closing this out as WONTFIX. If you have any concerns about this, please do not reopen. Instead, feel free to contact Red Hat Technical Support. Thank you.


Note You need to log in before you can comment on or make changes to this bug.