Bug 1629561 - geo-rep: geo-rep config set fails to set rsync-options
Summary: geo-rep: geo-rep config set fails to set rsync-options
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: geo-replication
Version: mainline
Hardware: All
OS: Unspecified
high
medium
Target Milestone: ---
Assignee: Kotresh HR
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1630140 1630673
TreeView+ depends on / blocked
 
Reported: 2018-09-17 06:06 UTC by Kotresh HR
Modified: 2019-03-25 16:30 UTC (History)
1 user (show)

Fixed In Version: glusterfs-6.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1630140 1630673 (view as bug list)
Environment:
Last Closed: 2018-11-27 13:55:02 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Kotresh HR 2018-09-17 06:06:24 UTC
Description of problem:
geo-rep config fails to set rsync-options to "--ignore-missing-args"


Version-Release number of selected component (if applicable):
mainline

How reproducible:
Always

Steps to Reproduce:
1. Setup geo-rep between two gluster volumes and start
2. gluster vol set <master> <slavehost>::<slavevol> config rsync-options "--ignore-missing-args"

Actual results:
config set fails

Expected results:
config set should not fail

Additional info:

Comment 1 Worker Ant 2018-09-17 07:35:58 UTC
REVIEW: https://review.gluster.org/21191 (geo-rep: Fix issues related config set) posted (#1) for review on master by Kotresh HR

Comment 2 Worker Ant 2018-09-18 04:28:41 UTC
COMMIT: https://review.gluster.org/21191 committed in master by "Amar Tumballi" <amarts@redhat.com> with a commit message- geo-rep: Fix issues related config set

1. '--ignore-mising-args' option for rsync is not
   being used even though the rsync version is
   greater than 3.1.0. Fixed the same.

2. '--existing' option for rsync is also not being
   used. Fixed the same.

3. geo-rep config fails to set rsync-options as the
   value contains '--'. Interestingly, python argsparse
   treats the value with '--' (e.g., --ignore-missing-args)
   as option. But when passed with something like
   --value=--ignore-missing-args, it succeeds. Fixed the
   same.

Change-Id: Iaeb838acaff1c2920fee9c7f920c99edce13a0a1
Signed-off-by: Kotresh HR <khiremat@redhat.com>
fixes: bz#1629561

Comment 3 Shyamsundar 2019-03-25 16:30:43 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-6.0, please open a new bug report.

glusterfs-6.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://lists.gluster.org/pipermail/announce/2019-March/000120.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.