Bug 1630064 - python-mapnik: Remove (sub)packages from Fedora 30+: python2-mapnik
Summary: python-mapnik: Remove (sub)packages from Fedora 30+: python2-mapnik
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: python-mapnik
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Tom Hughes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: PY2REMOVAL 1630222
TreeView+ depends on / blocked
 
Reported: 2018-09-17 22:30 UTC by Miro Hrončok
Modified: 2018-09-18 08:33 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-09-17 23:42:30 UTC


Attachments (Terms of Use)

Description Miro Hrončok 2018-09-17 22:30:37 UTC
In line with the Mass Python 2 Package Removal [0], the following (sub)packages of python-mapnik were marked for removal:

 * python2-mapnik

According to our query, those (sub)packages only provide a Python 2 importable module. If this is not true, please tell us why, so we can fix our query.

Please remove them from your package.

As said in the change document, if there is no objection in a week, we will remove the package(s) as soon as we get to it. This change might not match your packaging style, so we'd prefer if you did the change. If you need more time, please let us know here.

We hope this doesn't come to you as a surprise. If you want to know our motivation for this, please read the change document [0].

[0] https://fedoraproject.org/wiki/Changes/Mass_Python_2_Package_Removal

Comment 1 Tom Hughes 2018-09-17 23:45:24 UTC
Should I be doing something to obsolete the python2 package?

The change seems to say no but surely that means people will have dozens of python2 packages installed that aren't being upgraded any more and will eventually start to break updates?

Comment 2 Zbigniew Jędrzejewski-Szmek 2018-09-18 04:55:15 UTC
The current answer is "no". See https://lists.fedoraproject.org/archives/list/python-devel@lists.fedoraproject.org/thread/TX5OLJIXJ5KHFRQXCF6M7J2XWRMYFXUY/ for a discussion about this.

Comment 3 Tom Hughes 2018-09-18 07:37:47 UTC
The problem is that python-mapnik is linked to boost so the next time boost updates anybody with python2-mapnik installed is going to find they can't update boost or anything that uses boost.

There are a number of other libraries it links to as well that could cause similar effects but boost is probably the one that changes soname most often.

I'm not sure what happens these days when doing an update to a new release using official technologies as I always do it with dnf - does it refuse to update? or just update and leave python2-mapnik broken?

Comment 4 Petr Viktorin 2018-09-18 08:33:05 UTC
I filed Bug #1630222 for the obsoleting and quoted the reason there.


Note You need to log in before you can comment on or make changes to this bug.