Bug 1630233 - Unable to unlock (or cancel) LUKS-encrypted USB drive or SD card in GNOME
Summary: Unable to unlock (or cancel) LUKS-encrypted USB drive or SD card in GNOME
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-shell
Version: 29
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Owen Taylor
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker
Depends On:
Blocks: F29FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2018-09-18 08:53 UTC by Axel Sommerfeldt
Modified: 2018-10-10 17:40 UTC (History)
12 users (show)

Fixed In Version: gnome-shell-3.30.1-1.fc29
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-10-10 17:40:38 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
GNOME Gitlab GNOME gnome-shell issues 565 None None None 2018-10-01 22:07:36 UTC

Description Axel Sommerfeldt 2018-09-18 08:53:33 UTC
Description of problem:
If a LUKS1-encrypted USB drive or SD card is inserted the known dialog pops up which asks for the passphrase. But neither pressing <Enter> (after passphrase was entered) nor clicking "Unlock" nor clicking "Cancel" has any effect here.

Version-Release number of selected component (if applicable):
GNOME Shell 3.30.0

How reproducible:
Boot the Beta 1.3 ISO (https://dl.fedoraproject.org/pub/alt/stage/29_Beta-1.3/Workstation/x86_64/iso/Fedora-Workstation-Live-x86_64-29_Beta-1.3.iso) and insert a LUKS1-encrypted USB stick or SD card.

Steps to Reproduce:
1. Boot Beta 1.3 Workstation Live ISO
2. Insert a LUKS1-encrypted USB stick or SD card
3. Try to press "Unlock" or "Cancel"

Actual results:
The dialog asking for the passphrase won't go away.

Expected results:
The dialog should go away when pressing "Unlock" or "Cancel".

Additional info:
This is a F29 Workstation installation on a non-UEFI laptop which is up-to-date; updates-testing is enabled. The same problem appears when booting the Beta 1.3 Workstation Live ISO from USB.

Comment 1 Axel Sommerfeldt 2018-09-21 07:37:56 UTC
The problem still exists when using Fedora 29 Beta 1.5.

Comment 2 spam 2018-09-23 11:56:55 UTC
The same problem in Arch Linux.
https://bbs.archlinux.org/viewtopic.php?pid=1809173#p1809173

Comment 3 JockeTF 2018-09-23 18:12:40 UTC
I'm seeing this issue on Arch Linux as well.

Comment 4 JockeTF 2018-09-23 18:48:16 UTC
The mounting succeeds when clicking unlock, by the way. It's just that there's no way to get rid of the dialog afterwards. It also only seems to happen with newly plugged in devices. Unlocking a device that has been plugged in for a while appears to work as expected.

Disabling extensions has no effect. I can't see any obvious error messages in the journal related to this, only messages about the successful unlocking and mounting. The messages below do appear when tracker-miner-fs is running, but after killing the process they both disappear. The behavior stays the same either way.

sep 23 19:55:14 pachacuti tracker-miner-f[1119]: Could not set mount point in database 'urn:nepomuk:datasource:XXX', GDBus.Error:org.freedesktop.Tracker1.SparqlError.Internal: UNIQUE constraint failed: nie:DataObject.nie:url
sep 23 19:55:14 pachacuti gnome-shell[12000]: Error from MountOpReply2(): GDBus.Error:org.gtk.Private.RemoteVolumeMonitor.NotFound: No outstanding mount operation

Comment 5 Satish Balay 2018-09-25 22:00:25 UTC
I'm seeing the same issue on F29 [upgraded from F28]

If I enable 'save passwd' in the check box - the next time I plug-in an external drive - it gets auto-mounted [ without this dialog box - i.e no frozen gnome-shell]

Currently with gnome-shell-3.30.0-7.fc29.x86_64

Comment 6 Adam Williamson 2018-10-01 22:06:57 UTC
This was reported upstream already:

https://gitlab.gnome.org/GNOME/gnome-shell/issues/565

I think we should at least consider this as a Final blocker, with reference to the criteria "All elements of the default panel (or equivalent) configuration in all release-blocking desktops must function correctly in typical use" and its footnote, and "All applications that can be launched using the standard graphical mechanism of a release-blocking desktop after a default installation of that desktop must start successfully and withstand a basic functionality test." It's arguable that 'desktop session gets irretrievably stuck if you attach an encrypted disk' violates at least the intent of those criteria.

Comment 7 Satish Balay 2018-10-01 22:14:15 UTC
(In reply to Satish Balay from comment #5)

> If I enable 'save passwd' in the check box - the next time I plug-in an
> external drive - it gets auto-mounted [ without this dialog box - i.e no
> frozen gnome-shell]

BTW: I don't know how to remove the saved passwd in the future (when this issue gets fixed). If anyone can point to the process or tool I should use to query/delete saved passwds - that would be great! Thanks!

Comment 8 Peter Robinson 2018-10-02 09:14:05 UTC
I'm seeing this, the only way I can get rid of the dialog box is to go to a text tty and login as the user and do "killall -HUP gnome-shell" which, when in Xorg mode doesn't kill the entire session.

Comment 9 Fedora Blocker Bugs Application 2018-10-02 09:17:37 UTC
Proposed as a Freeze Exception for 29-final by Fedora user pbrobinson using the blocker tracking app because:

 Encrypted removal media is completely unusable within Workstation and it locks up the session. Potentially SMB shares are also affected

Comment 10 JockeTF 2018-10-02 10:03:17 UTC
As a work-around, lock your desktop before plugging in the drive. Then wait for a bit to make sure everything has had the time to initialize. After that you can unlock the disk using GNOME Disks (or maybe even nautilus).

Comment 11 Ondrej Holy 2018-10-02 10:21:19 UTC
It is better to simply disable automounting as a workaround:
https://gitlab.gnome.org/GNOME/gnome-shell/issues/565#note_333297

Then you can use Nautilus, GNOME Disks, "gio mount -d [device]", cryptsetup...

Comment 12 František Zatloukal 2018-10-08 16:52:22 UTC
Discussed during the 2018-10-08 blocker review meeting: [1]

The decision to classify this bug as an AcceptedBlocker was made:

"Accepted as a blocker under the "default panel functionality" and "application basic functionality test" criteria, per comment #6"

[1] https://meetbot-raw.fedoraproject.org/fedora-blocker-review/2018-10-08/f29-blocker-review.2018-10-08-16.00.log.txt

Comment 13 Fedora Update System 2018-10-08 21:47:17 UTC
mutter-3.30.1-1.fc29 gnome-shell-extensions-3.30.1-1.fc29 gnome-shell-3.30.1-1.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2018-9e1f9f945d

Comment 14 Fedora Update System 2018-10-09 05:13:14 UTC
gnome-shell-3.30.1-1.fc29, gnome-shell-extensions-3.30.1-1.fc29, mutter-3.30.1-1.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-9e1f9f945d

Comment 15 Kamil Páral 2018-10-09 11:55:11 UTC
Can some of you who were affected by this please confirm whether this is now working fine with the updates mentioned above? Thanks.

Comment 16 Peter Robinson 2018-10-09 12:01:07 UTC
(In reply to Kamil Páral from comment #15)
> Can some of you who were affected by this please confirm whether this is now
> working fine with the updates mentioned above? Thanks.

I did, I confirmed it in the karma comment when I provided karma. It still needs to go stable though.

Comment 17 Kamil Páral 2018-10-09 13:04:41 UTC
Sorry, I forgot to check the Bodhi update comments. Marking as verified.

Comment 18 Satish Balay 2018-10-09 14:26:36 UTC
(In reply to Satish Balay from comment #7)

> BTW: I don't know how to remove the saved passwd in the future (when this
> issue gets fixed). If anyone can point to the process or tool I should use
> to query/delete saved passwds - that would be great! Thanks!

I figured this out. 
- Run 'Passwords and Keys' - aka 'seahorse'
- switch 'View' to 'Show Any'
- Now the saved passphrase for the USB disk shows up in the 'Login' section - so it can be deleted

Comment 19 Fedora Update System 2018-10-10 17:40:38 UTC
gnome-shell-3.30.1-1.fc29, gnome-shell-extensions-3.30.1-1.fc29, mutter-3.30.1-1.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.