Bug 1630243 - [RFE] Show live migration progress bar also in virtual machine tab in host page
Summary: [RFE] Show live migration progress bar also in virtual machine tab in host page
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 2.1.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ovirt-4.3.0
: 4.3.0
Assignee: Andrej Krejcir
QA Contact: Polina
URL:
Whiteboard: verified_upstream
Depends On:
Blocks: 1417161
TreeView+ depends on / blocked
 
Reported: 2018-09-18 09:03 UTC by Simone Tiraboschi
Modified: 2019-05-08 12:38 UTC (History)
10 users (show)

Fixed In Version: ovirt-engine-4.3.0_alpha
Doc Type: Enhancement
Doc Text:
During virtual machine live migration, the migration progress bar is now also shown in the host's Virtual Machine tab.
Clone Of:
Environment:
Last Closed: 2019-05-08 12:38:22 UTC
oVirt Team: Virt
Target Upstream Version:
mavital: testing_plan_complete-


Attachments (Terms of Use)
vm.png (122.63 KB, image/png)
2018-09-18 09:04 UTC, Simone Tiraboschi
no flags Details
host_vm.png (136.80 KB, image/png)
2018-09-18 09:05 UTC, Simone Tiraboschi
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2019:1085 0 None None None 2019-05-08 12:38:39 UTC
oVirt gerrit 94961 0 master MERGED webadmin: Rename VmStatusColumn class to VmStatusIconColumn 2020-08-27 12:48:44 UTC
oVirt gerrit 94962 0 master MERGED webadmin: Move VM status column to separate class and use it 2020-08-27 12:48:45 UTC

Description Simone Tiraboschi 2018-09-18 09:03:38 UTC
Description of problem:
In virtual machine page I can see a progress bar for live migration in the status column (see vm.png).
If instead I select a single host (migration source or target, not relevant) and open virtual machine tab in the status column I see just "Migrating from" till the end of the migration without any progress indicator (see host_vm.png).

Version-Release number of selected component (if applicable):
4.2.6.5-0.0.master.20180916153857.git759b52e.el7

How reproducible:
100%

Steps to Reproduce:
1. migrate a VM
2. check status column in virtual machine page
3. select one of the two involved hosts and select virtual machine tab from there; look at the status column

Actual results:
Status column in virtual machine page show a progress bar.
Status column in virtual machine tab for a specific host shows just "Migrating from" without any progress indication.

Expected results:
Consistent behaviour.

Additional info:

Comment 1 Simone Tiraboschi 2018-09-18 09:04:41 UTC
Created attachment 1484310 [details]
vm.png

Comment 2 Simone Tiraboschi 2018-09-18 09:05:07 UTC
Created attachment 1484311 [details]
host_vm.png

Comment 4 Marina Kalinin 2018-09-20 19:40:00 UTC
I am changing it to downstream bug to add customer case to it.
If you believe I should have cloned it instead, please let me know.

Comment 8 Polina 2018-11-18 08:30:01 UTC
Verified on ovirt-engine-4.3.0-0.0.master.20181115085433.git293d9a1.el7.noarch.
Progress Status bar appears in all screens:
 Compute/Virtual Machines
 Host source/Virtual Machines
 Host destination/Virtual Machines

Comment 9 Raz Tamir 2018-11-26 16:30:10 UTC
QE verification bot: the bug was verified upstream

Comment 10 RHV bug bot 2018-12-10 15:12:36 UTC
WARN: Bug status (VERIFIED) wasn't changed but the folowing should be fixed:

[Found non-acked flags: '{'rhevm-4.3-ga': '?'}', ]

For more info please contact: rhv-devops@redhat.comINFO: Bug status (VERIFIED) wasn't changed but the folowing should be fixed:

[Found non-acked flags: '{'rhevm-4.3-ga': '?'}', ]

For more info please contact: rhv-devops@redhat.com

Comment 11 RHV bug bot 2019-01-15 23:34:58 UTC
WARN: Bug status (VERIFIED) wasn't changed but the folowing should be fixed:

[Found non-acked flags: '{'rhevm-4.3-ga': '?'}', ]

For more info please contact: rhv-devops@redhat.comINFO: Bug status (VERIFIED) wasn't changed but the folowing should be fixed:

[Found non-acked flags: '{'rhevm-4.3-ga': '?'}', ]

For more info please contact: rhv-devops@redhat.com

Comment 13 errata-xmlrpc 2019-05-08 12:38:22 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2019:1085


Note You need to log in before you can comment on or make changes to this bug.