Bug 163030 - missing buildrequires vim vi emacs nano pico edit
missing buildrequires vim vi emacs nano pico edit
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: cvs (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Martin Stransky
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-12 08:18 EDT by Karsten Hopp
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-21 07:10:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karsten Hopp 2005-07-12 08:18:00 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; de-DE; rv:1.7.8) Gecko/20050623 Fedora/1.0.4-5 Firefox/1.0.4

Description of problem:
rpmbuild exits during rebuild of cvs-1.11.19-8 in a minimal chroot due to missing buildrequires:

checking for library containing gss_import_name... -lgssapi_krb5
checking for vim... no
checking for vi... no
checking for emacs... no
checking for nano... no
checking for pico... no
checking for edit... no
configure: error:
    Failed to find a text file editor.  CVS cannot be compiled
    without a default log message editor.  Searched for
    `vim vi emacs nano pico edit'.  Try `configure --with-editor'.
error: Bad exit status from /var/tmp/rpm-tmp.13888 (%build)


RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.13888 (%build)

Version-Release number of selected component (if applicable):
cvs-1.11.19-8

How reproducible:
Always

Steps to Reproduce:
1. install mock
2. run 'mock -r fedora-development-i386-core.cfg cvs-1.11.19-8.src.rpm'
3. check results
  

Additional info:
Comment 1 Mephisto 2005-08-24 07:58:34 EDT
I don't like the fix in 1.11.19-9 (adding vim to requires). When trying to
update cvs to 1.11.19-10 (from -8), i was forced to install vim-minimal,
however, i have no need for vim, and i rather keep this off my system. I prefer
joe as editor.
Why is it necessary to add vim to the requries of the binary package when it is
only required for rebuilding the src rpm?
Comment 2 Martin Stransky 2005-08-24 08:59:32 EDT
For example, it's used for the commit command when you don't specify a comment
by -m switch. But I agree with you, it's bit ugly.

Note You need to log in before you can comment on or make changes to this bug.