Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 1630539 - Provide the Oracle ASMlib kernel module compiled for retpoline on 6.10
Provide the Oracle ASMlib kernel module compiled for retpoline on 6.10
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: Driver Update Disk (Show other bugs)
6.10
x86_64 Linux
urgent Severity high
: rc
: ---
Assigned To: Eugene Syromiatnikov
Ziqian SUN (Zamir)
:
: 1630538 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2018-09-18 17:54 EDT by Joshua Baker
Modified: 2018-10-10 12:46 EDT (History)
6 users (show)

See Also:
Fixed In Version: oracleasm-2.0.8-16.el6_10
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-10-10 12:46:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2018:2903 None None None 2018-10-10 12:46 EDT

  None (edit)
Description Joshua Baker 2018-09-18 17:54:26 EDT
Description of problem:
Customer get's this message:

Sep 17 13:50:48 localhost kernel: Spectre V2 : WARNING: module 'oracleasm' built without retpoline-enabled compiler, may affect Spectre v2 mitigation

Version-Release number of selected component (if applicable):
kmod-oracleasm-2.0.8-15.el6_9.x86_64

How reproducible:
Install the above module on a retpoline installed kernel

Some notes on previous kmod-oracleasm updates:

Some customers require the Oracle ASMlib kernel module ("oracleasm"). Oracle has indicated that, although they provide this module for earlier RHEL releases, they will not do this for RHEL 6. 

The module is open source, and available in several locations on the Internet. We plan to ship it as a kmod, separate from the kernel package, in the Supplementary channel. This is done to make it clear that Red Hat provides only limited support. x86_64 only. 

The kernel module uses some symbols that are not on the whitelist. As a result, it will be advisable to re-build the module for each y-stream release, and then manually check to ensure that there are no relevant kernel symbol changes during the z-stream. 

The ASMlib kmod rpm package will be marked as dependent on the y-stream GA kernel version (and any subsequent z-stream kernels).  This will ensure that either both the kernel and ASMlib module are upgraded, or both are not upgraded, or the kernel is upgraded and asmlib uninstalled.
Comment 1 Ziqian SUN (Zamir) 2018-09-18 21:27:53 EDT
*** Bug 1630538 has been marked as a duplicate of this bug. ***
Comment 2 Eugene Syromiatnikov 2018-09-19 03:27:18 EDT
Scratch build:
https://brewweb.engineering.redhat.com/brew/taskinfo?taskID=18394276
Comment 3 Ziqian SUN (Zamir) 2018-09-19 06:11:50 EDT
(In reply to Eugene Syromiatnikov from comment #2)
> Scratch build:
> https://brewweb.engineering.redhat.com/brew/taskinfo?taskID=18394276

The scratch build FAILED as it requires kernel < 2.6.32-697.el6. And the distro kernel for RHEL 6.10 is 2.6.32-754.el6.x86_64.
Comment 4 Eugene Syromiatnikov 2018-09-19 07:17:19 EDT
(In reply to Ziqian SUN (Zamir) from comment #3)
> (In reply to Eugene Syromiatnikov from comment #2)
> > Scratch build:
> > https://brewweb.engineering.redhat.com/brew/taskinfo?taskID=18394276
> 
> The scratch build FAILED as it requires kernel < 2.6.32-697.el6. And the
> distro kernel for RHEL 6.10 is 2.6.32-754.el6.x86_64.

Uhh, my bad, sorry. Another try:
https://brewweb.engineering.redhat.com/brew/taskinfo?taskID=18399164
Comment 18 errata-xmlrpc 2018-10-10 12:46:34 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2903

Note You need to log in before you can comment on or make changes to this bug.