Bug 163061 - mc sometimes hangs in ssh terminal
mc sometimes hangs in ssh terminal
Status: CLOSED DUPLICATE of bug 168076
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: mc (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jindrich Novy
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-12 13:41 EDT by Milan Kerslager
Modified: 2015-01-07 19:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-11 06:48:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Milan Kerslager 2005-07-12 13:41:10 EDT
mc sometimes hangs in ssh window. I have to restart gdm to be able to start mc
again. I'll post strace output next time but IIRC there was a select hanging
around. I'm not sure if it is related to the fact I was trying to start mc
inside a screen session.
Comment 1 Jindrich Novy 2005-07-13 12:13:29 EDT
Milan, I'm aware of no mc problems in a screen session. Could you please add
here some test case that surely hangs in a terminal with ssh connection? The
description you presented won't help me much at least to find a reason for that
hang. Please give me a hint how to reproduce it in points as suggested by
bugzilla. This will help me to find the reason/fix for it.
Comment 2 Jindrich Novy 2005-08-01 04:50:01 EDT
Closing because of invalid bugreport.

Please reopen it with proper test case if you need it fixed.
Comment 3 Milan Kerslager 2005-11-04 06:38:07 EST
Seems to not be related to the screen app. I experienced the problem again 
here. After the prevoius experience with the hang I recompiled 4.6.1-3.FC3 in 
the RHEL4 environment so be able to check it on the latest version.

Strace output (it does nothing so I breaked strace after some time):

$ strace -p 19513
Process 19513 attached - interrupt to quit
connect(8, {sa_family=AF_FILE, path="/dev/gpmctl"}, 13 <unfinished ...>
Process 19513 detached

As at the original report, after the gpm restart, the mc continued. The machine 
has PS/2 mouse, X on the terminal (no one logged on and a few other users 
logged in via ssh [about 10 or 20], all others was able to run mc except me so 
it sounds like mc has been blocked by some reason by gdm or so).
Comment 4 Jindrich Novy 2005-11-04 08:48:50 EST
Thanks for the investigation, this problem is likely caused by gpm daemon
running on your system as mc doesn't access /dev/gpmctl directly but via gpm
calls at least. The solution is to reassign this bug to gpm or a workaround is
to disable the gpm service at all. Note that the console mouse support in mc
works perfectly even without the gpm daemon running.

If the workaround here is not sufficient for you, please reassign to gpm.

Jindrich
Comment 5 Milan Kerslager 2005-11-11 06:48:19 EST
Maybe there is a possibility to disable gpm at all in RPM specfile on FC when mc
is able to utilize mouse without gpm...???

*** This bug has been marked as a duplicate of 168076 ***

Note You need to log in before you can comment on or make changes to this bug.