Bug 1630672 - F29/rawhide rpcbind needs --enable-rmtcalls
Summary: F29/rawhide rpcbind needs --enable-rmtcalls
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: rpcbind
Version: 29
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Steve Dickson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-09-19 04:01 UTC by Ed Marshall
Modified: 2019-10-04 21:56 UTC (History)
4 users (show)

Fixed In Version: rpcbind-1.2.5-2.fc29, rpcbind-1.2.5-4.fc30, rpcbind-1.2.5-5.fc31 rpcbind-1.2.5-4.fc30 rpcbind-1.2.5-2.fc29
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-09-21 00:03:00 UTC


Attachments (Terms of Use)
add --enable-rmtcalls configure option (316 bytes, patch)
2018-09-19 04:01 UTC, Ed Marshall
no flags Details | Diff

Description Ed Marshall 2018-09-19 04:01:25 UTC
Created attachment 1484568 [details]
add --enable-rmtcalls configure option

Description of problem:
rpcbind 0.2.4 (on F28) supported broadcast discovery of rpc services. As of 1.2.5, however, an additional configure-time option (--enable-rmtcalls) is required to permit rpcbind to respond.

Services such as Kodi (via libnfs) use this functionality to discover available NFS shares on the network.

Version-Release number of selected component (if applicable):
rpcbind-0.2.4-10.rc3.fc28.x86_64

How reproducible:
Every time

Steps to Reproduce:
1. dnf install rpcbind nfs-utils
2. systemctl enable rpcbind.socket
3. systemctl enable nfs-server.service
4. systemctl start nfs-server.service
5. rpcinfo -b 100005 2

Actual results:
rpcinfo shows no output

Expected results:
rpcinfo shows output for the discovered service

Comment 1 Steve Dickson 2018-09-20 21:41:49 UTC
Just curious... what is a "Kodia" service and what is "libnfs" ?

Comment 2 Ed Marshall 2018-09-20 22:59:22 UTC
"Kodi" is a media player platform that, among many other things, uses RPC and NFS to browser for shares on the local network and mount them. See https://kodi.tv/ (it is not currently packaged for Fedora, but is available in third-party repositories, and is easy enough to install via virtualenv).

The implementation they use under the hood to accomplish this is provided by "libnfs", which is a userspace implementation of the various NFS and portmapper protocols, mostly client-focused. See https://github.com/sahlberg/libnfs/ for more details, or https://src.fedoraproject.org/rpms/libnfs in Fedora.

An important point, though, is that none of that actually matters; you can reproduce the problem with just rpcinfo (or, any client that broadcasts looking for portmapper-based services). Without --enable-rmtcalls (which was effectively the default in previous releases), rpcbind won't respond to broadcasts, and thus exports are not discoverable in this manner.

Comment 3 Ed Marshall 2018-09-20 23:00:20 UTC
(As an unrelated side note, you might know of Kodi from it's old project name, "XBMC".)

Comment 4 Herbert Xu 2019-08-23 07:02:18 UTC
Hi Steve:

Just to chime in here: this also breaks NIS completely as NIS clients rely on broadcasts to find the NIS server.  So if you could revert this change that would be greatly appreciated.  Thanks!

Comment 5 Steve Dickson 2019-08-26 14:29:38 UTC
(In reply to Herbert Xu from comment #4)
> Hi Steve:
> 
> Just to chime in here: this also breaks NIS completely as NIS clients rely
> on broadcasts to find the NIS server.  So if you could revert this change
> that would be greatly appreciated.  Thanks!

Yeah... I did know this but there are other ways of defining
NIS servers... 

Maybe I'll make the change in Fedora only... Since it was the
enterprise people complaining about rpc.bind listening
on rouge ports.

Comment 6 Herbert Xu 2019-08-27 02:56:22 UTC
(In reply to Steve Dickson from comment #5)
>
> Maybe I'll make the change in Fedora only... Since it was the
> enterprise people complaining about rpc.bind listening
> on rouge ports.

How about a run-time option instead of a build-time option?

Thanks,

Comment 7 Markus Bonet 2019-09-09 07:27:53 UTC
I support the idea to add at least a run-time option. Is this feasable?

Comment 8 Steve Dickson 2019-09-19 18:36:31 UTC
(In reply to Markus Bonet from comment #7)
> I support the idea to add at least a run-time option. Is this feasable?

I really don't want to add a  new command flags at this point... 
I'll rather leave it up to each distro to decide whether
to enable it or not...

Comment 9 Fedora Update System 2019-09-19 18:42:52 UTC
FEDORA-2019-47c152654c has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-47c152654c

Comment 10 Fedora Update System 2019-09-19 18:42:56 UTC
FEDORA-2019-b78b90ca5c has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2019-b78b90ca5c

Comment 11 Fedora Update System 2019-09-20 01:57:08 UTC
rpcbind-1.2.5-4.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-47c152654c

Comment 12 Fedora Update System 2019-09-20 02:57:07 UTC
rpcbind-1.2.5-5.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-b78b90ca5c

Comment 13 Fedora Update System 2019-09-20 03:02:11 UTC
rpcbind-1.2.5-2.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-829fa80e83

Comment 14 Fedora Update System 2019-09-21 00:03:00 UTC
rpcbind-1.2.5-5.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.

Comment 15 Fedora Update System 2019-09-25 01:07:45 UTC
rpcbind-1.2.5-4.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.

Comment 16 Fedora Update System 2019-10-04 21:56:35 UTC
rpcbind-1.2.5-2.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.